summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-16 13:34:46 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-16 13:34:46 +0000
commit514277da307d22e02f044ba387b41834a9d126d8 (patch)
treee7367a2f8874ff3d3e2693b01da9b13175b9f588
parentRemove debug flag from build, bug #408483 (diff)
downloadgentoo-2-514277da307d22e02f044ba387b41834a9d126d8.tar.gz
gentoo-2-514277da307d22e02f044ba387b41834a9d126d8.tar.bz2
gentoo-2-514277da307d22e02f044ba387b41834a9d126d8.zip
Version bump by kensingtion <gentoo@scribeofthenile.com> wrt bug #408361.
(Portage version: 2.2.0_alpha90/cvs/Linux i686)
-rw-r--r--app-backup/luckybackup/ChangeLog7
-rw-r--r--app-backup/luckybackup/luckybackup-0.4.7.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-backup/luckybackup/ChangeLog b/app-backup/luckybackup/ChangeLog
index 896ac2160c4c..9f83c5a41fe7 100644
--- a/app-backup/luckybackup/ChangeLog
+++ b/app-backup/luckybackup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/luckybackup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/luckybackup/ChangeLog,v 1.16 2012/01/28 23:33:30 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/luckybackup/ChangeLog,v 1.17 2012/03/16 13:34:46 johu Exp $
+
+*luckybackup-0.4.7 (16 Mar 2012)
+
+ 16 Mar 2012; Johannes Huber <johu@gentoo.org> +luckybackup-0.4.7.ebuild:
+ Version bump by kensingtion <gentoo@scribeofthenile.com> wrt bug #408361.
28 Jan 2012; Johannes Huber <johu@gentoo.org> -luckybackup-0.4.0.ebuild:
Remove old.
diff --git a/app-backup/luckybackup/luckybackup-0.4.7.ebuild b/app-backup/luckybackup/luckybackup-0.4.7.ebuild
new file mode 100644
index 000000000000..65f5b0196fd6
--- /dev/null
+++ b/app-backup/luckybackup/luckybackup-0.4.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/luckybackup/luckybackup-0.4.7.ebuild,v 1.1 2012/03/16 13:34:46 johu Exp $
+
+EAPI=4
+inherit qt4-r2
+
+DESCRIPTION="Powerful and flexible backup (and syncing) tool, using RSync and Qt4"
+HOMEPAGE="http://luckybackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+DOCSDIR="${S}/readme"
+DOCS="AUTHORS changelog README TODO TRANSLATIONS"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:g" \
+ -e "s:/usr/share/doc/packages/${PN}:/usr/share/doc/${PF}:g" \
+ luckybackup.pro src/global.h || die "sed failed"
+
+ # causes empty directory to be installed
+ sed -i -e '/^INSTALLS/s/debianmenu //' luckybackup.pro \
+ || die "sed installs failed"
+
+ # remove text version - cannot remote HTML version
+ # as it's used within the application
+ rm license/gpl.txt || die "rm failed"
+}