summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-12-05 03:25:14 +0000
committerBen de Groot <yngwin@gentoo.org>2012-12-05 03:25:14 +0000
commit51374dc5229234ce48ab5feeb0e64d254ab95008 (patch)
tree016ea40672d00cb482854691379b0585e4562191
parentQt 4.8.4 version bump (diff)
downloadgentoo-2-51374dc5229234ce48ab5feeb0e64d254ab95008.tar.gz
gentoo-2-51374dc5229234ce48ab5feeb0e64d254ab95008.tar.bz2
gentoo-2-51374dc5229234ce48ab5feeb0e64d254ab95008.zip
Qt 4.8.4 version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--x11-libs/qt-phonon/ChangeLog7
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.8.4.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index 5ac6103d2d0e..0287d19801bb 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-phonon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.127 2012/09/16 04:35:50 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.128 2012/12/05 03:25:14 yngwin Exp $
+
+*qt-phonon-4.8.4 (05 Dec 2012)
+
+ 05 Dec 2012; Ben de Groot <yngwin@gentoo.org> +qt-phonon-4.8.4.ebuild:
+ Qt 4.8.4 version bump
16 Sep 2012; Ben de Groot <yngwin@gentoo.org> qt-phonon-4.8.3.ebuild:
Add overlay changes (c++0x useflag)
diff --git a/x11-libs/qt-phonon/qt-phonon-4.8.4.ebuild b/x11-libs/qt-phonon/qt-phonon-4.8.4.ebuild
new file mode 100644
index 000000000000..ddb622d89d66
--- /dev/null
+++ b/x11-libs/qt-phonon/qt-phonon-4.8.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.8.4.ebuild,v 1.1 2012/12/05 03:25:14 yngwin Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The Phonon module for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+IUSE="dbus qt3support"
+
+DEPEND="
+ ~x11-libs/qt-gui-${PV}[aqua=,debug=,qt3support=]
+ !kde-base/phonon-kde
+ !kde-base/phonon-xine
+ !media-libs/phonon
+ !media-sound/phonon
+ !aqua? ( media-libs/gstreamer:0.10
+ media-plugins/gst-plugins-meta:0.10 )
+ aqua? ( ~x11-libs/qt-opengl-${PV}[aqua,debug=,qt3support=] )
+ dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/phonon
+ src/plugins/phonon
+ tools/designer/src/plugins/phononwidgets"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include
+ src
+ tools"
+
+ QCONFIG_ADD="phonon"
+ QCONFIG_DEFINE="QT_PHONON
+ $(use !aqua && echo QT_GSTREAMER)"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ -phonon -phonon-backend -no-opengl -no-svg
+ $(qt_use dbus qdbus)
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+}