summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Cox <steel300@gentoo.org>2004-04-14 02:27:05 +0000
committerJason Cox <steel300@gentoo.org>2004-04-14 02:27:05 +0000
commit513333b2e182953d193abfec80b43ffe3d140953 (patch)
tree786414313547ccb30c82f8352bba575327d25eb8
parentVersion bump, closes #47712. Removed the nls comments, seems to be working no... (diff)
downloadgentoo-2-513333b2e182953d193abfec80b43ffe3d140953.tar.gz
gentoo-2-513333b2e182953d193abfec80b43ffe3d140953.tar.bz2
gentoo-2-513333b2e182953d193abfec80b43ffe3d140953.zip
Version Bump.
-rw-r--r--net-dialup/speedtouch/ChangeLog9
-rw-r--r--net-dialup/speedtouch/files/digest-speedtouch-1.21
-rw-r--r--net-dialup/speedtouch/speedtouch-1.2.ebuild72
3 files changed, 80 insertions, 2 deletions
diff --git a/net-dialup/speedtouch/ChangeLog b/net-dialup/speedtouch/ChangeLog
index da3c544cb54f..bbdd06e27d13 100644
--- a/net-dialup/speedtouch/ChangeLog
+++ b/net-dialup/speedtouch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/speedtouch
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/ChangeLog,v 1.13 2003/12/25 16:53:18 twp Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/ChangeLog,v 1.14 2004/04/14 02:27:05 steel300 Exp $
+
+*speedtouch-1.2 (13 Apr 2004)
+
+ 13 Apr 2004; <coxj@gentoo.org> speedtouch-1.2.ebuild:
+ Version bump.
25 Dec 2003; Tom Payne <twp@gentoo.org> speedtouch-1.2_beta3-r2.ebuild :
Install *.html correctly. Add MODEM_RUN_EXTRAOPTS to conf.d and init.d scripts.
diff --git a/net-dialup/speedtouch/files/digest-speedtouch-1.2 b/net-dialup/speedtouch/files/digest-speedtouch-1.2
new file mode 100644
index 000000000000..53029d6f1cb8
--- /dev/null
+++ b/net-dialup/speedtouch/files/digest-speedtouch-1.2
@@ -0,0 +1 @@
+MD5 fa55748175d14dcf8ebe22577df408b3 speedtouch-1.2.tar.bz2 188536
diff --git a/net-dialup/speedtouch/speedtouch-1.2.ebuild b/net-dialup/speedtouch/speedtouch-1.2.ebuild
new file mode 100644
index 000000000000..7196fffb4d8d
--- /dev/null
+++ b/net-dialup/speedtouch/speedtouch-1.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/speedtouch-1.2.ebuild,v 1.1 2004/04/14 02:27:05 steel300 Exp $
+
+inherit flag-o-matic
+filter-flags -mpowerpc-gfxopt -mpowerpc-gpopt
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="GPL Driver for the Alcatel Speedtouch USB under *nix"
+HOMEPAGE="http://speedtouch.sf.net/"
+SRC_URI="mirror://sourceforge/speedtouch/${MY_P}.tar.bz2"
+
+IUSE="static debug"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~hppa ~amd64"
+
+DEPEND=""
+RDEPEND=">=net-dialup/ppp-2.4.1"
+
+src_compile() {
+ use debug && myconf="--enable-debug"
+ use static && myconf="${myconf} --enable-static"
+
+ econf --enable-syslog \
+ ${myconf} || die "./configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall || die
+
+ # twp 2003-12-25 install *.html correctly
+ find ${D}/usr/share/doc/speedtouch/ -type f -name '*.html' | xargs dohtml
+ find ${D}/usr/share/doc/speedtouch/ -type f -name '*.html' | xargs rm
+ echo $(find ${D}/usr/share/doc/speedtouch/ -type f) | xargs dodoc
+ rm -rf ${D}/usr/share/doc/speedtouch/
+ dodoc AUTHORS COPYING ChangeLog INSTALL TODO VERSION
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/speedtouch.rc6 speedtouch
+
+ insinto /etc/conf.d ; newins ${FILESDIR}/speedtouch.confd speedtouch
+
+ insopts -m 600 ; insinto /etc/ppp/peers ; doins ${FILESDIR}/adsl.sample
+
+ dosbin doc-linux/adsl-conf-pppd
+}
+
+pkg_postinst() {
+ echo ""
+ ewarn "Make sure you have kernel support for USB, HDCL and PPP"
+ ewarn "NB: kernels >= 2.4.18 include the hdlc patch"
+ echo ""
+ ewarn "Read and subscribe vendor's licence to download the microcode"
+ ewarn "You can get it from: "
+ ewarn " 1) vendor's site: http://www.speedtouchdsl.com/dvrreg_lx.htm"
+ ewarn " 2) a windows system: c:\windows\system\alcaudsl.sys"
+ ewarn " 3) the CD provided: X:\Driver\alcaudsl.sys"
+ ewarn "Then you should set its path in the /etc/conf.d/speedtouch file"
+ ewarn "edit and rename 'adsl.sample' to 'adsl' in /etc/ppp/peers/adsl and"
+ ewarn "bring up your adsl line using the /etc/init.d/speedtouch script"
+ echo ""
+ einfo "More info in the documentation in /usr/share/doc/${P}"
+ echo ""
+ einfo "You need to pass -a /usr/share/speedtouch/boot.v123.bin to"
+ einfo "modem_run with this version. The URL for firmware is:"
+ einfo "http://www.speedtouchdsl.com/driver_upgrade_lx_3.0.1.2.htm"
+ echo ""
+}