summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-18 23:10:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-18 23:10:11 +0000
commit512ecde6f09b727e34e2f98234bd8ad3dd2fdb1e (patch)
tree8950f84478fd9424fd6279e5cfdc57c368ae944a
parentQA cleanups in ebuild, fixes bug 337978 (diff)
downloadgentoo-2-512ecde6f09b727e34e2f98234bd8ad3dd2fdb1e.tar.gz
gentoo-2-512ecde6f09b727e34e2f98234bd8ad3dd2fdb1e.tar.bz2
gentoo-2-512ecde6f09b727e34e2f98234bd8ad3dd2fdb1e.zip
Improve error messages.
(Portage version: 2.2_rc83_p41/cvs/Linux x86_64)
-rw-r--r--dev-python/logilab-common/logilab-common-0.51.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/logilab-common/logilab-common-0.51.1.ebuild b/dev-python/logilab-common/logilab-common-0.51.1.ebuild
index cf9b136a67f0..7f557a6733cf 100644
--- a/dev-python/logilab-common/logilab-common-0.51.1.ebuild
+++ b/dev-python/logilab-common/logilab-common-0.51.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.51.1.ebuild,v 1.1 2010/09/18 22:03:10 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.51.1.ebuild,v 1.2 2010/09/18 23:10:11 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -58,12 +58,12 @@ src_test() {
local tpath="${T}/test-${PYTHON_ABI}"
local spath="${tpath}$(python_get_sitedir)"
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${tpath}" || die "Installation for tests failed with Python ${PYTHON_ABI}"
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${tpath}" || die "Installation for tests failed with $(python_get_implementation) $(python_get_version)"
# pytest uses tests placed relatively to the current directory.
- pushd "${spath}" >/dev/null || die
+ pushd "${spath}" > /dev/null || return 1
PYTHONPATH="${spath}" "$(PYTHON)" "${tpath}/usr/bin/pytest" -v || return 1
- popd >/dev/null || die
+ popd > /dev/null || return 1
}
python_execute_function testing
}