summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-24 08:34:17 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-24 08:34:17 +0000
commit50786f72e5b038e58c854c8f864b0d70cd719616 (patch)
tree7470fa02dec555dd6e059188bf5a0631493a25e4
parentdisable libgomp for cross-compilers that cant support it #359855 by Andrei Sl... (diff)
downloadgentoo-2-50786f72e5b038e58c854c8f864b0d70cd719616.tar.gz
gentoo-2-50786f72e5b038e58c854c8f864b0d70cd719616.tar.bz2
gentoo-2-50786f72e5b038e58c854c8f864b0d70cd719616.zip
disable posix heads/tails fixing for newer gcc versions
-rw-r--r--eclass/toolchain.eclass15
1 files changed, 9 insertions, 6 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 7b9a44583d58..f546bb66b500 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.454 2011/03/24 08:30:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.455 2011/03/24 08:34:17 vapier Exp $
#
# Maintainer: Toolchain Ninjas <toolchain@gentoo.org>
@@ -1053,11 +1053,14 @@ gcc_src_unpack() {
fi
fi
- fix_files=""
- for x in contrib/test_summary libstdc++-v3/scripts/check_survey.in ; do
- [[ -e ${x} ]] && fix_files="${fix_files} ${x}"
- done
- ht_fix_file ${fix_files} */configure *.sh */Makefile.in
+ # No idea when this first started being fixed, but let's go with 4.3.x for now
+ if ! tc_version_is_at_least 4.3 ; then
+ fix_files=""
+ for x in contrib/test_summary libstdc++-v3/scripts/check_survey.in ; do
+ [[ -e ${x} ]] && fix_files="${fix_files} ${x}"
+ done
+ ht_fix_file ${fix_files} */configure *.sh */Makefile.in
+ fi
if ! is_crosscompile && is_multilib && [[ ${SYMLINK_LIB} == "yes" ]] && \
[[ ( $(tc-arch) == "amd64" || $(tc-arch) == "ppc64" ) && -z ${SKIP_MULTILIB_HACK} ]] ; then