summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-09-21 01:15:44 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-09-21 01:15:44 +0000
commit4f7e55041d4577487dac9e5ec5b3a007611181a1 (patch)
tree402fbb094dbba04509b40c59d9af82dd3315289d
parentnew experimental mailman ebuild (diff)
downloadgentoo-2-4f7e55041d4577487dac9e5ec5b3a007611181a1.tar.gz
gentoo-2-4f7e55041d4577487dac9e5ec5b3a007611181a1.tar.bz2
gentoo-2-4f7e55041d4577487dac9e5ec5b3a007611181a1.zip
Bump with many bugfixes.
(Portage version: 2.1.3.9)
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.1936
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.7.193.ebuild35
3 files changed, 48 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index a944c2685118..2ea98acd6946 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.51 2007/09/08 05:15:18 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.52 2007/09/21 01:15:43 dberkholz Exp $
+
+*xf86-video-ati-6.7.193 (21 Sep 2007)
+
+ 21 Sep 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xf86-video-ati-6.7.193.ebuild:
+ Bump with many bugfixes.
*xf86-video-ati-6.7.192 (08 Sep 2007)
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.193 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.193
new file mode 100644
index 000000000000..08758c76fbd8
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.193
@@ -0,0 +1,6 @@
+MD5 56566e8c3fb4bb99791d1788d0a9a1a8 x11-driver-patches-4.tar.bz2 346
+RMD160 fcbd405de080d07612d46f455b927035fd8123a8 x11-driver-patches-4.tar.bz2 346
+SHA256 07069bbd072f2def50e83801a8f2a41a4c96495104f15cd6f56f7df7f89769bf x11-driver-patches-4.tar.bz2 346
+MD5 316ebbe95834c5120c302cc004363f92 xf86-video-ati-6.7.193.tar.bz2 732848
+RMD160 a65d39fc0d906c585268b9089833d2e19eef321b xf86-video-ati-6.7.193.tar.bz2 732848
+SHA256 aa154bc22818baecfbd009ccf046a9eccfc789db95349439e754c76d6b35ed8a xf86-video-ati-6.7.193.tar.bz2 732848
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.193.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.193.ebuild
new file mode 100644
index 000000000000..da0625d2e75d
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.193.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.193.ebuild,v 1.1 2007/09/21 01:15:43 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+XDPVER=4
+
+inherit x-modular
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/glproto
+ x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}