summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2015-02-11 23:41:59 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2015-02-11 23:41:59 +0000
commit4e2a7fec8586774796ff70c8c6961628ba22b0cc (patch)
treed0b73fe1377fa9c53de444d5f35b91c421a7488f
parentKeyword ~ppc64, bug #459190. (diff)
downloadgentoo-2-4e2a7fec8586774796ff70c8c6961628ba22b0cc.tar.gz
gentoo-2-4e2a7fec8586774796ff70c8c6961628ba22b0cc.tar.bz2
gentoo-2-4e2a7fec8586774796ff70c8c6961628ba22b0cc.zip
version bump. bug #539468
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-vcs/fossil/ChangeLog10
-rw-r--r--dev-vcs/fossil/fossil-20150119112900.ebuild46
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-vcs/fossil/ChangeLog b/dev-vcs/fossil/ChangeLog
index e66a7bdaa893..a6f93acadc4b 100644
--- a/dev-vcs/fossil/ChangeLog
+++ b/dev-vcs/fossil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/fossil
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.21 2014/11/20 18:52:26 titanofold Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.22 2015/02/11 23:41:59 rafaelmartins Exp $
+
+*fossil-20150119112900 (11 Feb 2015)
+
+ 11 Feb 2015; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +fossil-20150119112900.ebuild:
+ version bump. bug #539468
*fossil-20140612172556 (20 Nov 2014)
diff --git a/dev-vcs/fossil/fossil-20150119112900.ebuild b/dev-vcs/fossil/fossil-20150119112900.ebuild
new file mode 100644
index 000000000000..58cc9b369a01
--- /dev/null
+++ b/dev-vcs/fossil/fossil-20150119112900.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20150119112900.ebuild,v 1.1 2015/02/11 23:41:59 rafaelmartins Exp $
+
+EAPI=5
+MY_P=${PN}-src-${PV}
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="json +lineedit sqlite +ssl tcl"
+
+DEPEND="sys-libs/zlib
+ lineedit? ( || ( sys-libs/readline:0 dev-libs/libedit ) )
+ ssl? ( dev-libs/openssl )
+ sqlite? ( dev-db/sqlite:3 )
+ tcl? ( dev-lang/tcl )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf='--with-zlib'
+
+ myconf+=" --lineedit=$(usex lineedit 1 0)"
+ myconf+=" --with-openssl=$(usex ssl auto none)"
+ use json && myconf+=' --json'
+ use sqlite && myconf+=' --disable-internal-sqlite'
+ use tcl && myconf+=' --with-tcl --with-tcl-stubs'
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}