summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-08-24 23:27:02 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-08-24 23:27:02 +0000
commit4e012529d52fa35e6d6ac7f18b352e2adc56e103 (patch)
tree954ab04d12ce841060eb7f6b2e015cf8f512047a
parentno more bots (diff)
downloadgentoo-2-4e012529d52fa35e6d6ac7f18b352e2adc56e103.tar.gz
gentoo-2-4e012529d52fa35e6d6ac7f18b352e2adc56e103.tar.bz2
gentoo-2-4e012529d52fa35e6d6ac7f18b352e2adc56e103.zip
added few configure flag improvements from #21071
-rw-r--r--dev-libs/hdf5/ChangeLog6
-rw-r--r--dev-libs/hdf5/Manifest4
-rw-r--r--dev-libs/hdf5/hdf5-1.6.0.ebuild10
3 files changed, 13 insertions, 7 deletions
diff --git a/dev-libs/hdf5/ChangeLog b/dev-libs/hdf5/ChangeLog
index bc4976241e57..d83ea15c83a8 100644
--- a/dev-libs/hdf5/ChangeLog
+++ b/dev-libs/hdf5/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-libs/hdf5
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf5/ChangeLog,v 1.2 2003/08/24 21:39:21 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf5/ChangeLog,v 1.3 2003/08/24 23:26:56 george Exp $
*hdf5-1.6.0 (24 Aug 2003)
24 Aug 2003; George Shapovalov <george@gentoo.org> hdf5-1.6.0.ebuild :
+ added few chenges from #21071, added ssl to IUSE
+ thanks to Donald Giuliano <guido@ou.edu> for some configure flags suggestions
+
+ 24 Aug 2003; George Shapovalov <george@gentoo.org> hdf5-1.6.0.ebuild :
new version (#25365),
this one installs examples, and of course in a wrong place :), had to fix location.
thanks to James Cloos <cloos@jhcloos.com> for notification
diff --git a/dev-libs/hdf5/Manifest b/dev-libs/hdf5/Manifest
index a4e1249fba83..c2ccc0ad3954 100644
--- a/dev-libs/hdf5/Manifest
+++ b/dev-libs/hdf5/Manifest
@@ -1,6 +1,6 @@
MD5 f051c05348d3fd8d34812837c993d44f hdf5-1.4.5.ebuild 1462
-MD5 2e7f447c15271fd3300bc1bc1e661d9f hdf5-1.6.0.ebuild 1441
-MD5 28edd1db28305a4392f824b7150fb7e6 ChangeLog 825
+MD5 ea6e9a808fd3800fa8a439567e316a6f hdf5-1.6.0.ebuild 1601
+MD5 6f878a3df46b89467c8c2604a5a2853e ChangeLog 1030
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 eb29b80216a0a85ed3dbe10cd7e9cb0f files/digest-hdf5-1.4.5 69
MD5 65fa18117e012e612d6e02d2964b857a files/digest-hdf5-1.6.0 63
diff --git a/dev-libs/hdf5/hdf5-1.6.0.ebuild b/dev-libs/hdf5/hdf5-1.6.0.ebuild
index 94008ee799a2..44ded8f1a1ec 100644
--- a/dev-libs/hdf5/hdf5-1.6.0.ebuild
+++ b/dev-libs/hdf5/hdf5-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf5/hdf5-1.6.0.ebuild,v 1.1 2003/08/24 21:39:21 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf5/hdf5-1.6.0.ebuild,v 1.2 2003/08/24 23:26:56 george Exp $
DESCRIPTION="HDF5 is a general purpose library and file format for storing scientific data."
SRC_URI="ftp://ftp.ncsa.uiuc.edu/HDF/HDF5/current/src/${P}.tar.gz"
@@ -9,7 +9,7 @@ HOMEPAGE="http://hdf.ncsa.uiuc.edu/HDF5/"
LICENSE="NCSA-HDF"
KEYWORDS="~x86"
SLOT="0"
-IUSE="static zlib"
+IUSE="static zlib ssl"
DEPEND="zlib? ( sys-libs/zlib )"
PROVIDE="dev-libs/hdf5"
@@ -17,8 +17,10 @@ PROVIDE="dev-libs/hdf5"
src_compile() {
local myconf
- use static || myconf="--disable-static"
+ #--disable-static conflicts with --enable-cxx, so we have to do either or
+ use static && myconf="--enable-cxx" || myconf="--disable-static"
use zlib || myconf="${myconf} --disable-zlib"
+ use ssl && myconf="${myconf} --with-ssl"
# NOTE: the hdf5 configure script has its own interpretation of
# the ARCH environment variable which conflicts with that of
@@ -27,7 +29,7 @@ src_compile() {
EBUILD_ARCH=${ARCH}
unset ARCH
- ./configure ${myconf} --enable-linux-lfs \
+ ./configure ${myconf} --enable-linux-lfs --with-gnu-ld \
--prefix=/usr \
--sysconfdir=/etc \
--infodir=/usr/share/info \