summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-07-02 22:04:11 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-07-02 22:04:11 +0000
commit4d2033445cf90736d00a296b5d550e2035eacf30 (patch)
tree1dab37279b548fde08fb5e254a52500719765076
parentstable amd64, security bug 326413 (diff)
downloadgentoo-2-4d2033445cf90736d00a296b5d550e2035eacf30.tar.gz
gentoo-2-4d2033445cf90736d00a296b5d550e2035eacf30.tar.bz2
gentoo-2-4d2033445cf90736d00a296b5d550e2035eacf30.zip
Version bump (bug #322315). Clean up ebuild and remove old.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-util/codeblocks/ChangeLog9
-rw-r--r--dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild59
-rw-r--r--dev-util/codeblocks/codeblocks-10.05.ebuild41
-rw-r--r--dev-util/codeblocks/codeblocks-8.02.ebuild88
4 files changed, 49 insertions, 148 deletions
diff --git a/dev-util/codeblocks/ChangeLog b/dev-util/codeblocks/ChangeLog
index 0f41195c960b..57ddefdfe3aa 100644
--- a/dev-util/codeblocks/ChangeLog
+++ b/dev-util/codeblocks/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/codeblocks
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.17 2010/05/06 06:08:10 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.18 2010/07/02 22:04:11 dirtyepic Exp $
+
+*codeblocks-10.05 (02 Jul 2010)
+
+ 02 Jul 2010; Ryan Hill <dirtyepic@gentoo.org>
+ -codeblocks-1.0_pre20070618.ebuild, -codeblocks-8.02.ebuild,
+ +codeblocks-10.05.ebuild:
+ Version bump (bug #322315). Clean up ebuild and remove old.
06 May 2010; Ryan Hill <dirtyepic@gentoo.org> codeblocks-8.02-r1.ebuild,
+files/codeblocks-8.02-gsocket.patch, metadata.xml:
diff --git a/dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild b/dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild
deleted file mode 100644
index ce1d9bfe2064..000000000000
--- a/dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild,v 1.3 2009/10/12 08:00:40 ssuominen Exp $
-
-inherit eutils wxwidgets
-
-#needed for wxwidgets.eclass
-WX_GTK_VER="2.6"
-
-DESCRIPTION="Code::Blocks - a free cross-platform C/C++ IDE"
-HOMEPAGE="http://www.codeblocks.org/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="unicode contrib debug"
-
-RDEPEND="=x11-libs/wxGTK-${WX_GTK_VER}*"
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.5
- >=sys-devel/automake-1.7
- >=sys-devel/libtool-1.4
- app-arch/zip"
-
-pkg_setup() {
- if use unicode; then
- #check for gtk2-unicode
- need-wxwidgets unicode
- else
- #check for gtk2-ansi
- need-wxwidgets gtk2
- fi
-}
-
-src_compile() {
- export WANT_AUTOCONF=2.5
- export WANT_AUTOMAKE=1.7
-
- local TMP
-
- TMP="/usr/share/aclocal/libtool.m4"
- einfo "Running ./bootstrap"
- if [ -e "$TMP" ]; then
- cp "$TMP" aclocal.m4 || die "cp failed"
- fi
- ./bootstrap || die "boostrap failed"
-
- econf --with-wx-config="${WX_CONFIG}" \
- $(use_enable contrib) \
- $(use_enable debug) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "make install failed"
-}
diff --git a/dev-util/codeblocks/codeblocks-10.05.ebuild b/dev-util/codeblocks/codeblocks-10.05.ebuild
new file mode 100644
index 000000000000..49e1118bff7a
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-10.05.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-10.05.ebuild,v 1.1 2010/07/02 22:04:11 dirtyepic Exp $
+
+EAPI="2"
+WX_GTK_VER="2.8"
+
+inherit wxwidgets flag-o-matic
+
+DESCRIPTION="The open source, cross platform, free C++ IDE."
+HOMEPAGE="http://www.codeblocks.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+SRC_URI="mirror://berlios/codeblocks/${P}-src.tar.bz2"
+
+IUSE="contrib debug pch static-libs"
+
+RDEPEND="x11-libs/wxGTK:2.8[X]"
+DEPEND="${RDEPEND}
+ app-arch/zip"
+
+S=${WORKDIR}/${P}-release
+
+src_configure() {
+ # C::B is picky on CXXFLAG -fomit-frame-pointer
+ # (project-wizard crash, instability ...)
+ filter-flags -fomit-frame-pointer
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable debug) \
+ $(use_enable pch) \
+ $(use_enable static-libs static) \
+ $(use_with contrib contrib-plugins all)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}
diff --git a/dev-util/codeblocks/codeblocks-8.02.ebuild b/dev-util/codeblocks/codeblocks-8.02.ebuild
deleted file mode 100644
index b87398d42269..000000000000
--- a/dev-util/codeblocks/codeblocks-8.02.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-8.02.ebuild,v 1.3 2009/02/12 04:42:37 dirtyepic Exp $
-
-inherit autotools wxwidgets flag-o-matic eutils
-
-WX_GTK_VER="2.8"
-
-DESCRIPTION="free cross-platform C/C++ IDE"
-HOMEPAGE="http://www.codeblocks.org/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-SRC_URI="mirror://sourceforge/codeblocks/${P}-src.tar.bz2"
-
-IUSE="contrib debug pch static unicode"
-
-RDEPEND="=x11-libs/wxGTK-${WX_GTK_VER}*
- x11-libs/gtk+"
-
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.5.0
- >=sys-devel/automake-1.7
- >=sys-devel/libtool-1.4
- app-arch/zip"
-
-pkg_setup() {
- if use unicode; then
- need-wxwidgets "unicode"
- else
- need-wxwidgets "gtk2"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}/${PV}-version.patch"
- epatch "${FILESDIR}"/${P}-gcc43.patch
- #epatch "${FILESDIR}/${PV}-install-plugins.patch"
- cd "${S}"
- find src/plugins -name Makefile.am -exec \
- sed -i -e 's#^libdir#pluginsdir#' \
- -e 's#^lib_LTLIBRARIES#plugins_LTLIBRARIES#' \
- '{}' \;
- # This one's buggy
- sed -i -e 's#^plugins_LTLIBRARIES#lib_LTLIBRARIES#' \
- src/plugins/contrib/wxSmith/Makefile.am
-
- eautoreconf || die "autoreconf failed"
-# ./bootstrap || die "boostrap failed"
-}
-
-src_compile() {
- # C::B is picky on CXXFLAG -fomit-frame-pointer
- # (project-wizard crash, instability ...)
- filter-flags -fomit-frame-pointer
- append-flags -fno-strict-aliasing
-
- cd "${S}"
- local myconf="$(use_enable pch)"
-# $(use_enable autosave) \
-# $(use_enable class-wizard) \
-# $(use_enable code-completion) \
-# $(use_enable compiler) \
-# $(use_enable debuger) \
-# $(use_enable mime-handler) \
-# $(use_enable open-files-list) \
-#
-# $(use_enable projects-importer) \
-# $(use_enable source-formatter) \
-# $(use_enable todo) \
-# $(use_enable xpmanifest)
-
- if use contrib; then
- myconf="${myconf} --with-contrib-plugins=all"
- fi
- econf --with-wx-config="${WX_CONFIG}" \
- --enable-dependency-tracking \
- $(use_enable unicode) \
- $(use_enable debug) \
- $(use_enable static) \
- ${myconf} || die "Died in action: econf ..."
- emake || die "Died in action: make ..."
-}
-
-src_install() {
- einstall || die "Install failed"
-}