summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-12-03 13:29:58 +0000
committerFabian Groffen <grobian@gentoo.org>2011-12-03 13:29:58 +0000
commit4d15669605363b60ab75ab4e2ec96fc3d0cbf2ee (patch)
tree54a9328e0c35fe70708ceda22ea36daf74a4ba66
parentStable on amd64 wrt bug #392313 (diff)
downloadgentoo-2-4d15669605363b60ab75ab4e2ec96fc3d0cbf2ee.tar.gz
gentoo-2-4d15669605363b60ab75ab4e2ec96fc3d0cbf2ee.tar.bz2
gentoo-2-4d15669605363b60ab75ab4e2ec96fc3d0cbf2ee.zip
Add patch to fix compilation on Darwin, marked ~x64-macos
(Portage version: 2.2.01.19824-prefix/cvs/Darwin i386)
-rw-r--r--dev-libs/nettle/ChangeLog6
-rw-r--r--dev-libs/nettle/files/nettle-2.4-darwin-shlink.patch54
-rw-r--r--dev-libs/nettle/nettle-2.4.ebuild7
3 files changed, 63 insertions, 4 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index 4e0ebe9e3036..eb184af22887 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/nettle
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.45 2011/09/04 04:10:48 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.46 2011/12/03 13:29:58 grobian Exp $
+
+ 03 Dec 2011; Fabian Groffen <grobian@gentoo.org>
+ +files/nettle-2.4-darwin-shlink.patch, nettle-2.4.ebuild:
+ Add patch to fix compilation on Darwin, marked ~x64-macos
*nettle-2.4 (04 Sep 2011)
diff --git a/dev-libs/nettle/files/nettle-2.4-darwin-shlink.patch b/dev-libs/nettle/files/nettle-2.4-darwin-shlink.patch
new file mode 100644
index 000000000000..b3c9377f5fe4
--- /dev/null
+++ b/dev-libs/nettle/files/nettle-2.4-darwin-shlink.patch
@@ -0,0 +1,54 @@
+From MacPorts:
+https://trac.macports.org/browser/trunk/dports/devel/nettle/files/patch-configure.diff
+
+nettle: move -L. before $(LDFLAGS) (which will contain -L${prefix}/lib)
+so future updates when the new and old libraries are incompatible don't
+go awry
+
+Reworked by Gentoo for configure.ac
+
+Fixes in particular the linking stage on Darwin, using the right
+dependency libs, and creating the right names.
+
+Fixed incorrect -gmp argument in LIBS (probably typo)
+
+
+--- configure.ac
++++ configure.ac
+@@ -61,9 +61,8 @@
+ [enable_gcov=no])
+
+ LSH_RPATH_INIT([`echo $with_lib_path | sed 's/:/ /g'` \
+- `echo $exec_prefix | sed "s@^NONE@$prefix/lib@g" | sed "s@^NONE@$ac_default_prefix/lib@g"` \
+- /usr/local/lib /sw/local/lib /sw/lib \
+- /usr/gnu/lib /opt/gnu/lib /sw/gnu/lib /usr/freeware/lib /usr/pkg/lib])
++ `echo $exec_prefix | sed "s@^NONE@$prefix/lib@g" | sed
++"s@^NONE@$ac_default_prefix/lib@g"`])
+
+ # Checks for programs.
+ AC_PROG_CC
+@@ -281,16 +280,16 @@
+ ;;
+ darwin*)
+ LIBNETTLE_FORLINK=libnettle.dylib
+- LIBNETTLE_SONAME='$(LIBNETTLE_FORLINK).$(LIBNETTLE_MAJOR)'
+- LIBNETTLE_FILE='$(LIBNETTLE_SONAME).$(LIBNETTLE_MINOR)'
+- LIBNETTLE_LINK='$(CC) -dynamiclib $(LDFLAGS)'
+- LIBNETTLE_LIBS=''
++ LIBNETTLE_SONAME='libnettle.$(LIBNETTLE_MAJOR).dylib'
++ LIBNETTLE_FILE='libnettle.$(LIBNETTLE_MAJOR).$(LIBNETTLE_MINOR).dylib'
++ LIBNETTLE_LINK='$(CC) -dynamiclib $(LDFLAGS) -install_name ${libdir}/$(LIBNETTLE_SONAME) -compatibility_version $(LIBNETTLE_MAJOR) -current_version $(LIBNETTLE_MAJOR).$(LIBNETTLE_MINOR)'
++ LIBNETTLE_LIBS='$(LIBS)'
+
+ LIBHOGWEED_FORLINK=libhogweed.dylib
+- LIBHOGWEED_SONAME='$(LIBHOGWEED_FORLINK).$(LIBHOGWEED_MAJOR)'
+- LIBHOGWEED_FILE='$(LIBHOGWEED_SONAME).$(LIBHOGWEED_MINOR)'
+- LIBHOGWEED_LINK='$(CC) -dynamiclib $(LDFLAGS)'
+- LIBHOGWEED_LIBS=''
++ LIBHOGWEED_SONAME='libhogweed.$(LIBHOGWEED_MAJOR).dylib'
++ LIBHOGWEED_FILE='libhogweed.$(LIBHOGWEED_MAJOR).$(LIBHOGWEED_MINOR).dylib'
++ LIBHOGWEED_LINK='$(CC) -dynamiclib -L. $(LDFLAGS) -install_name ${libdir}/$(LIBHOGWEED_SONAME) -compatibility_version $(LIBHOGWEED_MAJOR) -current_version $(LIBHOGWEED_MAJOR).$(LIBHOGWEED_MINOR)'
++ LIBHOGWEED_LIBS='$(LIBS) -lnettle'
+ ;;
+ solaris*)
+ # Sun's ld uses -h to set the soname, and this option is passed
diff --git a/dev-libs/nettle/nettle-2.4.ebuild b/dev-libs/nettle/nettle-2.4.ebuild
index d79e2a4b63aa..43400b771ee6 100644
--- a/dev-libs/nettle/nettle-2.4.ebuild
+++ b/dev-libs/nettle/nettle-2.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.4.ebuild,v 1.1 2011/09/04 04:10:48 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.4.ebuild,v 1.2 2011/12/03 13:29:58 grobian Exp $
EAPI="4"
-inherit autotools
+inherit eutils autotools
DESCRIPTION="Low-level cryptographic library"
HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
@@ -12,7 +12,7 @@ SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
LICENSE="|| ( LGPL-3 LGPL-2.1 )"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="gmp ssl"
DEPEND="gmp? ( dev-libs/gmp )
@@ -21,6 +21,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
sed -e "/CFLAGS=/s: -ggdb3::" -i configure.ac || die "sed failed"
+ epatch "${FILESDIR}"/${P}-darwin-shlink.patch
eautoreconf
}