summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-07-15 17:55:06 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-07-15 17:55:06 +0000
commit4cf97cd8e40189754160f3085db2512b02df473c (patch)
treebec3142ae73663656a945fc748531f2868911072
parentFix deps for dev-haskell/haddock, supports more ghc versions. (diff)
downloadgentoo-2-4cf97cd8e40189754160f3085db2512b02df473c.tar.gz
gentoo-2-4cf97cd8e40189754160f3085db2512b02df473c.tar.bz2
gentoo-2-4cf97cd8e40189754160f3085db2512b02df473c.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux i686)
-rw-r--r--app-accessibility/speakup/ChangeLog7
-rw-r--r--app-accessibility/speakup/speakup-3.1.2.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/app-accessibility/speakup/ChangeLog b/app-accessibility/speakup/ChangeLog
index f6e7f51d6189..c035b5d10e1b 100644
--- a/app-accessibility/speakup/ChangeLog
+++ b/app-accessibility/speakup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/speakup
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.25 2009/06/20 07:03:49 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.26 2009/07/15 17:55:06 williamh Exp $
+
+*speakup-3.1.2 (15 Jul 2009)
+
+ 15 Jul 2009; William Hubbs <williamh@gentoo.org> +speakup-3.1.2.ebuild:
+ Version bump.
*speakup-3.1.1 (20 Jun 2009)
diff --git a/app-accessibility/speakup/speakup-3.1.2.ebuild b/app-accessibility/speakup/speakup-3.1.2.ebuild
new file mode 100644
index 000000000000..33d540f17215
--- /dev/null
+++ b/app-accessibility/speakup/speakup-3.1.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/speakup-3.1.2.ebuild,v 1.1 2009/07/15 17:55:06 williamh Exp $
+
+EAPI="2"
+
+inherit linux-mod
+
+DESCRIPTION="The speakup linux kernel based screen reader."
+HOMEPAGE="http://linux-speakup.org"
+SRC_URI="ftp://linux-speakup.org/pub/speakup/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ case ${KV_EXTRA} in
+ *gentoo)
+ if kernel_is lt 2 6 25; then
+ die "Speakup requires at least gentoo-sources-2.6.25"
+ fi
+ ;;
+ *)
+ if kernel_is lt 2 6 26; then
+ die "Speakup requires at least kernel version2.6.26"
+ fi
+ ;;
+ esac
+}
+
+src_compile() {
+ MODULE_NAMES="speakup(${PN}:\"${S}\"/src)
+ speakup_acntpc(${PN}:\"${S}\"/src)
+ speakup_acntsa(${PN}:\"${S}\"/src)
+ speakup_apollo(${PN}:\"${S}\"/src)
+ speakup_audptr(${PN}:\"${S}\"/src)
+ speakup_bns(${PN}:\"${S}\"/src)
+ speakup_decext(${PN}:\"${S}\"/src)
+ speakup_decpc(${PN}:\"${S}\"/src)
+ speakup_dectlk(${PN}:\"${S}\"/src)
+ speakup_dtlk(${PN}:\"${S}\"/src)
+ speakup_dummy(${PN}:\"${S}\"/src)
+ speakup_keypc(${PN}:\"${S}\"/src)
+ speakup_ltlk(${PN}:\"${S}\"/src)
+ speakup_soft(${PN}:\"${S}\"/src)
+ speakup_spkout(${PN}:\"${S}\"/src)
+ speakup_txprt(${PN}:\"${S}\"/src)"
+ BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+ BUILD_TARGETS="clean all"
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+ dobin tools/speakupconf
+ dosbin tools/talkwith
+ dodoc Bugs.txt README To-Do doc/DefaultKeyAssignments doc/spkguide.txt
+ newdoc tools/README README.tools
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ elog "You must set up the speech synthesizer driver to be loaded"
+ elog "automatically in order for your system to start speaking"
+ elog "when it is booted."
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "this is done via /etc/modules.autoload.d/kernel-2.6"
+ else
+ elog "This is done via /etc/conf.d/modules."
+ fi
+}