summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-30 20:38:08 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-30 20:38:08 +0000
commit4ca40cb6b94697077ea22dab2ecd7febe9d0feab (patch)
tree624aaf6168ed23c37728d8cde9035e7cf3973ac8
parentVersion bump. (diff)
downloadgentoo-2-4ca40cb6b94697077ea22dab2ecd7febe9d0feab.tar.gz
gentoo-2-4ca40cb6b94697077ea22dab2ecd7febe9d0feab.tar.bz2
gentoo-2-4ca40cb6b94697077ea22dab2ecd7febe9d0feab.zip
Version bump.
(Portage version: 14746-svn/cvs/Linux x86_64)
-rw-r--r--dev-python/python-docs/ChangeLog8
-rw-r--r--dev-python/python-docs/python-docs-2.6.4.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index a9019c9d910f..e2d570183faa 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-docs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.133 2009/10/19 16:01:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.134 2009/10/30 20:38:08 arfrever Exp $
+
+*python-docs-2.6.4 (30 Oct 2009)
+
+ 30 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +python-docs-2.6.4.ebuild:
+ Version bump.
19 Oct 2009; Raúl Porcel <armin76@gentoo.org>
python-docs-2.6.2-r1.ebuild:
diff --git a/dev-python/python-docs/python-docs-2.6.4.ebuild b/dev-python/python-docs/python-docs-2.6.4.ebuild
new file mode 100644
index 000000000000..cec00436e501
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.6.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.4.ebuild,v 1.1 2009/10/30 20:38:08 arfrever Exp $
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=app-admin/eselect-python-20090606"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ [[ -z "${ED}" ]] && local ED="${D}"
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+eselect_python_update() {
+ local ignored_python_slots_options
+ [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots_options="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+
+ # Create python2 symlink.
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+
+ eselect python update ${ignored_python_slots_options}
+}
+
+pkg_postinst() {
+ eselect_python_update
+}
+
+pkg_postrm() {
+ [[ -z "${EROOT}" ]] && local EROOT="${ROOT}"
+ eselect_python_update
+
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+
+ rm -f "${EROOT}etc/env.d/50python-docs"
+}