summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-11-24 22:47:17 +0000
committerSven Wegener <swegener@gentoo.org>2004-11-24 22:47:17 +0000
commit4aa1cac81f47cde1e02ef4fb5a4b5cca8a57e06f (patch)
treee22307b318ba38374ba3d988287fccc48d6147b0
parentAdjust homepage in ebuilds. (Manifest recommit) (diff)
downloadgentoo-2-4aa1cac81f47cde1e02ef4fb5a4b5cca8a57e06f.tar.gz
gentoo-2-4aa1cac81f47cde1e02ef4fb5a4b5cca8a57e06f.tar.bz2
gentoo-2-4aa1cac81f47cde1e02ef4fb5a4b5cca8a57e06f.zip
Version bump. Thanks to Lars (Polynomial-C) <polynomial-C@gmx.de> for notification. Closes bug #72291.
-rw-r--r--net-irc/xchat/ChangeLog8
-rw-r--r--net-irc/xchat/Manifest2
-rw-r--r--net-irc/xchat/files/digest-xchat-2.4.12
-rw-r--r--net-irc/xchat/xchat-2.4.1.ebuild81
4 files changed, 92 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 3bff19710dfe..19be1765693c 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.135 2004/11/22 20:53:34 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.136 2004/11/24 22:47:17 swegener Exp $
+
+*xchat-2.4.1 (24 Nov 2004)
+
+ 24 Nov 2004; Sven Wegener <swegener@gentoo.org> +xchat-2.4.1.ebuild:
+ Version bump. Thanks to Lars (Polynomial-C) <polynomial-C@gmx.de> for
+ notification. Closes bug #72291.
22 Nov 2004; Stephen P. Becker <geoman@gentoo.org> xchat-2.4.0-r1.ebuild,
xchat-2.4.0.ebuild:
diff --git a/net-irc/xchat/Manifest b/net-irc/xchat/Manifest
index 7d9a5f463aa7..6456f15c34a9 100644
--- a/net-irc/xchat/Manifest
+++ b/net-irc/xchat/Manifest
@@ -1,3 +1,4 @@
+MD5 daeb237a0a47cf43d22fcf235b4c3ca5 xchat-2.4.1.ebuild 2245
MD5 9a920adedab8f380a8e0fa2344359159 xchat-2.4.0.ebuild 2233
MD5 e862cd62853b7ae38fc97f1fcedfcab8 xchat-1.8.11-r1.ebuild 2267
MD5 2482bed10a2e7145bc1814f094dd41a8 xchat-2.0.8-r1.ebuild 2005
@@ -8,6 +9,7 @@ MD5 f27b4078fe482ce7d5a084a83ef73c18 ChangeLog 20490
MD5 fb5772136a872c08434566d4f0bcdc7f metadata.xml 179
MD5 2effc9c4c2a5454c5abba3817894e865 files/digest-xchat-2.0.9 126
MD5 3ddde600db975d5c534197fa4fe2b1b7 files/digest-xchat-2.4.0 134
+MD5 4a066f82a7a8ab6fe970340332d70105 files/digest-xchat-2.4.1 134
MD5 28706a4c0068f4066e78bc9f93945fc2 files/digest-xchat-2.0.10-r3 135
MD5 a8f607d224408d4a27777d2ffce8beac files/xc1811fixststint.diff 422
MD5 3d228dd6bbf6d081f6888dd7b3d2a6af files/2.0.10-preeditstring.patch 820
diff --git a/net-irc/xchat/files/digest-xchat-2.4.1 b/net-irc/xchat/files/digest-xchat-2.4.1
new file mode 100644
index 000000000000..c09c93cf6a1a
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.4.1
@@ -0,0 +1,2 @@
+MD5 aeb2337cc36dd4a9ac0cd6e909f67227 xchat-2.4.1.tar.bz2 1214388
+MD5 4e66cb157c70b8d02f74238dc9a5057c xchat-dccserver-0.4.patch 11767
diff --git a/net-irc/xchat/xchat-2.4.1.ebuild b/net-irc/xchat/xchat-2.4.1.ebuild
new file mode 100644
index 000000000000..830d9d61ab61
--- /dev/null
+++ b/net-irc/xchat/xchat-2.4.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.4.1.ebuild,v 1.1 2004/11/24 22:47:17 swegener Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/2.4/${P}.tar.bz2
+ xchatdccserver? ( http://dfx.at/xchat/xchat-dccserver-0.4.patch )"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~sparc ~hppa ~ppc ~alpha ~amd64 ~ia64 ~mips ~ppc64"
+IUSE="perl tcltk python ssl mmx ipv6 nls xchattext xchatnogtk xchatdccserver"
+
+# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+if [ ${ARCH} = "sparc" ]
+then
+ replace-flags "-O[3-9]" "-O2"
+fi
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ !xchatnogtk? ( >=x11-libs/gtk+-2.0.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ >=sys-apps/sed-4
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use xchatdccserver && epatch ${DISTDIR}/xchat-dccserver-0.4.patch
+}
+
+src_compile() {
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcltk tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable xchattext textfe) \
+ $(use_enable !xchatnogtk gtkfe) \
+ --program-suffix=-2 \
+ || die "Configure failed"
+
+ emake || die "Compile failed"
+
+}
+
+src_install() {
+
+ # some magic to create a menu entry for xchat 2
+ sed -i \
+ -e "s:^Exec=xchat$:Exec=xchat-2:" \
+ -e "s:Name=XChat IRC:Name=XChat 2 IRC:" \
+ xchat.desktop
+
+ make DESTDIR=${D} install || die "Install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc ChangeLog README* || die "dodoc failed"
+
+}