summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-07 06:43:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-07 06:43:58 +0000
commit49b7087898c7e87bf809e3c7651d760c377673fe (patch)
treeffbc5e2e3910c863613d1430a8efae0abefeaab5
parentVersion bump. Drop jruby, code no longer compatible. (diff)
downloadgentoo-2-49b7087898c7e87bf809e3c7651d760c377673fe.tar.gz
gentoo-2-49b7087898c7e87bf809e3c7651d760c377673fe.tar.bz2
gentoo-2-49b7087898c7e87bf809e3c7651d760c377673fe.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/xlrd/ChangeLog7
-rw-r--r--dev-python/xlrd/xlrd-0.9.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/xlrd/ChangeLog b/dev-python/xlrd/ChangeLog
index f0e772743808..c86cfde3d55c 100644
--- a/dev-python/xlrd/ChangeLog
+++ b/dev-python/xlrd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/xlrd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.23 2014/03/31 20:55:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.24 2014/05/07 06:43:58 patrick Exp $
+
+*xlrd-0.9.3 (07 May 2014)
+
+ 07 May 2014; Patrick Lauer <patrick@gentoo.org> +xlrd-0.9.3.ebuild:
+ Bump
31 Mar 2014; Michał Górny <mgorny@gentoo.org> xlrd-0.9.0.ebuild,
xlrd-0.9.2.ebuild:
diff --git a/dev-python/xlrd/xlrd-0.9.3.ebuild b/dev-python/xlrd/xlrd-0.9.3.ebuild
new file mode 100644
index 000000000000..b39beebb9bae
--- /dev/null
+++ b/dev-python/xlrd/xlrd-0.9.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/xlrd-0.9.3.ebuild,v 1.1 2014/05/07 06:43:58 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
+HOMEPAGE="http://pypi.python.org/pypi/xlrd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # add shebang to runxlrd.py
+ sed -i -e '1i#!/usr/bin/encompdoc.html xlrd.htmlv python' scripts/runxlrd.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml ${PN}/doc/{compdoc.html,xlrd.html}
+ fi
+
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples/
+ insinto usr/share/doc/${P}/examples
+ doins ${PN}/examples/*
+ fi
+}