summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-11 23:56:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-11 23:56:05 +0000
commit4846967e141ac7b27fe4827a0c90df29616d6a54 (patch)
tree40eee07d2b718055dbbb2b6840767bc8f256981c
parentVersion bumped. Closes #41318, #43818. (Manifest recommit) (diff)
downloadgentoo-2-4846967e141ac7b27fe4827a0c90df29616d6a54.tar.gz
gentoo-2-4846967e141ac7b27fe4827a0c90df29616d6a54.tar.bz2
gentoo-2-4846967e141ac7b27fe4827a0c90df29616d6a54.zip
error checking; don't use S=${WORKDIR}/${P}
-rw-r--r--net-misc/keychain/ChangeLog8
-rw-r--r--net-misc/keychain/keychain-2.0.2.ebuild19
-rw-r--r--net-misc/keychain/keychain-2.0.3.ebuild21
3 files changed, 30 insertions, 18 deletions
diff --git a/net-misc/keychain/ChangeLog b/net-misc/keychain/ChangeLog
index 61220440f254..9b59011983d0 100644
--- a/net-misc/keychain/ChangeLog
+++ b/net-misc/keychain/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/keychain
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/keychain/ChangeLog,v 1.16 2004/03/06 01:30:56 tgall Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/keychain/ChangeLog,v 1.17 2004/03/11 23:56:05 mr_bones_ Exp $
+
+ 11 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> keychain-2.0.2.ebuild,
+ keychain-2.0.3.ebuild:
+ error checking; don't use S=${WORKDIR}/${P}
05 Mar 2004; Tom Gall <tgall@gentoo.org> keychain-2.0.3.ebuild:
Marked stable on ppc64
diff --git a/net-misc/keychain/keychain-2.0.2.ebuild b/net-misc/keychain/keychain-2.0.2.ebuild
index 902d9c930e06..0a7fd4801dfe 100644
--- a/net-misc/keychain/keychain-2.0.2.ebuild
+++ b/net-misc/keychain/keychain-2.0.2.ebuild
@@ -1,20 +1,23 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/keychain/keychain-2.0.2.ebuild,v 1.8 2003/03/27 05:28:19 vladimir Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/keychain/keychain-2.0.2.ebuild,v 1.9 2004/03/11 23:56:05 mr_bones_ Exp $
DESCRIPTION="A front-end to ssh-agent"
HOMEPAGE="http://www.gentoo.org/proj/en/keychain.xml"
-
SRC_URI="http://www.ibiblio.org/gentoo/distfiles/${P}.tar.bz2"
-S=${WORKDIR}/${P}
-KEYWORDS="x86 ppc sparc "
+
+KEYWORDS="x86 ppc sparc"
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
DEPEND="virtual/glibc"
-RDEPEND="${DEPEND} app-shells/bash net-misc/openssh sys-apps/sh-utils"
+RDEPEND="${DEPEND}
+ app-shells/bash
+ net-misc/openssh
+ sys-apps/sh-utils"
src_install() {
- dobin keychain
- dodoc ChangeLog README
+ dobin keychain || die "dobin failed"
+ dodoc ChangeLog README || die "dodoc failed"
}
diff --git a/net-misc/keychain/keychain-2.0.3.ebuild b/net-misc/keychain/keychain-2.0.3.ebuild
index 5698f7abe2d5..555126c53532 100644
--- a/net-misc/keychain/keychain-2.0.3.ebuild
+++ b/net-misc/keychain/keychain-2.0.3.ebuild
@@ -1,22 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/keychain/keychain-2.0.3.ebuild,v 1.7 2004/03/06 01:30:56 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/keychain/keychain-2.0.3.ebuild,v 1.8 2004/03/11 23:56:05 mr_bones_ Exp $
DESCRIPTION="A front-end to ssh-agent"
HOMEPAGE="http://www.gentoo.org/proj/en/keychain.xml"
-
SRC_URI="http://www.ibiblio.org/gentoo/distfiles/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
KEYWORDS="x86 ~ppc sparc ~alpha ~mips ~hppa amd64 ia64 ppc64"
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
DEPEND="virtual/glibc"
-RDEPEND="${DEPEND} app-shells/bash net-misc/openssh
- || ( sys-apps/coreutils sys-apps/sh-utils )"
+RDEPEND="${DEPEND}
+ app-shells/bash
+ net-misc/openssh
+ || (
+ sys-apps/coreutils
+ sys-apps/sh-utils
+ )"
src_install() {
- dobin keychain
- dodoc ChangeLog README
- doman keychain.1
+ dobin keychain || die "dobin failed"
+ dodoc ChangeLog README || die "dodoc failed"
+ doman keychain.1 || die "doman failed"
}