summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2003-09-01 18:19:22 +0000
committerBrian Jackson <iggy@gentoo.org>2003-09-01 18:19:22 +0000
commit47f567f281d68ffdf4ab5714ec94487bd09c050b (patch)
treeda7f5e24a8153723d2a9a8a640b46599ccc38969
parentbumping this for pauldv since he's oot (diff)
downloadgentoo-2-47f567f281d68ffdf4ab5714ec94487bd09c050b.tar.gz
gentoo-2-47f567f281d68ffdf4ab5714ec94487bd09c050b.tar.bz2
gentoo-2-47f567f281d68ffdf4ab5714ec94487bd09c050b.zip
bumping this for pauldv since he's oot
-rw-r--r--dev-util/subversion/ChangeLog7
-rw-r--r--dev-util/subversion/Manifest4
-rw-r--r--dev-util/subversion/files/digest-subversion-0.28.02
-rw-r--r--dev-util/subversion/subversion-0.28.0.ebuild260
4 files changed, 270 insertions, 3 deletions
diff --git a/dev-util/subversion/ChangeLog b/dev-util/subversion/ChangeLog
index aad72d382dd4..91cda39dc570 100644
--- a/dev-util/subversion/ChangeLog
+++ b/dev-util/subversion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/subversion
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.30 2003/08/26 12:50:31 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.31 2003/09/01 18:19:18 iggy Exp $
+
+*subversion-0.28.0 (01 Sep 2003)
+
+ 01 Sep 2003; <iggy@gentoo.org> subversion-0.28.0.ebuild:
+ bumping this for pauldv since he's oot
*subversion-0.27.0 (26 Aug 2003)
diff --git a/dev-util/subversion/Manifest b/dev-util/subversion/Manifest
index dda52cec40d8..56b14df7f0a9 100644
--- a/dev-util/subversion/Manifest
+++ b/dev-util/subversion/Manifest
@@ -1,8 +1,8 @@
MD5 f8e0863c8c84504268d8bd45e2783b72 subversion-0.26.0.ebuild 7857
MD5 bbf4a10088d925cf77b6055e25eff877 subversion-0.27.0.ebuild 7907
MD5 d22cfd9948bf734132ceb12c0a65ddcd subversion-0.24.2-r1.ebuild 7801
-MD5 c52fd283db5537c81b3a881cc2939984 subversion-0.28.0.ebuild 7980
-MD5 d37dd2313ab5432895cc8e30a2ac0ab7 ChangeLog 5205
+MD5 e1745326bc41c703e39bdcf7c40e5bc7 subversion-0.28.0.ebuild 7978
+MD5 19dedebb515786158b951416222258ff ChangeLog 5203
MD5 94a82b90df7338731c1f8d4a654edb8a metadata.xml 151
MD5 928a2b0b2d39afb7969f92af61da2a57 subversion-0.25.0.ebuild 7871
MD5 ea42402d74d0a58036f40ab88b679b6d files/digest-subversion-0.25.0 130
diff --git a/dev-util/subversion/files/digest-subversion-0.28.0 b/dev-util/subversion/files/digest-subversion-0.28.0
new file mode 100644
index 000000000000..480464e8eba7
--- /dev/null
+++ b/dev-util/subversion/files/digest-subversion-0.28.0
@@ -0,0 +1,2 @@
+MD5 12262c64fcd64b772e7cffad8e4d0ebc db-4.0.14.tar.gz 2701799
+MD5 62a10c5ec13815e29f9bc100a1ee6dcc subversion-0.28.tar.gz 7126235
diff --git a/dev-util/subversion/subversion-0.28.0.ebuild b/dev-util/subversion/subversion-0.28.0.ebuild
new file mode 100644
index 000000000000..4bac7df68a38
--- /dev/null
+++ b/dev-util/subversion/subversion-0.28.0.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-0.28.0.ebuild,v 1.1 2003/09/01 18:19:18 iggy Exp $
+
+inherit libtool
+
+# the tarball is oddly named for the release version
+PV="${PV/28.0/28}"
+
+DB_VERSION="4.0.14"
+DESCRIPTION="A compelling replacement for CVS"
+SRC_URI="berkdb? ( http://www.sleepycat.com/update/snapshot/db-${DB_VERSION}.tar.gz )
+ http://subversion.tigris.org/files/documents/15/5870/${PN}-${PV}.tar.gz"
+HOMEPAGE="http://subversion.tigris.org/"
+
+SLOT="0"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE="ssl apache2 berkdb python"
+
+S=${WORKDIR}/${PN}-${PV}
+
+if [ "${SVN_REPOS_LOC}x" = "x" ]; then
+ SVN_REPOS_LOC="/home/svn"
+fi
+
+#
+#
+# Note that to disable the server part of subversion you need to specify
+# USE="-berkdb" emerge subversion.
+#
+#
+
+S_DB="${WORKDIR}/db-${DB_VERSION}/build_unix"
+
+DEPEND="python? ( >=dev-lang/python-2.0 )
+ >=sys-apps/diffutils-2.7.7
+ >=sys-devel/libtool-1.4.1-r1
+ >=sys-devel/bison-1.28-r3
+ apache2? ( >=net-www/apache-2.0.45 )
+ !apache2? ( !>=apache-2* )
+ !dev-libs/apr
+ ~sys-devel/m4-1.4
+ python? ( >=dev-lang/swig-1.3.16 )
+ >=net-misc/neon-0.23.8"
+
+RDEPEND="python? ( >=dev-lang/python-2.0 )
+ >=sys-apps/diffutils-2.7.7
+ ~sys-devel/m4-1.4"
+
+pkg_setup() {
+ if use apache2; then
+ einfo "The apache2 subversion module will be built, and libapr from the"
+ einfo "apache package will be used instead of the included"
+ else
+ einfo "Please note that subversion and apache2 cannot be installed"
+ einfo "simultaneously without specifying the apache2 use flag. This is"
+ einfo "because subversion installs its own libapr and libapr-util in that"
+ einfo "case."
+ fi
+}
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${PN}-${PV}.tar.gz
+ use berkdb && ( has_version =db-4* || (
+ unpack db-${DB_VERSION}.tar.gz
+ ) )
+ cd ${S}
+ elibtoolize ${S}
+ patch -p1 <${FILESDIR}/subversion-db4.patch
+ autoconf
+}
+
+src_compile() {
+ local myconf
+ use berkdb && ( has_version =db-4* || (
+ cd ${S_DB}
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-compat185 \
+ --disable-cxx \
+ --disable-tcl \
+ --disable-java \
+ --disable-shared \
+ --with-uniquename
+ emake || make || die "db make failed"
+ [ -e ${WORKDIR}/dbinst ] && rm -rf ${WORKDIR}/dbinst
+ mkdir -p ${WORKDIR}/dbinst/lib
+ make prefix=${WORKDIR}/dbinst install ||die
+ mkdir ${WORKDIR}/dbinst/include/db4
+ cp ${WORKDIR}/dbinst/include/*.h ${WORKDIR}/dbinst/include/db4
+ mv ${WORKDIR}/dbinst/lib/libdb.a ${WORKDIR}/dbinst/lib/libdb4.a
+ cat <<EOF >${WORKDIR}/dbinst/lib/libdb4.so
+GROUP( ${WORKDIR}/dbinst/lib/libdb4.a /usr/lib/libdb.so)
+EOF
+ ) ) #no db4
+
+ cd ${S}
+ use ssl && myconf="${myconf} --with-ssl"
+ use ssl || myconf="${myconf} --without-ssl"
+
+ use apache2 && myconf="${myconf} --with-apxs=/usr/sbin/apxs2 \
+ --with-apr=/usr --with-apr-util=/usr"
+ use apache2 || myconf="${myconf} --without-apxs"
+
+ if use berkdb; then
+ has_version =db-4* && myconf="${myconf} --with-berkeley-db"
+ has_version =db-4* || myconf="${myconf} --with-berkeley-db=${WORKDIR}/dbinst"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ use python && myconf="${myconf} --with-python=/usr/bin/python --with-swig"
+ use python || myconf="${myconf} --without-python --without-swig"
+
+ echo "myconf=${myconf}"
+ econf ${myconf} \
+ --with-neon=/usr \
+ --disable-experimental-libtool \
+ --disable-mod-activation ||die "configuration failed"
+
+
+ # build subversion, but do it in a way that is safe for paralel builds
+ # Also apparently the included apr does have a libtool that doesn't like
+ # -L flags. So not specifying it at all when not building apache modules
+ # and only specify it for internal parts otherwise
+ if use apache2; then
+ ( emake external-all && emake LT_LDFLAGS="-L${D}/usr/lib" local-all ) || die "make of subversion failed"
+ else
+ ( emake external-all && emake local-all ) || die "make of subversion failed"
+ fi
+
+ #building fails without the apache apr-util as includes are wrong.
+ #Also the python bindings do not work without db installed
+ if use python; then
+ if use berkdb; then
+ if use apache2; then
+ emake swig-py || die "subversion python bindings failed"
+ else
+ emake SVN_APR_INCLUDES="-I${S}/apr/include -I${S}/apr-util/include" swig-py || die "subversion python bindings failed"
+ fi
+ fi
+ fi
+}
+
+
+src_install () {
+ mkdir -p ${D}/etc/apache2/conf
+ mkdir -p ${D}/etc/share
+
+ use berkdb && ( has_version =db-4* || (
+ mkdir -p ${D}/usr/share/subversion/bin
+ cp ${WORKDIR}/dbinst/bin/* ${D}/usr/share/subversion/bin/
+ ) )
+
+ make DESTDIR=${D} install || die "Installation of subversion failed"
+ if [ -e ${D}/usr/lib/apache2 ]; then
+ mv ${D}/usr/lib/apache2 ${D}/usr/lib/apache2-extramodules
+ fi
+
+ if use python; then
+ if use berkdb; then
+ make install-swig-py DESTDIR=${D} DISTUTIL_PARAM=--prefix=${D} || die "Installation of subversion python bindings failed"
+ # install cvs2svn
+ dobin tools/cvs2svn/cvs2svn.py
+ mv ${D}/usr/bin/cvs2svn.py ${D}/usr/bin/cvs2svn
+ doman tools/cvs2svn/cvs2svn.1
+
+ # move python bindings
+ mkdir -p ${D}/usr/lib/python2.2/site-packages
+ cp -r tools/cvs2svn/rcsparse ${D}/usr/lib/python2.2/site-packages
+ mv ${D}/usr/lib/svn-python/svn ${D}/usr/lib/python2.2/site-packages
+ mv ${D}/usr/lib/svn-python/libsvn ${D}/usr/lib/python2.2/site-packages
+ rmdir ${D}/usr/lib/svn-python
+ fi
+ fi
+
+ dodoc BUGS COMMITTERS COPYING HACKING IDEAS INSTALL PORTING README
+ dodoc CHANGES
+ dodoc tools/xslt/svnindex.css tools/xslt/svnindex.xsl
+
+ # install documentation
+ docinto notes
+ for f in notes/*
+ do
+ [ -f ${f} ] && dodoc ${f}
+ done
+ cd ${S}
+ echo "installing html book"
+ dohtml -r doc/book/book/book.html doc/book/book/styles.css doc/book/book/images
+ if use apache2; then
+ mkdir -p ${D}/etc/apache2/conf/modules.d
+ cat <<EOF >${D}/etc/apache2/conf/modules.d/47_mod_dav_svn.conf
+<IfDefine SVN>
+ <IfModule !mod_dav_svn.c>
+ LoadModule dav_svn_module extramodules/mod_dav_svn.so
+ </IfModule>
+ <Location /svn/repos>
+ DAV svn
+ SVNPath ${SVN_REPOS_LOC}/repos
+ AuthType Basic
+ AuthName "Subversion repository"
+ AuthUserFile ${SVN_REPOS_LOC}/conf/svnusers
+ Require valid-user
+ </Location>
+</IfDefine>
+EOF
+ fi
+}
+
+pkg_postinst() {
+ if use berkdb; then
+ if use apache2; then
+ einfo "Subversion has multiple server types. To enable the http based version"
+ einfo "you must edit /etc/conf.d/apache2 to include both \"-D DAV\" and \"-D SVN\""
+ einfo ""
+ fi
+ einfo "A repository needs to be created using the ebuild ${PN} config command"
+ if has_version =sys-libs/db-4*; then
+ einfo "If you upgraded from an older version of berkely db and experience"
+ einfo "problems with your repository then run the following command:"
+ einfo " su apache -c \"db4_recover -h /path/to/repos\""
+ fi
+ if use apache2; then
+ einfo "To allow web access a htpasswd file needs to be created using the"
+ einfo "following command:"
+ einfo " htpasswd2 -m -c ${SVN_REPOS_LOC}/conf/svnusers USERNAME"
+ fi
+ else
+ einfo "Your subversion is client only as the server is only build when"
+ einfo "the berkdb flag is set"
+ fi
+}
+
+pkg_config() {
+ if [ ! -x /usr/bin/svnadmin ]; then
+ die "You seem to only have build the subversion client"
+ fi
+ einfo ">>> Initializing the database in ${SVN_REPOS_LOC}..."
+ if [ -f ${SVN_REPOS_LOC}/repos ] ; then
+ echo "A subversion repository already exists and I will not overwrite it."
+ echo "Delete ${SVN_REPOS_LOC}/repos first if you're sure you want to have a clean version."
+ else
+ mkdir -p ${SVN_REPOS_LOC}
+ einfo ">>> Populating repository directory ..."
+ # create initial repository
+ /usr/bin/svnadmin create ${SVN_REPOS_LOC}/repos
+
+ einfo ">>> Setting repository permissions ..."
+ chown -Rf apache.apache ${SVN_REPOS_LOC}/repos
+ chmod -Rf 755 ${SVN_REPOS_LOC}/repos
+ fi
+}
+