summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-03-21 04:33:07 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-03-21 04:33:07 +0000
commit46c2f46a1f06fc03c5d5b247bc00f677f8482b80 (patch)
tree976c7eecc7fc40dc046d977af47deb3dde41f2d4
parentUse prune_libtool_files to remove unnecessary libtool archive (.la) of libosp. (diff)
downloadgentoo-2-46c2f46a1f06fc03c5d5b247bc00f677f8482b80.tar.gz
gentoo-2-46c2f46a1f06fc03c5d5b247bc00f677f8482b80.tar.bz2
gentoo-2-46c2f46a1f06fc03c5d5b247bc00f677f8482b80.zip
Version bump for 1.6 series
(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
-rw-r--r--sys-apps/hwloc/ChangeLog7
-rw-r--r--sys-apps/hwloc/hwloc-1.6.2.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index 435cba21d220..77ac1e00105a 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.34 2013/02/28 14:32:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.35 2013/03/21 04:33:07 alexxy Exp $
+
+*hwloc-1.6.2 (21 Mar 2013)
+
+ 21 Mar 2013; Alexey Shvetsov <alexxy@gentoo.org> +hwloc-1.6.2.ebuild:
+ Version bump for 1.6 series
28 Feb 2013; Jeroen Roovers <jer@gentoo.org> hwloc-1.6.1.ebuild:
Stable for HPPA (bug #458206).
diff --git a/sys-apps/hwloc/hwloc-1.6.2.ebuild b/sys-apps/hwloc/hwloc-1.6.2.ebuild
new file mode 100644
index 000000000000..aa482773a020
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.6.2.ebuild,v 1.1 2013/03/21 04:33:07 alexxy Exp $
+
+EAPI=5
+
+inherit multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="cairo debug +numa +pci plugins svg static-libs xml X"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ pci? (
+ sys-apps/pciutils
+ x11-libs/libpciaccess
+ )
+ plugins? ( sys-devel/libtool )
+ numa? ( sys-process/numactl )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_configure() {
+ export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable cairo) \
+ $(use_enable debug) \
+ $(use_enable pci) \
+ $(use_enable pci libpci) \
+ $(use_enable plugins) \
+ $(use_enable numa libnuma) \
+ $(use_enable static-libs static) \
+ $(use_enable xml libxml2) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la
+ use plugins && rm -f "${D}"/usr/$(get_libdir)/${PN}/*.la
+ fi
+}