summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-01-10 06:51:37 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-01-10 06:51:37 +0000
commit4619b8cbd8205576e2d4effaf428f8497c4fff47 (patch)
tree61495bf847f11aeb6cbe2f4df3a52d2e3c802de6
parentnew ebuild (diff)
downloadgentoo-2-4619b8cbd8205576e2d4effaf428f8497c4fff47.tar.gz
gentoo-2-4619b8cbd8205576e2d4effaf428f8497c4fff47.tar.bz2
gentoo-2-4619b8cbd8205576e2d4effaf428f8497c4fff47.zip
New version
-rw-r--r--media-libs/gst-plugins/files/digest-gst-plugins-0.5.11
-rw-r--r--media-libs/gst-plugins/files/gst-plugins-0.5.1-never-return-on-oss-busy.patch42
-rw-r--r--media-libs/gstreamer/ChangeLog7
-rw-r--r--media-libs/gstreamer/files/digest-gstreamer-0.5.11
-rw-r--r--media-libs/gstreamer/files/gstreamer-0.5.1-no-rm-html.devhelp.patch17
-rw-r--r--media-libs/gstreamer/gstreamer-0.5.1.ebuild72
6 files changed, 139 insertions, 1 deletions
diff --git a/media-libs/gst-plugins/files/digest-gst-plugins-0.5.1 b/media-libs/gst-plugins/files/digest-gst-plugins-0.5.1
new file mode 100644
index 000000000000..7b15d641eb53
--- /dev/null
+++ b/media-libs/gst-plugins/files/digest-gst-plugins-0.5.1
@@ -0,0 +1 @@
+MD5 1e41a9836681326798db2333d631fd38 gst-plugins-0.5.1.tar.gz 2664365
diff --git a/media-libs/gst-plugins/files/gst-plugins-0.5.1-never-return-on-oss-busy.patch b/media-libs/gst-plugins/files/gst-plugins-0.5.1-never-return-on-oss-busy.patch
new file mode 100644
index 000000000000..9ec6a5545651
--- /dev/null
+++ b/media-libs/gst-plugins/files/gst-plugins-0.5.1-never-return-on-oss-busy.patch
@@ -0,0 +1,42 @@
+--- gst-plugins-0.5.0/sys/oss/gstosscommon.c.orig 2002-12-27 08:58:32.000000000 +0200
++++ gst-plugins-0.5.0/sys/oss/gstosscommon.c 2002-12-27 09:01:44.000000000 +0200
+@@ -279,9 +279,23 @@
+ GST_INFO (GST_CAT_PLUGIN_INFO, "common: attempting to open sound device");
+
+ /* first try to open the sound card */
+- /* FIXME: this code is dubious, why do we need to open and close this ?*/
++ /* FIXME: This code is dubious, why do we need to open and close this ?
++ * For linux at least this causes the second open to never return
++ * if the device was already in use .. */
++#ifndef __linux__
+ if (mode == GST_OSSCOMMON_WRITE) {
++#endif
+ common->fd = open (common->device, O_WRONLY | O_NONBLOCK);
++#ifdef __linux__
++ if (common->fd >= 0) {
++ /* remove the non-blocking flag */
++ if(fcntl (common->fd, F_SETFL, 0) < 0) {
++ *error = g_strdup_printf ("osscommon: Can't make filedescriptor blocking for %s",
++ common->device);
++ return FALSE;
++ }
++ }
++#else
+ if (errno == EBUSY) {
+ g_warning ("osscommon: unable to open the sound device (in use ?)\n");
+ }
+@@ -295,9 +309,14 @@
+ else {
+ common->fd = open (common->device, O_RDONLY);
+ }
++#endif
+
+ if (common->fd < 0) {
+ switch (errno) {
++ case EBUSY:
++ *error = g_strdup_printf ("osscommon: Unable to open %s (in use ?)",
++ common->device);
++ break;
+ case EISDIR:
+ *error = g_strdup_printf ("osscommon: Device %s is a directory",
+ common->device);
diff --git a/media-libs/gstreamer/ChangeLog b/media-libs/gstreamer/ChangeLog
index 432ab1d1b926..42c3ab4178d5 100644
--- a/media-libs/gstreamer/ChangeLog
+++ b/media-libs/gstreamer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gstreamer
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.15 2002/12/30 04:33:06 satai Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.16 2003/01/10 06:47:26 lu_zero Exp $
+
+*gstreamer-0.5.1 (10 Jan 2003)
+
+ 10 Jan 2003; Luca Barbato <azarah@gentoo.org> gstreamer-0.5.1.ebuild :
+ Version bump
29 Dec 2002; Matthew Turk <satai@gentoo.org> gstreamer-0.3.4.ebuild
gstreamer-0.4.0-r1.ebuild gstreamer-0.4.1-r2.ebuild gstreamer-0.4.2-r1.ebuild
diff --git a/media-libs/gstreamer/files/digest-gstreamer-0.5.1 b/media-libs/gstreamer/files/digest-gstreamer-0.5.1
new file mode 100644
index 000000000000..85fcebda9eb5
--- /dev/null
+++ b/media-libs/gstreamer/files/digest-gstreamer-0.5.1
@@ -0,0 +1 @@
+MD5 3cb5958ce555eae3b06609f3308fc56c gstreamer-0.5.1.tar.bz2 1083948
diff --git a/media-libs/gstreamer/files/gstreamer-0.5.1-no-rm-html.devhelp.patch b/media-libs/gstreamer/files/gstreamer-0.5.1-no-rm-html.devhelp.patch
new file mode 100644
index 000000000000..9c85774456a6
--- /dev/null
+++ b/media-libs/gstreamer/files/gstreamer-0.5.1-no-rm-html.devhelp.patch
@@ -0,0 +1,17 @@
+--- gstreamer-0.5.1/docs/devhelp/Makefile.in.org 2003-01-10 07:35:18.000000000 +0100
++++ gstreamer-0.5.1/docs/devhelp/Makefile.in 2003-01-10 07:35:30.000000000 +0100
+@@ -271,12 +271,12 @@
+ $(PYTHON) ./html2xml.py ../gst/html
+ sed 's@base=""@base="@HTML_DIR@/gstreamer-@GST_MAJORMINOR@"@g' html.devhelp > gstreamer-@GST_MAJORMINOR@.devhelp && \
+ perl -i -p -e 's/name="html"/name="gstreamer-@GST_MAJORMINOR@"/' gstreamer-@GST_MAJORMINOR@.devhelp && \
+- rm html.devhelp
++# rm html.devhelp
+ cd ../libs && make
+ $(PYTHON) ./html2xml.py ../libs/html
+ sed 's@base=""@base="@HTML_DIR@/gstreamer-libs-@GST_MAJORMINOR@"@g' html.devhelp > gstreamer-libs-@GST_MAJORMINOR@.devhelp && \
+ perl -i -p -e 's/name="html"/name="gstreamer-libs-@GST_MAJORMINOR@"/' gstreamer-libs-@GST_MAJORMINOR@.devhelp && \
+- rm html.devhelp
++# rm html.devhelp
+
+ gstreamer-@GST_MAJORMINOR@.devhelp: devhelp
+ gstreamer-libs-@GST_MAJORMINOR@.devhelp: devhelp
diff --git a/media-libs/gstreamer/gstreamer-0.5.1.ebuild b/media-libs/gstreamer/gstreamer-0.5.1.ebuild
new file mode 100644
index 000000000000..b982a8d15102
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-0.5.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/gstreamer-0.5.1.ebuild,v 1.1 2003/01/10 06:47:26 lu_zero Exp $
+
+inherit eutils flag-o-matic libtool
+
+IUSE="doc"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Streaming media framework"
+SRC_URI="mirror://sourceforge/gstreamer/${P}.tar.bz2"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+DEPEND=">=dev-libs/glib-2.0.4
+ >=dev-libs/libxml2-2.4
+ >=dev-libs/popt-1.5
+ doc? ( >=dev-util/gtk-doc-0.9
+ media-gfx/transfig
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ app-text/passivetex
+ app-text/xpdf
+ app-text/ghostscript )
+ x86? ( >=dev-lang/nasm-0.90 )
+ >=sys-libs/zlib-1.1.4"
+
+src_unpack() {
+ unpack ${A}
+
+ # Patch for problems compiling when specifying USE="doc"
+ # The problem is that gstreamer's docs import the wrong version
+ # (or different to ours) of app-text/docbook-xsl-stylesheets,
+ # and delete files it should not.
+ # <azarah@gentoo.org> (27 Dec 2002).
+ cd ${S}
+# epatch ${FILESDIR}/${P}-xsl-use-current.patch
+ epatch ${FILESDIR}/${P}-no-rm-html.devhelp.patch
+}
+
+src_compile() {
+ elibtoolize
+
+ strip-flags
+ replace-flags "-O3" "-O2"
+
+ local myconf=""
+ use doc \
+ && myconf="${myconf} --enable-docs-build" \
+ || myconf="${myconf} --disable-docs-build"
+
+ econf \
+ --with-configdir=/etc/gstreamer \
+ --disable-tests --disable-examples \
+ ${myconf} || die "./configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install () {
+ einstall || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog COPYING* DEVEL NEWS \
+ README RELEASE REQUIREMENTS TODO
+}
+
+pkg_postinst () {
+ gst-register
+}