summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-05 17:23:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-05 17:23:57 +0000
commit45efda3b83cc58eaf968dfcdd86f69d64b9013e1 (patch)
treef8c962282859fd2527f863436f902e75a9e569c5
parentRevbump (diff)
downloadgentoo-2-45efda3b83cc58eaf968dfcdd86f69d64b9013e1.tar.gz
gentoo-2-45efda3b83cc58eaf968dfcdd86f69d64b9013e1.tar.bz2
gentoo-2-45efda3b83cc58eaf968dfcdd86f69d64b9013e1.zip
Version bump.
(Portage version: 15751-svn/cvs/Linux x86_64)
-rw-r--r--dev-python/nose/ChangeLog8
-rw-r--r--dev-python/nose/nose-0.11.2.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index 84d5778b7c76..7af778e397c8 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.46 2010/02/27 21:13:14 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.47 2010/03/05 17:23:57 arfrever Exp $
+
+*nose-0.11.2 (05 Mar 2010)
+
+ 05 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +nose-0.11.2.ebuild:
+ Version bump.
27 Feb 2010; Fabian Groffen <grobian@gentoo.org> nose-0.11.1.ebuild:
Marked ~x64-macos, thanks Ramon van Alteren in bug #306705
diff --git a/dev-python/nose/nose-0.11.2.ebuild b/dev-python/nose/nose-0.11.2.ebuild
new file mode 100644
index 000000000000..fc1965e529d8
--- /dev/null
+++ b/dev-python/nose/nose-0.11.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.11.2.ebuild,v 1.1 2010/03/05 17:23:57 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/ http://code.google.com/p/python-nose/ http://pypi.python.org/pypi/nose https://bitbucket.org/jpellerin/nose/"
+SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )
+ test? ( dev-python/twisted )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="AUTHORS"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable tests and doc features that access the network
+ epatch "${FILESDIR}/${PN}-0.10.0-tests-nonetwork.patch"
+ epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd doc
+ mkdir -p .build/html .build/doctrees
+ sphinx-build . html || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install --install-data "${EPREFIX}/usr/share"
+
+ python_generate_wrapper_scripts -E -f -q "${D%/}${EPREFIX}/usr/bin/nosetests"
+
+ if use doc; then
+ dohtml -r -A txt doc/html/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}