summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-11-22 19:48:37 +0000
committerRick Farina <zerochaos@gentoo.org>2012-11-22 19:48:37 +0000
commit45b124f0507bf4204e2401fca9772956b5a952ab (patch)
treede6af7a3c5679c22959af3800cec872947aaffbf
parentAdding a patch to fix legend text with FLTK backend, thanks Thomas Ilnseher (... (diff)
downloadgentoo-2-45b124f0507bf4204e2401fca9772956b5a952ab.tar.gz
gentoo-2-45b124f0507bf4204e2401fca9772956b5a952ab.tar.bz2
gentoo-2-45b124f0507bf4204e2401fca9772956b5a952ab.zip
sorry about that, that commit was not meant for gentoo-x86, reverting.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/boost-1.49.0-r2.ebuild13
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 72de430e4299..668f23a09128 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.284 2012/11/22 19:42:17 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.285 2012/11/22 19:48:37 zerochaos Exp $
+
+ 22 Nov 2012; Rick Farina <zerochaos@gentoo.org> boost-1.49.0-r2.ebuild:
+ sorry about that, that commit was not meant for gentoo-x86, reverting.
22 Nov 2012; Rick Farina <zerochaos@gentoo.org> boost-1.49.0-r2.ebuild:
fix to parse MAKEOPTS jobs properly, same style as newer ebuilds
diff --git a/dev-libs/boost/boost-1.49.0-r2.ebuild b/dev-libs/boost/boost-1.49.0-r2.ebuild
index 083e75e22acb..d1581241c1d2 100644
--- a/dev-libs/boost/boost-1.49.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.49.0-r2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.49.0-r2.ebuild,v 1.4 2012/11/22 19:42:17 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.49.0-r2.ebuild,v 1.5 2012/11/22 19:48:37 zerochaos Exp $
EAPI="4"
PYTHON_DEPEND="python? *"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
-inherit flag-o-matic multilib multiprocessing python toolchain-funcs versionator
+inherit flag-o-matic multilib python toolchain-funcs versionator
MY_P=${PN}_$(replace_all_version_separators _)
@@ -124,10 +124,17 @@ src_configure() {
}
src_compile() {
+ local jobs
+ jobs=$( echo " ${MAKEOPTS} " | \
+ sed -e 's/ --jobs[= ]/ -j /g' \
+ -e 's/ -j \([1-9][0-9]*\)/ -j\1/g' \
+ -e 's/ -j\>/ -j1/g' | \
+ ( while read -d ' ' j; do if [[ "${j#-j}" = "$j" ]]; then continue; fi; jobs="${j#-j}"; done; echo ${jobs} ) )
+ if [[ "${jobs}" != "" ]]; then NUMJOBS="-j"${jobs}; fi
+
export BOOST_ROOT="${S}"
PYTHON_DIRS=""
MPI_PYTHON_MODULE=""
- NUMJOBS="-j$(makeopts_jobs)"
building() {
create_user-config.jam