summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-20 15:44:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-20 15:44:55 +0000
commit45520667b26e3ae9355bb22cf080def4d40f362e (patch)
tree50c23483bedfa292bcc47bf099584be7d9224215
parentReplace py26.py with a stub for python 2.5. (diff)
downloadgentoo-2-45520667b26e3ae9355bb22cf080def4d40f362e.tar.gz
gentoo-2-45520667b26e3ae9355bb22cf080def4d40f362e.tar.bz2
gentoo-2-45520667b26e3ae9355bb22cf080def4d40f362e.zip
Missing build dependencies x11-libs/libXt (for X11/Intrinsic.h) and x11-proto/xproto (X11/keysym.h). Thanks to fouDuBassan (Freenode, IRC) for reporting.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
-rw-r--r--app-editors/jed/ChangeLog9
-rw-r--r--app-editors/jed/jed-0.99.19.ebuild51
2 files changed, 36 insertions, 24 deletions
diff --git a/app-editors/jed/ChangeLog b/app-editors/jed/ChangeLog
index a2a5e3519b58..65cc7d656dcc 100644
--- a/app-editors/jed/ChangeLog
+++ b/app-editors/jed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/jed
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/ChangeLog,v 1.61 2011/03/20 16:37:13 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/ChangeLog,v 1.62 2012/05/20 15:44:55 ssuominen Exp $
+
+ 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> jed-0.99.19.ebuild:
+ Missing build dependencies x11-libs/libXt (for X11/Intrinsic.h) and
+ x11-proto/xproto (X11/keysym.h). Thanks to fouDuBassan (Freenode, IRC) for
+ reporting.
20 Mar 2011; Raúl Porcel <armin76@gentoo.org> jed-0.99.19.ebuild:
Add ~alpha
diff --git a/app-editors/jed/jed-0.99.19.ebuild b/app-editors/jed/jed-0.99.19.ebuild
index 02dfcc196754..679a8e2d11a1 100644
--- a/app-editors/jed/jed-0.99.19.ebuild
+++ b/app-editors/jed/jed-0.99.19.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.19.ebuild,v 1.7 2011/03/20 16:37:13 armin76 Exp $
-
-EAPI=3
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.19.ebuild,v 1.8 2012/05/20 15:44:55 ssuominen Exp $
+EAPI=4
inherit versionator
MY_P=${PN}-$(replace_version_separator 2 '-')
+
DESCRIPTION="Console S-Lang-based editor"
HOMEPAGE="http://www.jedsoft.org/jed/"
-SRC_URI="ftp://space.mit.edu/pub/davis/jed/v0.99/${MY_P}.tar.bz2"
+SRC_URI="ftp://space.mit.edu/pub/davis/jed/v${PV%.*}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -17,40 +17,47 @@ KEYWORDS="~alpha amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="X gpm xft"
RDEPEND=">=sys-libs/slang-2
- X? ( x11-libs/libX11
- xft? ( x11-libs/libXext
+ gpm? ( sys-libs/gpm )
+ X? (
+ x11-libs/libX11
+ xft? (
+ >=media-libs/freetype-2
+ x11-libs/libXext
x11-libs/libXft
x11-libs/libXrender
- >=media-libs/freetype-2.0 ) )
- gpm? ( sys-libs/gpm )"
-DEPEND="${RDEPEND}"
+ )
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-libs/libXt
+ x11-proto/xproto
+ )"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_configure() {
- export JED_ROOT="${EPREFIX}/usr/share/jed"
+ export JED_ROOT="${EPREFIX}"/usr/share/jed
econf \
$(use_enable gpm) \
$(use_enable xft)
}
src_compile() {
- emake || die
- if use X; then
- emake xjed || die
- fi
+ emake
+ use X && emake xjed
}
src_install() {
- emake -j1 DESTDIR="${D}" install || die
+ emake -j1 DESTDIR="${D}" install
- dodoc INSTALL INSTALL.unx README changes.txt || die
- doinfo info/jed* || die
+ dodoc changes.txt INSTALL{,.unx} README
+ doinfo info/jed*
insinto /etc
- doins lib/jed.conf || die
+ doins lib/jed.conf
# replace IDE mode with EMACS mode
- sed -i -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' \
- "${ED}"/etc/jed.conf || die "patching jed.conf failed"
+ sed -i \
+ -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' \
+ "${ED}"/etc/jed.conf || die
}