summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-01-15 13:39:01 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-01-15 13:39:01 +0000
commit44ef4cdbb827308a5e8009be334bb01812e6245b (patch)
treea9528a682337ba4884a1575e23e04faae084197c
parentenable harfbuzz by default, as upstream does, by Nikoli, bug #452210 (diff)
downloadgentoo-2-44ef4cdbb827308a5e8009be334bb01812e6245b.tar.gz
gentoo-2-44ef4cdbb827308a5e8009be334bb01812e6245b.tar.bz2
gentoo-2-44ef4cdbb827308a5e8009be334bb01812e6245b.zip
Version bump to 1.3.9 which offers several filter improvements, new reconfiguration options and DragonFly BSD support. As requested by LINX network engineer Moyaze Shivji.
(Portage version: 2.1.11.41/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
-rw-r--r--net-misc/bird/ChangeLog11
-rw-r--r--net-misc/bird/bird-1.3.9.ebuild62
2 files changed, 71 insertions, 2 deletions
diff --git a/net-misc/bird/ChangeLog b/net-misc/bird/ChangeLog
index 71637013ca6c..d4143a8e7c69 100644
--- a/net-misc/bird/ChangeLog
+++ b/net-misc/bird/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/bird
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.22 2012/08/15 10:15:19 chainsaw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.23 2013/01/15 13:39:01 chainsaw Exp $
+
+*bird-1.3.9 (15 Jan 2013)
+
+ 15 Jan 2013; Tony Vroon <chainsaw@gentoo.org> +bird-1.3.9.ebuild:
+ Version bump to 1.3.9 which offers several filter improvements, new
+ reconfiguration options and DragonFly BSD support. As requested by LINX
+ network engineer Moyaze Shivji.
*bird-1.3.8-r2 (15 Aug 2012)
diff --git a/net-misc/bird/bird-1.3.9.ebuild b/net-misc/bird/bird-1.3.9.ebuild
new file mode 100644
index 000000000000..bc177ddd58e2
--- /dev/null
+++ b/net-misc/bird/bird-1.3.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/bird-1.3.9.ebuild,v 1.1 2013/01/15 13:39:01 chainsaw Exp $
+
+EAPI=4
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_prepare() {
+ mkdir ipv6
+ tar c --exclude ipv6 . | tar x -C ipv6
+}
+
+src_configure() {
+ econf \
+ --enable-client \
+ --disable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+
+ if use ipv6; then
+ cd ipv6
+ econf \
+ --enable-client \
+ --enable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+ fi
+}
+
+src_compile() {
+ emake
+ if use ipv6; then
+ cd ipv6
+ emake
+ fi
+}
+
+src_install() {
+ if use ipv6; then
+ newbin ipv6/birdc birdc6
+ newsbin ipv6/bird bird6
+ newinitd "${FILESDIR}/initd-v6-${PN}-1.3.8" bird6
+ fi
+ dobin birdc
+ dosbin bird
+ newinitd "${FILESDIR}/initd-v4-${PN}-1.3.8" bird
+ dodoc doc/bird.conf.example
+}