summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-30 12:12:04 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-30 12:12:04 +0000
commit435e9c16295e2f605c0d64f47cafc55e317c88c1 (patch)
tree76f23c1e90b972ee933b844ed751c5db64e00005
parentFix build/running when python3 is main interpreter, bug #401047 by Alexander ... (diff)
downloadgentoo-2-435e9c16295e2f605c0d64f47cafc55e317c88c1.tar.gz
gentoo-2-435e9c16295e2f605c0d64f47cafc55e317c88c1.tar.bz2
gentoo-2-435e9c16295e2f605c0d64f47cafc55e317c88c1.zip
Fix building against qt-4.8, #399829
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
-rw-r--r--sci-visualization/qtiplot/ChangeLog6
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.8.9-qt48.patch29
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.8.9-r1.ebuild5
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.8.9.ebuild7
4 files changed, 41 insertions, 6 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
index a62a92148227..95e63c9a8e5b 100644
--- a/sci-visualization/qtiplot/ChangeLog
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/qtiplot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.87 2012/01/22 14:20:07 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.88 2012/01/30 12:12:04 jlec Exp $
+
+ 30 Jan 2012; Justin Lecher <jlec@gentoo.org> qtiplot-0.9.8.9.ebuild,
+ qtiplot-0.9.8.9-r1.ebuild, +files/qtiplot-0.9.8.9-qt48.patch:
+ Fix building against qt-4.8, #399829
*qtiplot-0.9.8.9-r1 (22 Jan 2012)
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.8.9-qt48.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.8.9-qt48.patch
new file mode 100644
index 000000000000..31c8a5ee7af2
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.8.9-qt48.patch
@@ -0,0 +1,29 @@
+ 3rdparty/qwtplot3d/include/qwt3d_openglhelper.h | 2 ++
+ qtiplot/src/plot3D/Cone3D.cpp | 1 +
+ 2 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/3rdparty/qwtplot3d/include/qwt3d_openglhelper.h b/3rdparty/qwtplot3d/include/qwt3d_openglhelper.h
+index 0ee80de..3d02e3f 100755
+--- a/3rdparty/qwtplot3d/include/qwt3d_openglhelper.h
++++ b/3rdparty/qwtplot3d/include/qwt3d_openglhelper.h
+@@ -8,6 +8,8 @@
+ #include <QtOpenGL/qgl.h>
+ #endif
+
++#include <GL/glu.h>
++
+ namespace Qwt3D
+ {
+
+diff --git a/qtiplot/src/plot3D/Cone3D.cpp b/qtiplot/src/plot3D/Cone3D.cpp
+index 16df12d..169d5c7 100755
+--- a/qtiplot/src/plot3D/Cone3D.cpp
++++ b/qtiplot/src/plot3D/Cone3D.cpp
+@@ -27,6 +27,7 @@
+ * *
+ ***************************************************************************/
+ #include <math.h>
++#include <GL/glu.h>
+ #include "qwt3d_color.h"
+ #include "qwt3d_plot.h"
+ #include <qwt3d_curve.h>
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.8.9-r1.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.8.9-r1.ebuild
index efc576e12a8f..c707e8b34769 100644
--- a/sci-visualization/qtiplot/qtiplot-0.9.8.9-r1.ebuild
+++ b/sci-visualization/qtiplot/qtiplot-0.9.8.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.8.9-r1.ebuild,v 1.1 2012/01/22 14:20:07 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.8.9-r1.ebuild,v 1.2 2012/01/30 12:12:04 jlec Exp $
EAPI=3
@@ -58,6 +58,7 @@ RDEPEND="${CDEPEND}
PATCHES=(
"${DISTDIR}/${P}-origin.patch.bz2"
"${FILESDIR}/${P}-origin-2.patch"
+ "${FILESDIR}/${P}-qt48.patch"
"${FILESDIR}/${PN}-0.9.8.8-system-gl2ps.patch"
"${FILESDIR}/${PN}-0.9.7.10-dont-install-qwt.patch"
"${FILESDIR}/${PN}-0.9.8.6-gold.patch"
@@ -95,7 +96,7 @@ src_prepare() {
QWT_LIBS = \$\$QTI_ROOT/3rdparty/qwt/lib/libqwt.a
QWT3D_INCLUDEPATH = \$\$QTI_ROOT/3rdparty/qwtplot3d/include
QWT3D_LIBS = \$\$QTI_ROOT/3rdparty/qwtplot3d/lib/libqwtplot3d.a
- SYS_LIBS = -lgl2ps ${mylibs}
+ SYS_LIBS = -lgl2ps ${mylibs} -lGLU
PYTHON = python
LUPDATE = lupdate
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.8.9.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.8.9.ebuild
index 2b6d21309452..f101257a1e14 100644
--- a/sci-visualization/qtiplot/qtiplot-0.9.8.9.ebuild
+++ b/sci-visualization/qtiplot/qtiplot-0.9.8.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.8.9.ebuild,v 1.1 2011/12/22 15:45:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.8.9.ebuild,v 1.2 2012/01/30 12:12:04 jlec Exp $
EAPI=3
@@ -53,6 +53,7 @@ RDEPEND="${CDEPEND}
python? ( dev-python/PyQt4[X] )"
PATCHES=(
+ "${FILESDIR}/${P}-qt48.patch"
"${FILESDIR}/${PN}-0.9.8.8-system-gl2ps.patch"
"${FILESDIR}/${PN}-0.9.7.10-dont-install-qwt.patch"
"${FILESDIR}/${PN}-0.9.8.6-gold.patch"
@@ -90,7 +91,7 @@ src_prepare() {
QWT_LIBS = \$\$QTI_ROOT/3rdparty/qwt/lib/libqwt.a
QWT3D_INCLUDEPATH = \$\$QTI_ROOT/3rdparty/qwtplot3d/include
QWT3D_LIBS = \$\$QTI_ROOT/3rdparty/qwtplot3d/lib/libqwtplot3d.a
- SYS_LIBS = -lgl2ps ${mylibs}
+ SYS_LIBS = -lgl2ps ${mylibs} -lGLU
PYTHON = python
LUPDATE = lupdate