summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-06 04:46:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-06 04:46:45 +0000
commit406880a5ecfcf929855302076e3ee58732bf77f8 (patch)
treef825142bea8960f674c74c9c965b435eb3a5212b
parentver bumpage (diff)
downloadgentoo-2-406880a5ecfcf929855302076e3ee58732bf77f8.tar.gz
gentoo-2-406880a5ecfcf929855302076e3ee58732bf77f8.tar.bz2
gentoo-2-406880a5ecfcf929855302076e3ee58732bf77f8.zip
Changed src_install () to src_install()
-rw-r--r--app-admin/conserver/conserver-8.0.9.ebuild18
-rw-r--r--app-arch/pax/pax-3.3.4.ebuild13
-rw-r--r--app-crypt/bcwipe/bcwipe-1.2_p3.ebuild19
3 files changed, 24 insertions, 26 deletions
diff --git a/app-admin/conserver/conserver-8.0.9.ebuild b/app-admin/conserver/conserver-8.0.9.ebuild
index 8864e8ece75c..73b4f697b163 100644
--- a/app-admin/conserver/conserver-8.0.9.ebuild
+++ b/app-admin/conserver/conserver-8.0.9.ebuild
@@ -1,25 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conserver/conserver-8.0.9.ebuild,v 1.4 2004/01/23 14:46:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conserver/conserver-8.0.9.ebuild,v 1.5 2004/03/06 04:42:39 vapier Exp $
-DESCRIPTION="Conserver - Serial Console Manager"
+DESCRIPTION="Serial Console Manager"
HOMEPAGE="http://www.conserver.com/"
SRC_URI="ftp://ftp.conserver.com/conserver/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86 sparc alpha ia64"
-
IUSE="pam ssl tcpd"
-DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
- pam? ( sys-libs/pam )
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
+ pam? ( sys-libs/pam )
tcpd? ( sys-apps/tcp-wrappers )"
src_compile() {
econf \
- $(use_with ssl openssl) \
- $(use_with pam) \
- $(use_with tcpd libwrap) \
+ `use_with ssl openssl` \
+ `use_with pam` \
+ `use_with tcpd libwrap` \
--with-logfile=/var/log/conserver.log \
--with-pidfile=/var/run/conserver.pid \
--with-cffile=conserver/conserver.cf \
@@ -30,7 +30,7 @@ src_compile() {
emake || die "compile failed"
}
-src_install () {
+src_install() {
einstall exampledir=${D}/usr/share/doc/${PF}/examples || die "problem with install"
## create data directory
diff --git a/app-arch/pax/pax-3.3.4.ebuild b/app-arch/pax/pax-3.3.4.ebuild
index 71591d3372be..32e787b1dcdb 100644
--- a/app-arch/pax/pax-3.3.4.ebuild
+++ b/app-arch/pax/pax-3.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pax/pax-3.3.4.ebuild,v 1.4 2004/02/22 06:08:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pax/pax-3.3.4.ebuild,v 1.5 2004/03/06 04:43:43 vapier Exp $
inherit eutils rpm
@@ -11,8 +11,8 @@ DESCRIPTION="pax (Portable Archive eXchange) is the POSIX standard archive tool"
HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/bin/pax/"
SRC_URI="ftp://rpmfind.net/linux/contrib/libc6/SRPMS/${MY_PS}.src.rpm"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
IUSE=""
@@ -28,13 +28,8 @@ src_unpack() {
epatch ${WORKDIR}/pax-3.3-bzip2.patch
}
-src_compile () {
- econf || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- dobin src/pax
+src_install() {
+ dobin src/pax || die
doman src/pax.1
dodoc AUTHORS ChangeLog NEWS README THANKS
}
diff --git a/app-crypt/bcwipe/bcwipe-1.2_p3.ebuild b/app-crypt/bcwipe/bcwipe-1.2_p3.ebuild
index 1f0e61138929..3c5008631ec1 100644
--- a/app-crypt/bcwipe/bcwipe-1.2_p3.ebuild
+++ b/app-crypt/bcwipe/bcwipe-1.2_p3.ebuild
@@ -1,22 +1,25 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.2_p3.ebuild,v 1.3 2003/06/29 22:18:38 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.2_p3.ebuild,v 1.4 2004/03/06 04:46:45 vapier Exp $
-S=${WORKDIR}/${PN}
DESCRIPTION="BCWipe secure file removal utility"
+HOMEPAGE="http://www.jetico.com/"
SRC_URI="http://www.jetico.com/linux/BCWipe-${PV/_p/-}.tar.gz"
-HOMEPAGE="http://www.jetico.com"
-SLOT="0"
+
LICENSE="bestcrypt"
+SLOT="0"
+KEYWORDS="x86"
+
DEPEND="virtual/glibc"
RDEPEND=""
-KEYWORDS="x86"
+
+S=${WORKDIR}/${PN}
src_compile() {
emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "Make failed"
}
-src_install () {
+src_install() {
+ dobin bcwipe || die
doman bcwipe.1
- exeinto /bin ; doexe bcwipe
}