summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-08-15 11:31:57 +0000
committerTorsten Veller <tove@gentoo.org>2009-08-15 11:31:57 +0000
commit404bd9837402997d3e6235d68e530ad64c655af2 (patch)
treed0182af8a48deb0db1aecf57fbf38e8f60a46fba
parentVersion bump. Fixes APOP design error (CVE-2007-1558)(#281559) (diff)
downloadgentoo-2-404bd9837402997d3e6235d68e530ad64c655af2.tar.gz
gentoo-2-404bd9837402997d3e6235d68e530ad64c655af2.tar.bz2
gentoo-2-404bd9837402997d3e6235d68e530ad64c655af2.zip
Bump to fix segmentation fault (#280760)
(Portage version: 2.2_rc38/cvs/Linux x86_64)
-rw-r--r--net-mail/fetchmail/ChangeLog8
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.11-r1.ebuild111
-rw-r--r--net-mail/fetchmail/files/6.3.11-fix-free-corruption.patch15
3 files changed, 133 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 08439dc465ed..6d9715c0f97f 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/fetchmail
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.165 2009/08/10 22:19:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.166 2009/08/15 11:31:56 tove Exp $
+
+*fetchmail-6.3.11-r1 (15 Aug 2009)
+
+ 15 Aug 2009; Torsten Veller <tove@gentoo.org>
+ +files/6.3.11-fix-free-corruption.patch, +fetchmail-6.3.11-r1.ebuild:
+ Bump to fix segmentation fault (#280760)
10 Aug 2009; Markus Meier <maekke@gentoo.org> fetchmail-6.3.11.ebuild:
amd64 stable, bug #280537
diff --git a/net-mail/fetchmail/fetchmail-6.3.11-r1.ebuild b/net-mail/fetchmail/fetchmail-6.3.11-r1.ebuild
new file mode 100644
index 000000000000..a36ae06760dc
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.11-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.11-r1.ebuild,v 1.1 2009/08/15 11:31:56 tove Exp $
+
+EAPI=2
+
+inherit multilib python eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl nls kerberos krb4 hesiod"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( app-crypt/mit-krb5 )
+ krb4? ( <app-crypt/mit-krb5-1.7[krb4] )
+ nls? ( virtual/libintl )
+ elibc_FreeBSD? ( sys-libs/com_err )
+ virtual/python"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_prepare() {
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch "${FILESDIR}"/${PN}-6.2.5-broken-headers.patch
+
+ epatch "${FILESDIR}"/${PV}-fix-free-corruption.patch
+
+ # dont compile during src_install
+ : > "${S}"/py-compile
+}
+
+src_configure() {
+# PYTHON=: \
+ econf \
+ --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ $(use_with krb4 kerberos) \
+ $(use_with ssl) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+}
+
+src_install() {
+ # dir for pidfile
+ dodir /var/run/${PN} || die "dodir failed"
+ keepdir /var/run/${PN}
+ fowners ${PN}:${PN} /var/run/${PN} || die "fowners failed"
+
+ # fetchmail's homedir (holds fetchmail's .fetchids)
+ dodir /var/lib/${PN} || die "dodir failed"
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN} || die "fowners failed"
+ fperms 700 /var/lib/${PN} || die "fperms failed"
+
+ emake DESTDIR="${D}" install || die
+ python_need_rebuild
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO || die
+
+ newinitd "${FILESDIR}"/fetchmail.new fetchmail || die
+ newconfd "${FILESDIR}"/conf.d-fetchmail fetchmail || die
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ elog
+ elog "You will not be able to use fetchmailconf(1), because you"
+ elog "don't seem to have Python with tkinter support."
+ elog
+ elog "If you want to be able to use fetchmailconf(1), do the following:"
+ elog " 1. Add 'tk' to the USE variable in /etc/make.conf."
+ elog " 2. (Re-)merge Python."
+ elog
+ fi
+
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages
+}
diff --git a/net-mail/fetchmail/files/6.3.11-fix-free-corruption.patch b/net-mail/fetchmail/files/6.3.11-fix-free-corruption.patch
new file mode 100644
index 000000000000..d84d50cc8c94
--- /dev/null
+++ b/net-mail/fetchmail/files/6.3.11-fix-free-corruption.patch
@@ -0,0 +1,15 @@
+--- socket.c
++++ socket.c
+@@ -628,9 +628,10 @@
+ report(stdout, GT_("Unknown Issuer CommonName\n"));
+ }
+ if ((i = X509_NAME_get_text_by_NID(subj, NID_commonName, buf, sizeof(buf))) != -1) {
+- if (outlevel >= O_VERBOSE)
++ if (outlevel >= O_VERBOSE) {
+ report(stdout, GT_("Server CommonName: %s\n"), (tt = sdump(buf, i)));
+- xfree(tt);
++ xfree(tt);
++ }
+ if ((size_t)i >= sizeof(buf) - 1) {
+ /* Possible truncation. In this case, this is a DNS name, so this
+ * is really bad. We do not tolerate this even in the non-strict case. */