summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-17 15:56:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-17 15:56:34 +0000
commit400b096e132239dc6ce914d02131f1254b16bf0d (patch)
treef99b24ae2da1106045e1c9742695ce76119a8e36
parentThe consolekit flag can be satisfied by new enough systemd as well. (diff)
downloadgentoo-2-400b096e132239dc6ce914d02131f1254b16bf0d.tar.gz
gentoo-2-400b096e132239dc6ce914d02131f1254b16bf0d.tar.bz2
gentoo-2-400b096e132239dc6ce914d02131f1254b16bf0d.zip
remove custom-cpuopts option: if anything breaks the build we can disallow it with REQUIRED_USE
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
-rw-r--r--media-video/mplayer/ChangeLog6
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild35
2 files changed, 11 insertions, 30 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 44a7bd78e1f4..eb250a882af0 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/mplayer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.820 2011/12/17 15:52:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.821 2011/12/17 15:56:34 aballier Exp $
+
+ 17 Dec 2011; Alexis Ballier <aballier@gentoo.org> mplayer-9999.ebuild:
+ remove custom-cpuopts option: if anything breaks the build we can disallow it
+ with REQUIRED_USE
17 Dec 2011; Alexis Ballier <aballier@gentoo.org> mplayer-9999.ebuild:
remove dead code: faac + bindist is disallowed by REQUIRED_USE
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index e9cdc1bc5623..1a7efee6c851 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.113 2011/12/17 15:52:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.114 2011/12/17 15:56:34 aballier Exp $
EAPI=4
@@ -11,7 +11,7 @@ ESVN_REPO_URI="svn://svn.mplayerhq.hu/mplayer/trunk"
inherit toolchain-funcs eutils flag-o-matic multilib base ${SVN_ECLASS}
IUSE="3dnow 3dnowext +a52 aalib +alsa altivec aqua +ass bidi bindist bl bluray
-bs2b cddb +cdio cdparanoia cpudetection custom-cpuopts debug dga
+bs2b cddb +cdio cdparanoia cpudetection debug dga
directfb doc +dts +dv dvb +dvd +dvdnav dxr3 +enca +encode esd faac +faad fbcon
ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
libcaca libmpeg2 lirc +live lzo mad md5sum +mmx mmxext mng +mp3 nas
@@ -208,23 +208,6 @@ pkg_setup() {
ewarn "mplayer for this system. Also, if your compile fails, try"
ewarn "disabling this use flag."
fi
-
- if use custom-cpuopts; then
- ewarn
- ewarn "You are using the custom-cpuopts flag which will"
- ewarn "specifically allow you to enable / disable certain"
- ewarn "CPU optimizations."
- ewarn
- ewarn "Most desktop users won't need this functionality, but it"
- ewarn "is included for corner cases like cross-compiling and"
- ewarn "certain profiles. If unsure, disable this flag and MPlayer"
- ewarn "will automatically detect and use your available CPU"
- ewarn "optimizations."
- ewarn
- ewarn "Using this flag means your build is unsupported, so"
- ewarn "please make sure your CPU optimization use flags (3dnow"
- ewarn "3dnowext mmx mmxext sse sse2 ssse3) are properly set."
- fi
}
src_unpack() {
@@ -520,16 +503,10 @@ src_configure() {
# Platform specific flags, hardcoded on amd64 (see below)
use cpudetection && myconf+=" --enable-runtime-cpudetection"
- # Turning off CPU optimizations usually will break the build.
- # However, this use flag, if enabled, will allow users to completely
- # specify which ones to use. If disabled, mplayer will automatically
- # enable all CPU optimizations that the host build supports.
- if use custom-cpuopts; then
- uses="3dnow 3dnowext altivec mmx mmxext shm sse sse2 ssse3"
- for i in ${uses}; do
- myconf+=" $(use_enable ${i})"
- done
- fi
+ uses="3dnow 3dnowext altivec mmx mmxext shm sse sse2 ssse3"
+ for i in ${uses}; do
+ myconf+=" $(use_enable ${i})"
+ done
use debug && myconf+=" --enable-debug=3"