summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-12-05 10:58:27 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-12-05 10:58:27 +0000
commit3cccc69123b2c5a52b36292f5e094ef508dee2b4 (patch)
tree0034b95e6a982988219c722463aa9ba3d139ce66
parentBump patchset to fix HPPA patch (diff)
downloadgentoo-2-3cccc69123b2c5a52b36292f5e094ef508dee2b4.tar.gz
gentoo-2-3cccc69123b2c5a52b36292f5e094ef508dee2b4.tar.bz2
gentoo-2-3cccc69123b2c5a52b36292f5e094ef508dee2b4.zip
bump
(Portage version: 2.1.4_rc4)
-rw-r--r--dev-scheme/hop/ChangeLog16
-rw-r--r--dev-scheme/hop/files/digest-hop-1.8.13
-rw-r--r--dev-scheme/hop/hop-1.8.1.ebuild29
3 files changed, 46 insertions, 2 deletions
diff --git a/dev-scheme/hop/ChangeLog b/dev-scheme/hop/ChangeLog
index 7d95bb788a51..acef08e12085 100644
--- a/dev-scheme/hop/ChangeLog
+++ b/dev-scheme/hop/ChangeLog
@@ -1,12 +1,24 @@
# ChangeLog for dev-scheme/hop
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/ChangeLog,v 1.3 2007/09/27 08:24:52 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/ChangeLog,v 1.4 2007/12/05 10:58:27 hkbst Exp $
+
+*hop-1.8.1 (05 Dec 2007)
+
+ 05 Dec 2007; Marijn Schouten <hkBst@gentoo.org> +hop-1.8.1.ebuild:
+ 1- A new packaging system (Hz) that allows end users to
+ run and install Hop programs with a single click.
+ 2- Support for MathML (with an extension that allows users to use TeX
+ syntax).
+ 3- Support for SVG (with an extension that allows users to inline SVG
+ external images inside Hop documents).
+ 4- Pre-compiled JVM version is now fully compatible with the native
+ version.
27 Sep 2007; Christian Faulhammer <opfer@gentoo.org> ChangeLog, Manifest:
fixing Changelog, regenerating Manifest
27 Sep 2007; Christian Faulhammer <opfer@gentoo.org> hop-1.7.0.ebuild:
- keywording ~x86, requested by kiuma on gentoo-lisp mailint list
+ keywording ~x86, requested by kiuma on gentoo-lisp mailing list
*hop-1.7.0 (25 Sep 2007)
diff --git a/dev-scheme/hop/files/digest-hop-1.8.1 b/dev-scheme/hop/files/digest-hop-1.8.1
new file mode 100644
index 000000000000..560a57f3c3d7
--- /dev/null
+++ b/dev-scheme/hop/files/digest-hop-1.8.1
@@ -0,0 +1,3 @@
+MD5 04179136b209c522866c2ee43c8894a0 hop-1.8.1.tar.gz 1649478
+RMD160 614efb1a6186cc46ca512ba9c40f6954102a77fc hop-1.8.1.tar.gz 1649478
+SHA256 50b38b01902c19a8f93d5e8ee73d8ce0397af7a516c5837b6791e4633157b22d hop-1.8.1.tar.gz 1649478
diff --git a/dev-scheme/hop/hop-1.8.1.ebuild b/dev-scheme/hop/hop-1.8.1.ebuild
new file mode 100644
index 000000000000..190517fb3a93
--- /dev/null
+++ b/dev-scheme/hop/hop-1.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/hop-1.8.1.ebuild,v 1.1 2007/12/05 10:58:27 hkbst Exp $
+
+inherit multilib
+
+DESCRIPTION="Hop is a higher-order language for programming interactive web applications such as web agendas, web galleries, music players, etc. that is implemented as a Web broker"
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Bigloo/bigloo.html"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Hop/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-scheme/bigloo-3.0b"
+
+IUSE=""
+
+src_compile() {
+ # Hop doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure --prefix=/usr --libdir=/usr/$(get_libdir) || die "configure failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+}