summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-19 11:31:13 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-19 11:31:13 +0000
commit39c3a22d8c1537ddc7888546fcfa72e6bb312ead (patch)
tree75a3a66b8aaef1363b1d3582b1b44ef9e48d6079
parentRemove older unstable and buggy versions (diff)
downloadgentoo-2-39c3a22d8c1537ddc7888546fcfa72e6bb312ead.tar.gz
gentoo-2-39c3a22d8c1537ddc7888546fcfa72e6bb312ead.tar.bz2
gentoo-2-39c3a22d8c1537ddc7888546fcfa72e6bb312ead.zip
sci-biology/vcftools: Version BUmp, fix build system
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
-rw-r--r--sci-biology/vcftools/ChangeLog8
-rw-r--r--sci-biology/vcftools/files/vcftools-0.1.8-buildsystem.patch50
-rw-r--r--sci-biology/vcftools/vcftools-0.1.8.ebuild47
3 files changed, 104 insertions, 1 deletions
diff --git a/sci-biology/vcftools/ChangeLog b/sci-biology/vcftools/ChangeLog
index aa0c44d7c6cb..27ec7612ae59 100644
--- a/sci-biology/vcftools/ChangeLog
+++ b/sci-biology/vcftools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/vcftools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/vcftools/ChangeLog,v 1.3 2012/01/02 21:51:52 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vcftools/ChangeLog,v 1.4 2012/07/19 11:31:13 jlec Exp $
+
+*vcftools-0.1.8 (19 Jul 2012)
+
+ 19 Jul 2012; Justin Lecher <jlec@gentoo.org> +vcftools-0.1.8.ebuild,
+ +files/vcftools-0.1.8-buildsystem.patch:
+ Version BUmp, fix build system
*vcftools-0.1.7 (02 Jan 2012)
diff --git a/sci-biology/vcftools/files/vcftools-0.1.8-buildsystem.patch b/sci-biology/vcftools/files/vcftools-0.1.8-buildsystem.patch
new file mode 100644
index 000000000000..37caee9c28dd
--- /dev/null
+++ b/sci-biology/vcftools/files/vcftools-0.1.8-buildsystem.patch
@@ -0,0 +1,50 @@
+ cpp/Makefile | 16 +++++++++++-----
+ 1 files changed, 11 insertions(+), 5 deletions(-)
+
+diff --git a/cpp/Makefile b/cpp/Makefile
+index 42d03e4..2f4d4f6 100644
+--- a/cpp/Makefile
++++ b/cpp/Makefile
+@@ -3,7 +3,7 @@
+ # ($Revision: 1.1 $)
+
+ # Compiler
+-CPP = g++
++CPP ?= g++
+ # Output executable
+ EXECUTABLE = vcftools
+ # Flag used to turn on compilation of PCA routines
+@@ -11,7 +11,7 @@ ifndef VCFTOOLS_PCA
+ VCFTOOLS_PCA = 0
+ endif
+ # Compiler flags
+-CPPFLAGS = -O2 -Wall -Wextra
++CPPFLAGS = -Wall -Wextra
+ #CPPFLAGS = -g
+ # Included libraries (zlib)
+ LIB = -lz
+@@ -28,15 +28,21 @@ ifeq ($(VCFTOOLS_PCA), 1)
+ # Define flag for PCA routine compilation
+ CPPFLAGS += -DVCFTOOLS_PCA
+ # Add LAPACK library
+- LIB += -llapack
++ LIB += `pkg-config --libs lapack`
+ # Add PCA source code
+ SOURCES += dgeev.cpp
+ endif
+
++objects := $(patsubst %.cpp,%.o,$(SOURCES))
++
+ all: vcftools
+
+-vcftools: $(SOURCES)
+- $(CPP) $(CPPFLAGS) $(SOURCES) -o $@ $(LIB)
++vcftools: $(objects)
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) $(objects) -o $@ $(LIB)
++
++.cpp.o: $(SOURCES)
++ $(CXX) -c $(CXXFLAGS) $(CPPFLAGS) -o $@ $<
++
+ ifdef BINDIR
+ cp $(CURDIR)/$@ $(BINDIR)/$@
+ endif
diff --git a/sci-biology/vcftools/vcftools-0.1.8.ebuild b/sci-biology/vcftools/vcftools-0.1.8.ebuild
new file mode 100644
index 000000000000..b378d7823283
--- /dev/null
+++ b/sci-biology/vcftools/vcftools-0.1.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vcftools/vcftools-0.1.8.ebuild,v 1.1 2012/07/19 11:31:13 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Tools for working with VCF (Variant Call Format) files"
+HOMEPAGE="http://vcftools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="lapack"
+
+RDEPEND="virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch
+ tc-export CXX
+}
+
+src_compile() {
+ local myconf
+ use lapack && myconf="VCFTOOLS_PCA=1"
+ emake -C cpp ${myconf}
+}
+
+src_install(){
+ dobin cpp/${PN}
+ insinto /usr/share/${PN}/perl
+ doins perl/*.pm
+ exeinto /usr/share/${PN}/perl
+ doexe perl/{fill,vcf}-*
+ echo 'COLON_SEPARATED=PERL5LIB' > "${S}/99${PN}"
+ echo "PERL5LIB=/usr/share/${PN}/perl" >> "${S}/99${PN}"
+ doenvd "${S}/99${PN}"
+ dodoc README.txt
+}