summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-11-19 21:35:37 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-11-19 21:35:37 +0000
commit39a153aeae226958b26a2167bb5a16c31f18609e (patch)
tree963189a91212413df5ca406ee66167d55ecf28b6
parentPort portpeek to use newer version of gentoolkit (diff)
downloadgentoo-2-39a153aeae226958b26a2167bb5a16c31f18609e.tar.gz
gentoo-2-39a153aeae226958b26a2167bb5a16c31f18609e.tar.bz2
gentoo-2-39a153aeae226958b26a2167bb5a16c31f18609e.zip
update 2.6.36 patch, close bug #346115
(Portage version: 2.2_rc91/cvs/Linux x86_64)
-rw-r--r--media-libs/svgalib/ChangeLog6
-rw-r--r--media-libs/svgalib/files/svgalib-1.9.25-linux2.6.36.patch12
2 files changed, 10 insertions, 8 deletions
diff --git a/media-libs/svgalib/ChangeLog b/media-libs/svgalib/ChangeLog
index 061b26d6e3b2..415b02e50d6f 100644
--- a/media-libs/svgalib/ChangeLog
+++ b/media-libs/svgalib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/svgalib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/ChangeLog,v 1.89 2010/11/05 16:31:23 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/ChangeLog,v 1.90 2010/11/19 21:35:37 lxnay Exp $
+
+ 19 Nov 2010; Fabio Erculiani <lxnay@gentoo.org>
+ files/svgalib-1.9.25-linux2.6.36.patch:
+ update 2.6.36 patch, close bug #346115
05 Nov 2010; Fabio Erculiani <lxnay@gentoo.org> svgalib-1.9.25-r1.ebuild,
+files/svgalib-1.9.25-linux2.6.36.patch:
diff --git a/media-libs/svgalib/files/svgalib-1.9.25-linux2.6.36.patch b/media-libs/svgalib/files/svgalib-1.9.25-linux2.6.36.patch
index 33cf7e9b1417..eed935ebef4d 100644
--- a/media-libs/svgalib/files/svgalib-1.9.25-linux2.6.36.patch
+++ b/media-libs/svgalib/files/svgalib-1.9.25-linux2.6.36.patch
@@ -1,24 +1,22 @@
--- svgalib-1.9.25.orig/kernel/svgalib_helper/main.c
+++ svgalib-1.9.25/kernel/svgalib_helper/main.c
-@@ -162,10 +162,16 @@ static void task_startad(void *data) {
- get_user(pciv.address, &user_pciv->address); \
+@@ -163,8 +163,15 @@ static void task_startad(void *data) {
get_user(pciv.val, &user_pciv->val);
#define PUT_PCIV \
-- put_user(pciv.val, &user_pciv->val);
-+ put_user(pciv.val, &user_pciv->val);
+ put_user(pciv.val, &user_pciv->val);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,36)
static int svgalib_helper_ioctl( struct inode *inode, struct file *filp,
unsigned int cmd, unsigned long arg) {
+#else
+static int svgalib_helper_ioctl(struct file *filp,
+ unsigned int cmd, unsigned long arg) {
++
++ struct inode *inode=filp->f_dentry->d_inode;
+#endif
-+ struct inode *inode=filp->f_dentry->d_inode;
io_t iov, *user_iov=(io_t *)arg;
pcic_t pciv, *user_pciv=(pcic_t *)arg;
- int minor = my_minor(inode->i_rdev);
-@@ -595,7 +601,11 @@ struct file_operations svgalib_helper_fo
+@@ -595,7 +602,11 @@ struct file_operations svgalib_helper_fo
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,3,0)
.owner = THIS_MODULE,
#endif