summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-13 16:46:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-13 16:46:44 +0000
commit3968454840dc86678863606f8d6ddff219851e79 (patch)
tree77ac371959d535d5e733847faddf8a2757cbe4d4
parentSimplify ebuild. (diff)
downloadgentoo-2-3968454840dc86678863606f8d6ddff219851e79.tar.gz
gentoo-2-3968454840dc86678863606f8d6ddff219851e79.tar.bz2
gentoo-2-3968454840dc86678863606f8d6ddff219851e79.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--media-sound/lingot/ChangeLog9
-rw-r--r--media-sound/lingot/lingot-0.8.1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/media-sound/lingot/ChangeLog b/media-sound/lingot/ChangeLog
index b3688f1c3a13..afdfae4ede4f 100644
--- a/media-sound/lingot/ChangeLog
+++ b/media-sound/lingot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lingot
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lingot/ChangeLog,v 1.5 2009/06/06 08:58:01 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lingot/ChangeLog,v 1.6 2010/04/13 16:46:44 ssuominen Exp $
+
+*lingot-0.8.1 (13 Apr 2010)
+
+ 13 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> +lingot-0.8.1.ebuild:
+ Version bump.
05 Jul 2008; Samuli Suominen <ssuominen@gentoo.org>
+files/lingot-0.7.6-memory_leak.patch, lingot-0.7.6.ebuild:
diff --git a/media-sound/lingot/lingot-0.8.1.ebuild b/media-sound/lingot/lingot-0.8.1.ebuild
new file mode 100644
index 000000000000..9eef5a187456
--- /dev/null
+++ b/media-sound/lingot/lingot-0.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lingot/lingot-0.8.1.ebuild,v 1.1 2010/04/13 16:46:44 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="LINGOT Is Not a Guitar-Only Tuner"
+HOMEPAGE="http://www.nongnu.org/lingot"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa jack"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libglade-2
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.102 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7.6-clean-install.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable alsa) \
+ $(use_enable jack)
+}
+
+src_install() {
+ emake DESTDIR="${D}" lingotdocdir="/usr/share/doc/${PF}" \
+ install || die
+ prepalldocs
+}