summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-03-22 21:35:34 +0000
committerDon Seiler <rizzo@gentoo.org>2004-03-22 21:35:34 +0000
commit3943257c9f78cb79f00df730c72b061360ecea50 (patch)
tree2a61fdc0e9d3585f281febf6adf3847aa83e98f7
parentMake sure spool only gets created in pkg_postinst(). Fixes bug #45142. (Manif... (diff)
downloadgentoo-2-3943257c9f78cb79f00df730c72b061360ecea50.tar.gz
gentoo-2-3943257c9f78cb79f00df730c72b061360ecea50.tar.bz2
gentoo-2-3943257c9f78cb79f00df730c72b061360ecea50.zip
Initial import, thanks to Jamis Buck for the good work. Bug #43813
-rw-r--r--dev-db/oracle-instantclient-jdbc/ChangeLog10
-rw-r--r--dev-db/oracle-instantclient-jdbc/Manifest2
-rw-r--r--dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.21
-rw-r--r--dev-db/oracle-instantclient-jdbc/metadata.xml10
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2.ebuild45
-rw-r--r--dev-db/oracle-instantclient-sqlplus/ChangeLog10
-rw-r--r--dev-db/oracle-instantclient-sqlplus/Manifest2
-rw-r--r--dev-db/oracle-instantclient-sqlplus/files/digest-oracle-instantclient-sqlplus-10.1.0.21
-rw-r--r--dev-db/oracle-instantclient-sqlplus/metadata.xml10
-rw-r--r--dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-10.1.0.2.ebuild49
10 files changed, 140 insertions, 0 deletions
diff --git a/dev-db/oracle-instantclient-jdbc/ChangeLog b/dev-db/oracle-instantclient-jdbc/ChangeLog
new file mode 100644
index 000000000000..de8a68e1d096
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/oracle-instantclient-jdbc
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.1 2004/03/22 21:31:36 rizzo Exp $
+
+*oracle-instantclient-jdbc-10.1.0.2 (22 Mar 2004)
+
+ 22 Mar 2004; Don Seiler <rizzo@gentoo.org>; metadata.xml,
+ oracle-instantclient-jdbc-10.1.0.2.ebuild:
+ Initial import, thanks to Jamis Buck for the good work. Bug #43813
+
diff --git a/dev-db/oracle-instantclient-jdbc/Manifest b/dev-db/oracle-instantclient-jdbc/Manifest
new file mode 100644
index 000000000000..dfd7cb7ac4fd
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/Manifest
@@ -0,0 +1,2 @@
+MD5 04bc7ed7c73828c0d5c3822b90e7c076 oracle-instantclient-jdbc-10.1.0.2.ebuild 1010
+MD5 2a2ab5b81985a1c6bbd57468f6c23cd4 files/digest-oracle-instantclient-jdbc-10.1.0.2 91
diff --git a/dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.2 b/dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.2
new file mode 100644
index 000000000000..fb426627dc1e
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.2
@@ -0,0 +1 @@
+MD5 51c0715f43784cd12d5073bb2059a239 oracle-instantclient-jdbc-10.1.0.2-1.i386.rpm 4578875
diff --git a/dev-db/oracle-instantclient-jdbc/metadata.xml b/dev-db/oracle-instantclient-jdbc/metadata.xml
new file mode 100644
index 000000000000..634b161a6d3e
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>rizzo@gentoo.org</email>
+<!-- <description>Description of the maintainership</description> -->
+</maintainer>
+<longdescription>Instant Client Package - Basic: All files required to run OCI, OCCI, and JDBC-OCI applications</longdescription>
+</pkgmetadata>
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2.ebuild
new file mode 100644
index 000000000000..efb5ac79c3d3
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2.ebuild,v 1.1 2004/03/22 21:31:36 rizzo Exp $
+
+inherit eutils
+
+MY_P="${P}-1.i386"
+
+S=${WORKDIR}
+DESCRIPTION="Oracle 10g client installation for Linux: JDBC supplement"
+HOMEPAGE="http://otn.oracle.com/software/tech/oci/instantclient/htdocs/linuxsoft.html"
+SRC_URI="${MY_P}.rpm"
+
+LICENSE="OTN"
+SLOT="${KV}"
+KEYWORDS="~x86"
+RESTRICT="fetch"
+
+DEPEND="app-arch/rpm2targz
+ =dev-db/oracle-instantclient-basic-10.1.0.2"
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the JDBC supplemental package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz
+}
+
+src_install() {
+ mv ${S}/usr ${D}
+}
+
+pkg_postinst() {
+ echo
+ einfo "The JDBC supplement package for Oracle 10g has been installed."
+ einfo "You may wish to install the oracle-instantclient-sqlplus (for "
+ einfo "running the SQL*Plus application) package as well."
+ echo
+}
diff --git a/dev-db/oracle-instantclient-sqlplus/ChangeLog b/dev-db/oracle-instantclient-sqlplus/ChangeLog
new file mode 100644
index 000000000000..b49eea4317ef
--- /dev/null
+++ b/dev-db/oracle-instantclient-sqlplus/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/oracle-instantclient-sqlplus
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/ChangeLog,v 1.1 2004/03/22 21:35:34 rizzo Exp $
+
+*oracle-instantclient-sqlplus-10.1.0.2 (22 Mar 2004)
+
+ 22 Mar 2004; Don Seiler <rizzo@gentoo.org>; metadata.xml,
+ oracle-instantclient-sqlplus-10.1.0.2.ebuild:
+ Initial import, thanks to Jamis Buck for the good work. Bug #43813
+
diff --git a/dev-db/oracle-instantclient-sqlplus/Manifest b/dev-db/oracle-instantclient-sqlplus/Manifest
new file mode 100644
index 000000000000..ddffa858c2d4
--- /dev/null
+++ b/dev-db/oracle-instantclient-sqlplus/Manifest
@@ -0,0 +1,2 @@
+MD5 968c3c1686cfc68fca005a3e321c4133 oracle-instantclient-sqlplus-10.1.0.2.ebuild 1056
+MD5 77c18d359283aaf49ec2636bae6693f2 files/digest-oracle-instantclient-sqlplus-10.1.0.2 93
diff --git a/dev-db/oracle-instantclient-sqlplus/files/digest-oracle-instantclient-sqlplus-10.1.0.2 b/dev-db/oracle-instantclient-sqlplus/files/digest-oracle-instantclient-sqlplus-10.1.0.2
new file mode 100644
index 000000000000..ebd91256b849
--- /dev/null
+++ b/dev-db/oracle-instantclient-sqlplus/files/digest-oracle-instantclient-sqlplus-10.1.0.2
@@ -0,0 +1 @@
+MD5 6b4896bb3ab20bb2005c3b94b58285db oracle-instantclient-sqlplus-10.1.0.2-1.i386.rpm 321157
diff --git a/dev-db/oracle-instantclient-sqlplus/metadata.xml b/dev-db/oracle-instantclient-sqlplus/metadata.xml
new file mode 100644
index 000000000000..634b161a6d3e
--- /dev/null
+++ b/dev-db/oracle-instantclient-sqlplus/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>rizzo@gentoo.org</email>
+<!-- <description>Description of the maintainership</description> -->
+</maintainer>
+<longdescription>Instant Client Package - Basic: All files required to run OCI, OCCI, and JDBC-OCI applications</longdescription>
+</pkgmetadata>
diff --git a/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-10.1.0.2.ebuild b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-10.1.0.2.ebuild
new file mode 100644
index 000000000000..365fc040b6a6
--- /dev/null
+++ b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-10.1.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-10.1.0.2.ebuild,v 1.1 2004/03/22 21:35:34 rizzo Exp $
+
+inherit eutils
+
+MY_P="${P}-1.i386"
+
+S=${WORKDIR}
+DESCRIPTION="Oracle 10g client installation for Linux: SQL*Plus"
+HOMEPAGE="http://otn.oracle.com/software/tech/oci/instantclient/htdocs/linuxsoft.html"
+SRC_URI="${MY_P}.rpm"
+
+LICENSE="OTN"
+SLOT="${KV}"
+KEYWORDS="~x86"
+RESTRICT="fetch"
+
+DEPEND="app-arch/rpm2targz
+ =dev-db/oracle-instantclient-basic-10.1.0.2"
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the SQL*Plus package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz 2>/dev/null
+}
+
+src_install() {
+ mv ${S}/usr ${D}
+ dosym /usr/lib/oracle/${PV}/client/bin/sqlplus /usr/bin/sqlplus
+}
+
+pkg_postinst() {
+ echo
+ einfo "The SQL*Plus package for Oracle 10g has been installed."
+ einfo "You may wish to install the oracle-instantclient-jdbc (for"
+ einfo "the supplemental JDBC functionality) package as well."
+ einfo
+ einfo "If you have any questions, be sure to read the README:"
+ einfo "http://otn.oracle.com/docs/tech/sql_plus/10102/readme_ic.htm"
+ echo
+}