summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-08-07 17:46:19 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-08-07 17:46:19 +0000
commit3776f460cfef1f95ad8507ef13576b825dddda46 (patch)
tree0a49c8a289c64e3e2004ed4df14d3f3177ed2187
parentRevision bump adds upstream patch which fixes memleak in knotify spotted by D... (diff)
downloadgentoo-2-3776f460cfef1f95ad8507ef13576b825dddda46.tar.gz
gentoo-2-3776f460cfef1f95ad8507ef13576b825dddda46.tar.bz2
gentoo-2-3776f460cfef1f95ad8507ef13576b825dddda46.zip
Make libkate support optional. Bug #368539
(Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--net-misc/icecast/ChangeLog6
-rw-r--r--net-misc/icecast/files/icecast-2.3.3-libkate.patch28
-rw-r--r--net-misc/icecast/icecast-2.3.3.ebuild12
-rw-r--r--net-misc/icecast/metadata.xml1
4 files changed, 42 insertions, 5 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index f468ef2f966f..557ebb1850a2 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/icecast
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.86 2012/08/06 19:30:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.87 2012/08/07 17:46:18 hwoarang Exp $
+
+ 07 Aug 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/icecast-2.3.3-libkate.patch, icecast-2.3.3.ebuild, metadata.xml:
+ Make libkate support optional. Bug #368539
*icecast-2.3.3 (06 Aug 2012)
diff --git a/net-misc/icecast/files/icecast-2.3.3-libkate.patch b/net-misc/icecast/files/icecast-2.3.3-libkate.patch
new file mode 100644
index 000000000000..32cbd78ed964
--- /dev/null
+++ b/net-misc/icecast/files/icecast-2.3.3-libkate.patch
@@ -0,0 +1,28 @@
+Index: icecast-2.3.3/configure.in
+===================================================================
+--- icecast-2.3.3.orig/configure.in
++++ icecast-2.3.3/configure.in
+@@ -81,14 +81,18 @@ XIPH_PATH_SPEEX(
+ [ AC_MSG_WARN([Speex support disabled!])
+ ])
+
+-AC_CHECK_LIB(kate, kate_decode_init,[have_kate=yes],[have_kate=no], -logg)
+-if test "x$have_kate" == "xyes"
++AC_ARG_ENABLE([kate], AS_HELP_STRING([--disable-kate], [Disable karaoke and text encapsulation support for ogg]))
++if test "x$enable_kate" != "xno"
+ then
+- AC_CHECK_LIB(oggkate, kate_ogg_decode_headerin,[have_kate=yes],[have_kate=no],-lkate -logg)
++ AC_CHECK_LIB(kate, kate_decode_init,[have_kate=yes],[have_kate=no], -logg)
+ if test "x$have_kate" == "xyes"
+ then
+- KATE_LIBS="-loggkate -lkate -logg"
+- AC_DEFINE([HAVE_KATE],[1],[Define if you have libkate])
++ AC_CHECK_LIB(oggkate, kate_ogg_decode_headerin,[have_kate=yes],[have_kate=no],-lkate -logg)
++ if test "x$have_kate" == "xyes"
++ then
++ KATE_LIBS="-loggkate -lkate -logg"
++ AC_DEFINE([HAVE_KATE],[1],[Define if you have libkate])
++ fi
+ fi
+ fi
+ dnl we still use format_kate as it doesn't need libkate to work
diff --git a/net-misc/icecast/icecast-2.3.3.ebuild b/net-misc/icecast/icecast-2.3.3.ebuild
index 0931b27b8ff9..fd77bc4853a5 100644
--- a/net-misc/icecast/icecast-2.3.3.ebuild
+++ b/net-misc/icecast/icecast-2.3.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.3.3.ebuild,v 1.1 2012/08/06 19:30:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.3.3.ebuild,v 1.2 2012/08/07 17:46:18 hwoarang Exp $
EAPI=4
-inherit eutils libtool
+inherit eutils autotools
DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
HOMEPAGE="http://www.icecast.org/"
@@ -12,7 +12,7 @@ SRC_URI="http://downloads.xiph.org/releases/icecast/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="+speex +ssl +theora +yp"
+IUSE="kate +speex +ssl +theora +yp"
#Although there is a --with-ogg and --with-orbis configure option, they're
#only useful for specifying paths, not for disabling.
@@ -20,6 +20,7 @@ DEPEND="dev-libs/libxslt
dev-libs/libxml2
media-libs/libogg
media-libs/libvorbis
+ kate? ( media-libs/libkate )
speex? ( media-libs/speex )
theora? ( media-libs/libtheora )
yp? ( net-misc/curl )
@@ -30,13 +31,16 @@ pkg_setup() {
}
src_prepare() {
- elibtoolize
+ # bug #368539
+ epatch "${FILESDIR}"/${P}-libkate.patch
+ eautoreconf
}
src_configure() {
econf \
--disable-dependency-tracking \
--sysconfdir=/etc/icecast2 \
+ $(use_enable kate) \
$(use_with theora) \
$(use_with speex) \
$(use_with yp curl) \
diff --git a/net-misc/icecast/metadata.xml b/net-misc/icecast/metadata.xml
index 945aee953126..2abecb635d5a 100644
--- a/net-misc/icecast/metadata.xml
+++ b/net-misc/icecast/metadata.xml
@@ -7,6 +7,7 @@
<name>Markos Chandras</name>
</maintainer>
<use>
+ <flag name="kate">Add karaoke and text encapsulation support for Ogg files</flag>
<flag name="yp">Build support for yp public directory listings</flag>
</use>
</pkgmetadata>