summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-09-09 17:36:55 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-09-09 17:36:55 +0000
commit34bc4286834fa6131b141c9c66f7ae9168855675 (patch)
tree1a67e31e7414234081a8f2642da7ebfeefc4361e
parentStable on hppa. (diff)
downloadgentoo-2-34bc4286834fa6131b141c9c66f7ae9168855675.tar.gz
gentoo-2-34bc4286834fa6131b141c9c66f7ae9168855675.tar.bz2
gentoo-2-34bc4286834fa6131b141c9c66f7ae9168855675.zip
Fixed gcc-34 compile issues. Bug #53910
-rw-r--r--x11-misc/fbdesk/ChangeLog6
-rw-r--r--x11-misc/fbdesk/fbdesk-1.1.5.ebuild10
-rw-r--r--x11-misc/fbdesk/files/fbdesk-1.1.5-gcc34.patch83
3 files changed, 97 insertions, 2 deletions
diff --git a/x11-misc/fbdesk/ChangeLog b/x11-misc/fbdesk/ChangeLog
index a2bd607db13d..9f26b00392a6 100644
--- a/x11-misc/fbdesk/ChangeLog
+++ b/x11-misc/fbdesk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/fbdesk
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.9 2004/06/24 22:17:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.10 2004/09/09 17:36:55 sekretarz Exp $
+
+ 09 Sep 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/fbdesk-1.1.5-gcc34.patch, fbdesk-1.1.5.ebuild:
+ Fixed gcc-34 compile issues. Bug #53910
14 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> fbdesk-1.1.5.ebuild:
Added IUSE=
diff --git a/x11-misc/fbdesk/fbdesk-1.1.5.ebuild b/x11-misc/fbdesk/fbdesk-1.1.5.ebuild
index acfa78755ba3..b858b98c3930 100644
--- a/x11-misc/fbdesk/fbdesk-1.1.5.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.1.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.1.5.ebuild,v 1.7 2004/06/24 22:17:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.1.5.ebuild,v 1.8 2004/09/09 17:36:55 sekretarz Exp $
+
+inherit eutils gcc
DESCRIPTION="fluxbox-util application that creates and manage icons on your Fluxbox desktop"
HOMEPAGE="http://www.fluxbox.org/fbdesk/"
@@ -13,6 +15,12 @@ KEYWORDS="x86 ppc ~sparc ~ia64"
DEPEND="media-libs/libpng
virtual/x11"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
src_compile() {
econf || die
emake || die
diff --git a/x11-misc/fbdesk/files/fbdesk-1.1.5-gcc34.patch b/x11-misc/fbdesk/files/fbdesk-1.1.5-gcc34.patch
new file mode 100644
index 000000000000..b2b6e314859a
--- /dev/null
+++ b/x11-misc/fbdesk/files/fbdesk-1.1.5-gcc34.patch
@@ -0,0 +1,83 @@
+diff -Naur fbdesk-1.1.5.orig/src/Resource.hh fbdesk-1.1.5/src/Resource.hh
+--- fbdesk-1.1.5.orig/src/Resource.hh 2003-01-14 22:45:53.000000000 +0100
++++ fbdesk-1.1.5/src/Resource.hh 2004-07-17 11:31:57.000000000 +0200
+@@ -56,40 +56,8 @@
+ std::string m_altname; ///< alternative name
+ };
+
+-class ResourceManager;
+-
+-/**
+- Real resource class
+-*/
+ template <typename T>
+-class Resource:public Resource_base
+-{
+-public:
+- Resource(ResourceManager &rm, T val,
+- const std::string &name, const std::string &altname):
+- Resource_base(name, altname),
+- m_value(val), m_defaultval(val),
+- m_rm(rm)
+- {
+- m_rm.addResource(*this); // add this to resource handler
+- }
+- virtual ~Resource() {
+- m_rm.removeResource(*this); // remove this from resource handler
+- }
+-
+- inline void setDefaultValue() { m_value = m_defaultval; }
+- void setFromString(const char *strval);
+- inline Resource<T>& operator = (const T& newvalue) { m_value = newvalue; return *this;}
+-
+- std::string getString();
+- inline T& operator*() { return m_value; }
+- inline const T& operator*() const { return m_value; }
+- inline T *operator->() { return &m_value; }
+- inline const T *operator->() const { return &m_value; }
+-private:
+- T m_value, m_defaultval;
+- ResourceManager &m_rm;
+-};
++class Resource;
+
+ class ResourceManager
+ {
+@@ -129,4 +97,37 @@
+ ResourceList m_resourcelist;
+ };
+
++/**
++ Real resource class
++*/
++template <typename T>
++class Resource:public Resource_base
++{
++public:
++ Resource(ResourceManager &rm, T val,
++ const std::string &name, const std::string &altname):
++ Resource_base(name, altname),
++ m_value(val), m_defaultval(val),
++ m_rm(rm)
++ {
++ m_rm.addResource(*this); // add this to resource handler
++ }
++ virtual ~Resource() {
++ m_rm.removeResource(*this); // remove this from resource handler
++ }
++
++ inline void setDefaultValue() { m_value = m_defaultval; }
++ void setFromString(const char *strval);
++ inline Resource<T>& operator = (const T& newvalue) { m_value = newvalue; return *this;}
++
++ std::string getString();
++ inline T& operator*() { return m_value; }
++ inline const T& operator*() const { return m_value; }
++ inline T *operator->() { return &m_value; }
++ inline const T *operator->() const { return &m_value; }
++private:
++ T m_value, m_defaultval;
++ ResourceManager &m_rm;
++};
++
+ #endif //_RESOURCE_HH_