summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-02-10 13:24:54 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-02-10 13:24:54 +0000
commit34632349bcc4154f42dccc2e7d9216851ecf73dc (patch)
tree6589b0d9e5609633bb5525d1330972b74ae0bb0b
parentadded dev-util/global:vim (diff)
downloadgentoo-2-34632349bcc4154f42dccc2e7d9216851ecf73dc.tar.gz
gentoo-2-34632349bcc4154f42dccc2e7d9216851ecf73dc.tar.bz2
gentoo-2-34632349bcc4154f42dccc2e7d9216851ecf73dc.zip
Version bump as per bug #80946
(Portage version: 2.0.51.16)
-rw-r--r--dev-util/global/ChangeLog10
-rw-r--r--dev-util/global/Manifest2
-rw-r--r--dev-util/global/files/digest-global-4.8.21
-rw-r--r--dev-util/global/global-4.8.2.ebuild67
4 files changed, 78 insertions, 2 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 13d964488d24..1e48dcf8bf2c 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/global
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.12 2004/07/03 16:53:14 dholm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.13 2005/02/10 13:24:54 dragonheart Exp $
+
+*global-4.8.2 (10 Feb 2005)
+
+ 10 Feb 2005; Daniel Black <dragonheart@gentoo.org> +global-4.8.2.ebuild:
+ Version bump as per bug #80946. Thanks Matteo Settenvini
+ <matteo-ml@member.fsf.org>
03 Jul 2004; David Holm <dholm@gentoo.org> global-4.7.2.ebuild:
Added to ~ppc.
diff --git a/dev-util/global/Manifest b/dev-util/global/Manifest
index f6124ebdd85f..206681c3b0cc 100644
--- a/dev-util/global/Manifest
+++ b/dev-util/global/Manifest
@@ -1,5 +1,7 @@
MD5 83015a9a71541455bc5843500993e8f8 ChangeLog 1754
+MD5 69d7a511184b6aef972dbbe2245acf00 global-4.8.2.ebuild 1342
MD5 d938a5a567a195b4379516bf21c8e926 global-4.5.ebuild 730
MD5 f4661530b9745748bd43ad19b0ca7f7c global-4.7.2.ebuild 1104
MD5 0424e6fe5b2cb2d127bb8c2d358c86f0 files/digest-global-4.5 62
MD5 e9f2d3ff22577cbeeb33f207c8660067 files/digest-global-4.7.2 64
+MD5 abfcd62d837afb87d067cc5175a77b72 files/digest-global-4.8.2 64
diff --git a/dev-util/global/files/digest-global-4.8.2 b/dev-util/global/files/digest-global-4.8.2
new file mode 100644
index 000000000000..b73cc8a1de14
--- /dev/null
+++ b/dev-util/global/files/digest-global-4.8.2
@@ -0,0 +1 @@
+MD5 ec0b03ea8042ed84b6d9f607e24f6360 global-4.8.2.tar.gz 641674
diff --git a/dev-util/global/global-4.8.2.ebuild b/dev-util/global/global-4.8.2.ebuild
new file mode 100644
index 000000000000..371957caf955
--- /dev/null
+++ b/dev-util/global/global-4.8.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-4.8.2.ebuild,v 1.1 2005/02/10 13:24:54 dragonheart Exp $
+
+inherit elisp
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in C, C++, Yacc, Java and assembler sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc vim emacs"
+DEPEND="virtual/libc
+ doc? ( sys-apps/texinfo )
+ vim? ( app-editors/vim )
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50gtags-gentoo.el
+
+src_compile() {
+ econf || die "econf failed"
+
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.txi
+ texi2html -o doc/global.html doc/global.txi
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ if use doc; then
+ dohtml doc/global.html
+ dodoc doc/global.pdf
+ fi
+ dodoc AUTHORS LICENSE FAQ INSTALL NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+ insinto /usr/share/${PN}
+ doins gtags.pl globash.rc
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ cp gtags.el ${SITEFILE}
+ elisp-site-file-install ${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ if use emacs; then
+ elisp-site-regen
+ fi
+}