summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-04 02:59:52 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-04 02:59:52 +0000
commit340a7bb842b3805446a04f56a796638f5a1fe4a8 (patch)
treec013ac444c715e837a99197844766d073327d7fd
parentold (diff)
downloadgentoo-2-340a7bb842b3805446a04f56a796638f5a1fe4a8.tar.gz
gentoo-2-340a7bb842b3805446a04f56a796638f5a1fe4a8.tar.bz2
gentoo-2-340a7bb842b3805446a04f56a796638f5a1fe4a8.zip
Make sure we use a custom PKGDIR so we dont overwrite the users normal toolchain binpkgs.
(Portage version: 2.0.51.19)
-rw-r--r--sys-devel/crossdev/ChangeLog9
-rw-r--r--sys-devel/crossdev/crossdev-0.9-r1.ebuild20
-rwxr-xr-xsys-devel/crossdev/files/crossdev8
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9-r10
4 files changed, 33 insertions, 4 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index fac4e6056dc5..b49314b40f12 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/crossdev
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.7 2005/03/03 18:44:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.8 2005/03/04 02:59:52 vapier Exp $
+
+*crossdev-0.9-r1 (03 Mar 2005)
+
+ 03 Mar 2005; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ +crossdev-0.9-r1.ebuild:
+ Make sure we use a custom PKGDIR so we dont overwrite the users normal
+ toolchain binpkgs.
*crossdev-0.9 (03 Mar 2005)
diff --git a/sys-devel/crossdev/crossdev-0.9-r1.ebuild b/sys-devel/crossdev/crossdev-0.9-r1.ebuild
new file mode 100644
index 000000000000..94caaea3281c
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9-r1.ebuild,v 1.1 2005/03/04 02:59:52 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/portage
+ app-shells/bash
+ sys-apps/coreutils"
+
+src_install() {
+ dobin "${FILESDIR}"/crossdev || die
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index 14c27a82301d..e3ef3c037fe5 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.1 2005/03/03 18:44:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.2 2005/03/04 02:59:52 vapier Exp $
source /sbin/functions.sh || exit 1
die() {
@@ -23,7 +23,7 @@ ${GOOD}Options${NORMAL}:
${GOOD}-g, --gcc${NORMAL} ver Specify version of gcc to use
${GOOD}-k, --kernel${NORMAL} ver Specify version of kernel headers to use
${GOOD}-l, --libc${NORMAL} ver Specify version of libc to use
- ${GOOD}-p, -v, -a${NORMAL} Options to pass to emerge (see emerge(1))
+ ${GOOD}-a, -b, -p, -v${NORMAL} Options to pass to emerge (see emerge(1))
${GOOD}-s1, --stage1${NORMAL} Build a C compiler (no libc/C++)
${GOOD}-s2, --stage2${NORMAL} Build a C compiler & libc (no C++)
@@ -109,7 +109,7 @@ while [[ $# -gt 0 ]] ; do
-k|--kernel) shift; KVER=-$1;;
-l|--libc) shift; LVER=-$1;;
-s?|--stage?) STAGE=${1:0-1};;
- -p|-v|-a) UOPTS="${UOPTS} $1";;
+ -a|-b|-p|-v) UOPTS="${UOPTS} $1";;
-h|--help) usage;;
*) eerror "UNKNOWN OPTION: '$1'" ; usage 1;;
esac
@@ -124,6 +124,7 @@ PORTDIR_OVERLAY=$(portageq envvar PORTDIR_OVERLAY)
PORTDIR=$(portageq envvar PORTDIR)
PORT_LOGDIR=$(portageq envvar PORT_LOGDIR)
PORT_LOGDIR=${PORT_LOGDIR:-/var/log/portage}
+PKGDIR=$(portageq envvar PKGDIR)/cross-${CTARGET}
[[ ! -d ${PORT_LOGDIR} ]] && mkdir -p ${PORT_LOGDIR}
(
hr
@@ -140,6 +141,7 @@ einfo "libc: ${LPKG}${LVER}"
echo
einfo "PORTDIR_OVERLAY: ${PORTDIR_OVERLAY}"
einfo "PORT_LOGDIR: ${PORT_LOGDIR}"
+einfo "PKGDIR: ${PKGDIR}"
hr
) >& ${PORT_LOGDIR}/cross-${CTARGET}-info.log
cat ${PORT_LOGDIR}/cross-${CTARGET}-info.log
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9-r1 b/sys-devel/crossdev/files/digest-crossdev-0.9-r1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9-r1