summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-18 07:45:42 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-18 07:45:42 +0000
commit340a20dd92149d7c8437e9fc9234dfc5cc930cce (patch)
tree0e4c57cc4d89d8b52321d6d9859008d792c53ca3
parentVersion bump. (diff)
downloadgentoo-2-340a20dd92149d7c8437e9fc9234dfc5cc930cce.tar.gz
gentoo-2-340a20dd92149d7c8437e9fc9234dfc5cc930cce.tar.bz2
gentoo-2-340a20dd92149d7c8437e9fc9234dfc5cc930cce.zip
Version Bump
(Portage version: 2.2_rc62/cvs/Linux i686)
-rw-r--r--app-arch/lbzip2/ChangeLog8
-rw-r--r--app-arch/lbzip2/files/0.21-Makefile.patch45
-rw-r--r--app-arch/lbzip2/lbzip2-0.21.ebuild58
3 files changed, 110 insertions, 1 deletions
diff --git a/app-arch/lbzip2/ChangeLog b/app-arch/lbzip2/ChangeLog
index 05c61003aaa3..6193928bfe7c 100644
--- a/app-arch/lbzip2/ChangeLog
+++ b/app-arch/lbzip2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/lbzip2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.1 2010/02/09 20:19:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.2 2010/02/18 07:45:41 jlec Exp $
+
+*lbzip2-0.21 (18 Feb 2010)
+
+ 18 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +files/0.21-Makefile.patch, +lbzip2-0.21.ebuild:
+ Version Bump
*lbzip2-0.20 (09 Feb 2010)
diff --git a/app-arch/lbzip2/files/0.21-Makefile.patch b/app-arch/lbzip2/files/0.21-Makefile.patch
new file mode 100644
index 000000000000..19f86380e5dd
--- /dev/null
+++ b/app-arch/lbzip2/files/0.21-Makefile.patch
@@ -0,0 +1,45 @@
+--- Makefile 2009-04-04 00:33:49.000000000 +0200
++++ Makefile.new 2009-04-15 21:12:02.886390550 +0200
+@@ -1,34 +1,27 @@
+ # Makefile,v 1.9 2009-04-03 22:33:49 lacos Exp
+ .POSIX:
+
+-CC=gcc
+-CFLAGS=$$($(SHELL) lfs.sh CFLAGS) -D _XOPEN_SOURCE=500 -pipe -ansi -pedantic \
+- -O2
+-
+-
+-
+-
+-LDFLAGS=-s $$($(SHELL) lfs.sh LDFLAGS)
+-LIBS=-l pthread -l bz2 $$($(SHELL) lfs.sh LIBS)
++CFLAGS += -D _XOPEN_SOURCE=500
++LIBS=-lpthread -lbz2
+
+ lbzip2: main.o lbzip2.o lbunzip2.o lbunzip2_single.o lacos_rbtree.o
+- $(CC) -o lbzip2 $(LDFLAGS) main.o lbzip2.o lbunzip2.o \
++ $(CC) $(CPPFLAGS) $(LDFLAGS) -o lbzip2 main.o lbzip2.o lbunzip2.o \
+ lbunzip2_single.o lacos_rbtree.o $(LIBS)
+
+ main.o: main.c main.h lbunzip2_single.h lbunzip2.h lbzip2.h
+- $(CC) $(CFLAGS) -c main.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c main.c
+
+ lbzip2.o: lbzip2.c main.h lbzip2.h lacos_rbtree.h
+- $(CC) $(CFLAGS) -c lbzip2.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c lbzip2.c
+
+ lbunzip2.o: lbunzip2.c main.h lbunzip2.h lacos_rbtree.h
+- $(CC) $(CFLAGS) -c lbunzip2.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c lbunzip2.c
+
+ lbunzip2_single.o: lbunzip2_single.c main.h lbunzip2_single.h
+- $(CC) $(CFLAGS) -c lbunzip2_single.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c lbunzip2_single.c
+
+ lacos_rbtree.o: lacos_rbtree.c lacos_rbtree.h
+- $(CC) $(CFLAGS) -c lacos_rbtree.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c lacos_rbtree.c
+
+ clean:
+ rm -f lbzip2 main.o lbzip2.o lbunzip2.o lbunzip2_single.o \
diff --git a/app-arch/lbzip2/lbzip2-0.21.ebuild b/app-arch/lbzip2/lbzip2-0.21.ebuild
new file mode 100644
index 000000000000..d3e00f5c4bfc
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-0.21.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.21.ebuild,v 1.1 2010/02/18 07:45:41 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Pthreads-based parallel bzip2/bunzip2 filter, passable to GNU tar"
+HOMEPAGE="http://lacos.hu/"
+SRC_URI="http://lacos.web.elte.hu/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="symlink test"
+
+RDEPEND="app-arch/bzip2"
+DEPEND="${REDEPEND}
+ test? (
+ app-shells/dash
+ sys-process/time
+ )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+}
+
+src_compile() {
+ append-lfs-flags
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_test() {
+ if [ -t 0 ] || return; then
+ rm -rf "${T}/scratch" "${T}/results" "${T}/rnd"
+ hexdump -n 10485760 /dev/urandom > "${T}/rnd"
+ emake -j1 SHELL="${EPREFIX}"/bin/dash PATH="${S}:${PATH}" TESTFILE="${T}/rnd" check \
+ || die "make check failed"
+ else
+ ewarn "make check must be run attached to a terminal"
+ fi
+}
+
+src_install() {
+ dobin ${PN} || die "Installation of ${PN} failed"
+ dodoc ChangeLog README || die "no docs"
+ doman ${PN}.1 || die "no man"
+ insinto /usr/share/${PN}
+ doins corr-perf.sh malloc_trace.pl || die
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/gzip || die
+ dosym un${PN} /usr/bin/gunzip || die
+ fi
+}