summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-07-31 08:38:50 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-07-31 08:38:50 +0000
commit33d87f7a141dcf701717991c9fce7df8cf096a74 (patch)
treefd77aa3c2fbd7b8ab4957301223f2da6f23e2c3d
parentAdd missing slot dependencies on Qt. (diff)
downloadgentoo-2-33d87f7a141dcf701717991c9fce7df8cf096a74.tar.gz
gentoo-2-33d87f7a141dcf701717991c9fce7df8cf096a74.tar.bz2
gentoo-2-33d87f7a141dcf701717991c9fce7df8cf096a74.zip
Restore back 0.8.0 version for qutim.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64, RepoMan options: --force)
-rw-r--r--net-libs/telepathy-qt/ChangeLog8
-rw-r--r--net-libs/telepathy-qt/metadata.xml1
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.8.0.ebuild70
3 files changed, 78 insertions, 1 deletions
diff --git a/net-libs/telepathy-qt/ChangeLog b/net-libs/telepathy-qt/ChangeLog
index d6033a6f26c2..ca18017442d3 100644
--- a/net-libs/telepathy-qt/ChangeLog
+++ b/net-libs/telepathy-qt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/telepathy-qt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.14 2012/07/31 07:10:54 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.15 2012/07/31 08:38:50 scarabeus Exp $
+
+*telepathy-qt-0.8.0 (31 Jul 2012)
+
+ 31 Jul 2012; Tomáš Chvátal <scarabeus@gentoo.org> +telepathy-qt-0.8.0.ebuild,
+ metadata.xml:
+ Restore back 0.8.0 version for qutim.
31 Jul 2012; Tomáš Chvátal <scarabeus@gentoo.org> metadata.xml:
Remove unused useflag and add kde herd too to metadata.
diff --git a/net-libs/telepathy-qt/metadata.xml b/net-libs/telepathy-qt/metadata.xml
index dabc844f3d48..5041aecd4fbd 100644
--- a/net-libs/telepathy-qt/metadata.xml
+++ b/net-libs/telepathy-qt/metadata.xml
@@ -4,6 +4,7 @@
<herd>qt</herd>
<herd>kde</herd>
<use>
+ <flag name='glib'>Enable support for various telepathy/glib related packages</flag>
<flag name='farsight'>Enable support for farsight connection manager</flag>
<flag name='farstream'>Enable support for audio/video calls via farstream</flag>
</use>
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.8.0.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.8.0.ebuild
new file mode 100644
index 000000000000..81d468d769ee
--- /dev/null
+++ b/net-libs/telepathy-qt/telepathy-qt-0.8.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/telepathy-qt-0.8.0.ebuild,v 1.8 2012/07/31 08:38:50 scarabeus Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+MY_PN=${PN}4
+inherit python base cmake-utils
+
+DESCRIPTION="Qt4 bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug farsight glib test"
+
+RESTRICT="test" #423089
+
+RDEPEND="
+ dev-python/dbus-python
+ x11-libs/qt-core:4[glib?]
+ x11-libs/qt-dbus:4
+ farsight? (
+ dev-libs/dbus-glib
+ dev-libs/libxml2
+ media-libs/gstreamer
+ >=net-libs/telepathy-glib-0.15.1
+ net-libs/telepathy-farsight
+ )
+ glib? ( dev-libs/glib:2 )
+ !net-libs/telepathy-qt4
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+ test? ( x11-libs/qt-test:4 )
+"
+
+PATCHES=( "${FILESDIR}/${P}-automagicness.patch" )
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+
+ sed -i -e '/^add_subdirectory(examples)$/d' CMakeLists.txt || die
+
+ if ! use test ; then
+ sed -i -e '/^add_subdirectory(tests)$/d' CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable debug DEBUG_OUTPUT)
+ $(cmake-utils_use_with glib)
+ $(cmake-utils_use_with farsight)
+ )
+ cmake-utils_src_configure
+}