summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-12-29 11:06:56 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-12-29 11:06:56 +0000
commit32b67f4311d07c945bbecef79157c7e418be0095 (patch)
treee0e9946aa078129134e61341aed950bb1cd9daae
parentInitial commit. Package required for knot dns and others. Added to base-syste... (diff)
downloadgentoo-2-32b67f4311d07c945bbecef79157c7e418be0095.tar.gz
gentoo-2-32b67f4311d07c945bbecef79157c7e418be0095.tar.bz2
gentoo-2-32b67f4311d07c945bbecef79157c7e418be0095.zip
Initial commit of knot dns authoritative server used by NIC.cz. Added to herd bind as it is closest herd. Can't do much runtime testing on gentoo but possibly can fix packaging errors.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
-rw-r--r--net-dns/knot/ChangeLog12
-rw-r--r--net-dns/knot/files/knot.init43
-rw-r--r--net-dns/knot/knot-0.8.1.ebuild47
-rw-r--r--net-dns/knot/metadata.xml6
4 files changed, 108 insertions, 0 deletions
diff --git a/net-dns/knot/ChangeLog b/net-dns/knot/ChangeLog
new file mode 100644
index 000000000000..f1a89ddcfcba
--- /dev/null
+++ b/net-dns/knot/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-dns/knot
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/ChangeLog,v 1.1 2011/12/29 11:06:56 scarabeus Exp $
+
+*knot-0.8.1 (29 Dec 2011)
+
+ 29 Dec 2011; Tomáš Chvátal <scarabeus@gentoo.org> +knot-0.8.1.ebuild,
+ +files/knot.init, +metadata.xml:
+ Initial commit of knot dns authoritative server used by NIC.cz. Added to herd
+ bind as it is closest herd. Can't do much runtime testing on gentoo but
+ possibly can fix packaging errors.
+
diff --git a/net-dns/knot/files/knot.init b/net-dns/knot/files/knot.init
new file mode 100644
index 000000000000..cf73f6240454
--- /dev/null
+++ b/net-dns/knot/files/knot.init
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+check_config() {
+ # we need to ensure that var is created for runtime
+ if [ ! -d /var/lib/knot/ ]; then
+ mkdir -p /var/lib/knot/
+ fi
+ # without config dns is kinda useless
+ if [ ! -f /etc/knot/knot.conf ]; then
+ eerror "This script requires configured knot-dns at /etc/knot/knot.conf."
+ return 1
+ fi
+}
+
+start() {
+ check_config || return 1
+
+ ebegin "Starting knot-dns"
+ /usr/sbin/knotc start
+ eend $?
+}
+
+stop() {
+ ebegin "Stoping knot-dns"
+ /usr/sbin/knotc stop
+ eend $?
+}
+
+restart() {
+ ebegin "Restarting knot-dns"
+ /usr/sbin/knotc restart
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading knot-dns"
+ /usr/sbin/knotc reload
+ eend $?
+}
diff --git a/net-dns/knot/knot-0.8.1.ebuild b/net-dns/knot/knot-0.8.1.ebuild
new file mode 100644
index 000000000000..ef8e27555cbd
--- /dev/null
+++ b/net-dns/knot/knot-0.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/knot-0.8.1.ebuild,v 1.1 2011/12/29 11:06:56 scarabeus Exp $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="http://www.knot-dns.cz/"
+SRC_URI="http://public.nic.cz/files/knot-dns/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/openssl
+ dev-libs/userspace-rcu
+"
+# sys-libs/glibc
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+"
+
+src_prepare() {
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ --libexecdir="${EPREFIX}/usr/libexec/${PN}" \
+ --enable-recvmmsg \
+ $(use_enable debug debug verbose)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/knot.init" knot-dns
+}
diff --git a/net-dns/knot/metadata.xml b/net-dns/knot/metadata.xml
new file mode 100644
index 000000000000..a45240fd29ba
--- /dev/null
+++ b/net-dns/knot/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>bind</herd>
+</pkgmetadata>
+