summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2014-06-27 16:16:01 +0000
committerChristoph Mende <angelos@gentoo.org>2014-06-27 16:16:01 +0000
commit3167ce5efc5f2f021d16e1717f8b33a946fe5c5f (patch)
tree381fe8ecd7ebe64a676067ee46a5cf6993fef6aa
parentFix SRC_URI (diff)
downloadgentoo-2-3167ce5efc5f2f021d16e1717f8b33a946fe5c5f.tar.gz
gentoo-2-3167ce5efc5f2f021d16e1717f8b33a946fe5c5f.tar.bz2
gentoo-2-3167ce5efc5f2f021d16e1717f8b33a946fe5c5f.zip
Fix missing playback icons (bug #509798), thanks to Philip L.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 84F20B43)
-rw-r--r--media-sound/gmpc/ChangeLog10
-rwxr-xr-xmedia-sound/gmpc/files/gmpc-11.8.16-icons.patch119
-rw-r--r--media-sound/gmpc/gmpc-11.8.16-r1.ebuild60
3 files changed, 187 insertions, 2 deletions
diff --git a/media-sound/gmpc/ChangeLog b/media-sound/gmpc/ChangeLog
index 3d0b4d8bcbcd..7e444462b5fc 100644
--- a/media-sound/gmpc/ChangeLog
+++ b/media-sound/gmpc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/gmpc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/ChangeLog,v 1.90 2013/05/11 17:56:43 angelos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/ChangeLog,v 1.91 2014/06/27 16:16:01 angelos Exp $
+
+*gmpc-11.8.16-r1 (27 Jun 2014)
+
+ 27 Jun 2014; Christoph Mende <angelos@gentoo.org>
+ +files/gmpc-11.8.16-icons.patch, +gmpc-11.8.16-r1.ebuild:
+ Fix missing playback icons (bug #509798), thanks to Philip L.
11 May 2013; Christoph Mende <angelos@gentoo.org> gmpc-11.8.16.ebuild:
Add gnome-doc-utils dependency (bug #469278), fix AM_CONFIG_HEADER failure
diff --git a/media-sound/gmpc/files/gmpc-11.8.16-icons.patch b/media-sound/gmpc/files/gmpc-11.8.16-icons.patch
new file mode 100755
index 000000000000..ea37effa9f74
--- /dev/null
+++ b/media-sound/gmpc/files/gmpc-11.8.16-icons.patch
@@ -0,0 +1,119 @@
+diff --git a/glade/playlist3.ui b/glade/playlist3.ui
+index fedb627..452f3ec 100644
+--- a/glade/playlist3.ui
++++ b/glade/playlist3.ui
+@@ -436,16 +436,17 @@
+ <child>
+ <object class="GtkButton" id="button_previous">
+ <property name="visible">True</property>
++ <property name="use_action_appearance">False</property>
+ <property name="related-action">MPDPrevious</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">False</property>
+ <property name="relief">none</property>
+ <property name="use_action_appearance">False</property>
+ <child>
+- <object class="GtkImage" id="image10">
++ <object class="GtkImage" id="button_previous_image">
+ <property name="visible">True</property>
+ <property name="stock">gtk-media-previous</property>
+- </object>
++ </object>
+ </child>
+ </object>
+ <packing>
+@@ -455,18 +456,18 @@
+ </packing>
+ </child>
+ <child>
+- <object class="GtkButton" id="top_button">
++ <object class="GtkButton" id="stop_button">
+ <property name="visible">True</property>
++ <property name="use_action_appearance">False</property>
+ <property name="related-action">MPDStop</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">True</property>
+ <property name="relief">none</property>
+- <property name="use_action_appearance">False</property>
+ <child>
+- <object class="GtkImage" id="stop_button_image">
++ <object class="GtkImage" id="button_stop_image">
+ <property name="visible">True</property>
+ <property name="stock">gtk-media-stop</property>
+- </object>
++ </object>
+ </child>
+ </object>
+ <packing>
+@@ -478,15 +479,16 @@
+ <child>
+ <object class="GtkButton" id="play_button">
+ <property name="visible">True</property>
++ <property name="use_action_appearance">False</property>
+ <property name="related-action">MPDPlayPause</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">False</property>
+ <property name="relief">none</property>
+ <child>
+- <object class="GtkImage" id="play_button_image">
++ <object class="GtkImage" id="play_button_image">
+ <property name="visible">True</property>
+ <property name="stock">gtk-media-play</property>
+- </object>
++ </object>
+ </child>
+ </object>
+ <packing>
+@@ -498,13 +500,13 @@
+ <child>
+ <object class="GtkButton" id="next_button">
+ <property name="visible">True</property>
++ <property name="use_action_appearance">False</property>
+ <property name="related-action">MPDNext</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">False</property>
+- <property name="use_action_appearance">False</property>
+ <property name="relief">none</property>
+ <child>
+- <object class="GtkImage" id="image11">
++ <object class="GtkImage" id="next_button_image">
+ <property name="visible">True</property>
+ <property name="stock">gtk-media-next</property>
+ </object>
+diff --git a/src/playlist3.c b/src/playlist3.c
+index 72b4ef7..3dac409 100644
+--- a/src/playlist3.c
++++ b/src/playlist3.c
+@@ -1632,7 +1632,8 @@ static void playlist_status_changed(MpdObj * mi, ChangedStatusType what, void *u
+ gtk_action_set_stock_id(GTK_ACTION(gtk_builder_get_object(pl3_xml, "MPDPlayPause")), "gtk-media-pause");
+ gtk_image_set_from_stock(GTK_IMAGE
+ (gtk_builder_get_object
+- (pl3_xml, "play_button_image")), "gtk-media-pause", GTK_ICON_SIZE_BUTTON);
++ (pl3_xml, "play_button_image")), "gtk-media-pause",
++ GTK_ICON_SIZE_MENU);
+
+ /**
+ * Update window title
+@@ -1669,8 +1670,8 @@ static void playlist_status_changed(MpdObj * mi, ChangedStatusType what, void *u
+ gtk_action_set_stock_id(GTK_ACTION(gtk_builder_get_object(pl3_xml, "MPDPlayPause")), "gtk-media-play");
+ gtk_image_set_from_stock(GTK_IMAGE
+ (gtk_builder_get_object
+- (pl3_xml, "play_button_image")), "gtk-media-play", GTK_ICON_SIZE_BUTTON);
+-
++ (pl3_xml, "play_button_image")), "gtk-media-play",
++ GTK_ICON_SIZE_MENU);
+ /**
+ * Set paused in Window string
+ */
+@@ -1704,8 +1705,8 @@ static void playlist_status_changed(MpdObj * mi, ChangedStatusType what, void *u
+
+ gtk_image_set_from_stock(GTK_IMAGE
+ (gtk_builder_get_object
+- (pl3_xml, "play_button_image")), "gtk-media-play", GTK_ICON_SIZE_BUTTON);
+-
++ (pl3_xml, "play_button_image")), "gtk-media-play",
++ GTK_ICON_SIZE_MENU);
+ if (gmpc_profiles_get_number_of_profiles(gmpc_profiles) > 1)
+ {
+ gchar *id = gmpc_profiles_get_current(gmpc_profiles);
+--
diff --git a/media-sound/gmpc/gmpc-11.8.16-r1.ebuild b/media-sound/gmpc/gmpc-11.8.16-r1.ebuild
new file mode 100644
index 000000000000..4197d875c129
--- /dev/null
+++ b/media-sound/gmpc/gmpc-11.8.16-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/gmpc-11.8.16-r1.ebuild,v 1.1 2014/06/27 16:16:01 angelos Exp $
+
+EAPI=4
+VALA_MIN_API_VERSION=0.12
+
+inherit autotools eutils gnome2-utils vala
+
+DESCRIPTION="A GTK+2 client for the Music Player Daemon"
+HOMEPAGE="http://gmpc.wikia.com/wiki/Gnome_Music_Player_Client"
+SRC_URI="http://download.sarine.nl/Programs/gmpc/11.8/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls xspf +unique"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2:2
+ >=media-libs/libmpd-11.8
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ x11-themes/hicolor-icon-theme
+ unique? ( dev-libs/libunique:1 )
+ xspf? ( >=media-libs/libxspf-1.2 )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/gnome-doc-utils
+ >=dev-util/gob-2.0.17
+ virtual/pkgconfig
+ nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlinking.patch \
+ "${FILESDIR}"/${P}-icons.patch
+ sed -i -e "s:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:" configure.ac || die
+ eautoreconf
+ vala_src_prepare
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-libspiff \
+ --disable-appindicator \
+ --enable-mmkeys \
+ $(use_enable nls) \
+ $(use_enable unique) \
+ $(use_enable xspf libxspf)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }