summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-12 18:54:05 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-12 18:54:05 +0000
commit315628cb0f29f57c975187177b2c94e3c2e0279b (patch)
tree554e64289402193804b369c925c963c5a289acc3
parentwork around buggy patch version (bug #336004); clean old (diff)
downloadgentoo-2-315628cb0f29f57c975187177b2c94e3c2e0279b.tar.gz
gentoo-2-315628cb0f29f57c975187177b2c94e3c2e0279b.tar.bz2
gentoo-2-315628cb0f29f57c975187177b2c94e3c2e0279b.zip
Version bump. Respect CC (bug #243516), LDFLAGS, CFLAGS. Do not strip. Remove pointless DEPEND.
(Portage version: 2.2_rc92/cvs/Linux i686)
-rw-r--r--app-benchmarks/cpuburn/ChangeLog11
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a.ebuild37
-rw-r--r--app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch7
3 files changed, 53 insertions, 2 deletions
diff --git a/app-benchmarks/cpuburn/ChangeLog b/app-benchmarks/cpuburn/ChangeLog
index a14165cd3d09..6c80d3c16b4a 100644
--- a/app-benchmarks/cpuburn/ChangeLog
+++ b/app-benchmarks/cpuburn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-benchmarks/cpuburn
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/ChangeLog,v 1.15 2009/10/12 19:02:05 halcy0n Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/ChangeLog,v 1.16 2010/10/12 18:54:05 jer Exp $
+
+*cpuburn-1.4a (12 Oct 2010)
+
+ 12 Oct 2010; Jeroen Roovers <jer@gentoo.org> +cpuburn-1.4a.ebuild,
+ +files/cpuburn-1.4a-flags.patch:
+ Version bump. Respect CC (bug #243516), LDFLAGS, CFLAGS. Do not strip.
+ Remove pointless DEPEND.
12 Oct 2009; Mark Loeser <halcy0n@gentoo.org> cpuburn-1.4.ebuild:
QA fixes; unquoted variables
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild
new file mode 100644
index 000000000000..d594482a4217
--- /dev/null
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild,v 1.1 2010/10/12 18:54:05 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P="${PV/./_}"
+DESCRIPTION="designed to heavily load CPU chips [testing purposes]"
+HOMEPAGE="http://pages.sbcglobal.net/redelm/"
+SRC_URI="http://pages.sbcglobal.net/redelm/cpuburn_${MY_P}_tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="amd64? ( >=app-emulation/emul-linux-x86-baselibs-1.0 )"
+
+src_unpack() {
+ # for some reason he has it _tar instead of .tar ...
+ unpack ${A}
+ tar -xf cpuburn_${MY_P}_tar || die
+}
+
+src_prepare() {
+cp -av Makefile{,.orig}
+ epatch "${FILESDIR}"/${P}-flags.patch
+ use amd64 && append-flags -m32 #65719
+ tc-export CC
+}
+
+src_install() {
+ dodoc Design README
+ dobin burn{BX,K6,K7,MMX,P5,P6} || die
+}
diff --git a/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch b/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch
new file mode 100644
index 000000000000..97b8836c0af4
--- /dev/null
+++ b/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch
@@ -0,0 +1,7 @@
+--- Makefile.orig 2001-06-16 05:39:17.000000000 +0200
++++ Makefile 2010-10-12 20:31:38.000000000 +0200
+@@ -1,3 +1,3 @@
+ all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
+ .S:
+- gcc -s -nostdlib -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -nostdlib -o $@ $<