summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2010-01-23 21:00:18 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2010-01-23 21:00:18 +0000
commit30997da6db5e11ec404e5d054b57288a71fc1647 (patch)
treef65da9115c06e98ed7a3825a4e46512f8fc3eaf6
parentKeyword ~amd64-linux/~x86-linux (diff)
downloadgentoo-2-30997da6db5e11ec404e5d054b57288a71fc1647.tar.gz
gentoo-2-30997da6db5e11ec404e5d054b57288a71fc1647.tar.bz2
gentoo-2-30997da6db5e11ec404e5d054b57288a71fc1647.zip
Removing obsolete version.
(Portage version: 2.1.6.13/cvs/Linux i686)
-rw-r--r--dev-lang/tinycobol/ChangeLog8
-rw-r--r--dev-lang/tinycobol/files/tinycobol-0.61.patch42
-rw-r--r--dev-lang/tinycobol/tinycobol-0.61.ebuild41
3 files changed, 6 insertions, 85 deletions
diff --git a/dev-lang/tinycobol/ChangeLog b/dev-lang/tinycobol/ChangeLog
index 6beef14369ea..14af8b8d3bba 100644
--- a/dev-lang/tinycobol/ChangeLog
+++ b/dev-lang/tinycobol/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tinycobol
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/ChangeLog,v 1.17 2009/08/29 18:12:58 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/ChangeLog,v 1.18 2010/01/23 21:00:17 phosphan Exp $
+
+ 23 Jan 2010; Patrick Kursawe <phosphan@gentoo.org> -tinycobol-0.61.ebuild,
+ -files/tinycobol-0.61.patch:
+ Removing obsolete version.
29 Aug 2009; nixnut <nixnut@gentoo.org> tinycobol-0.64.ebuild:
ppc stable #276396
diff --git a/dev-lang/tinycobol/files/tinycobol-0.61.patch b/dev-lang/tinycobol/files/tinycobol-0.61.patch
deleted file mode 100644
index e8d72d30dfc7..000000000000
--- a/dev-lang/tinycobol/files/tinycobol-0.61.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- configure.in 2003-02-07 16:35:14.000000000 +0100
-+++ configure.in.new 2003-05-12 12:43:24.000000000 +0200
-@@ -787,7 +787,7 @@
- #
- cobdir_default='${prefix}/share/htcobol'
- optfile_dir='${prefix}/share/htcobol'
--cobpp_dir='${prefix}/share/htcobol'
-+cobpp_dir='${prefix}/bin'
- cobcpy_default='${prefix}/share/htcobol/copybooks'
- #
- cobbin_default='${prefix}/bin'
---- configure 2003-05-12 12:44:37.000000000 +0200
-+++ configure.new 2003-05-12 12:45:33.000000000 +0200
-@@ -7312,7 +7312,7 @@
- #
- cobdir_default='${prefix}/share/htcobol'
- optfile_dir='${prefix}/share/htcobol'
--cobpp_dir='${prefix}/share/htcobol'
-+cobpp_dir='${prefix}/bin'
- cobcpy_default='${prefix}/share/htcobol/copybooks'
- #
- cobbin_default='${prefix}/bin'
---- htconfig.h.in 2003-02-07 16:35:14.000000000 +0100
-+++ htconfig.h.in.new 2003-05-12 13:24:10.000000000 +0200
-@@ -201,7 +201,7 @@
-
- /* Set the pre-processor (htcobolpp) paths */
- #define COBPP_NAME "htcobolpp"
--#define COBPP_PATH COBDIR_DEFAULT"/"COBPP_NAME
-+#define COBPP_PATH COBBIN_DEFAULT"/"COBPP_NAME
-
- /* Set the expand command path */
- #undef COBPP_EXPAND_CMD_PATH
---- cobpp/Makefile.in 2003-05-12 13:31:10.000000000 +0200
-+++ cobpp/Makefile.in.new 2003-05-12 13:30:57.000000000 +0200
-@@ -80,5 +80,5 @@
-
- install: $(PROG)
- strip $(PROG)
-- ${INSTALL} -m 755 $(PROG) $(INSTRC)/$(PROG)
-+ ${INSTALL} -m 755 $(PROG) $(INSTBIN)/$(PROG)
- # ${INSTALL_DATA} $(PROG) $(INSTRC)/$(PROG)
diff --git a/dev-lang/tinycobol/tinycobol-0.61.ebuild b/dev-lang/tinycobol/tinycobol-0.61.ebuild
deleted file mode 100644
index 44c7822f2908..000000000000
--- a/dev-lang/tinycobol/tinycobol-0.61.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.61.ebuild,v 1.8 2008/12/08 22:54:43 phosphan Exp $
-
-inherit eutils
-
-DESCRIPTION="COBOL for linux"
-HOMEPAGE="http://tiny-cobol.sourceforge.net/"
-SRC_URI="mirror://sourceforge/tiny-cobol/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-IUSE=""
-KEYWORDS="x86 ppc"
-
-DEPEND=">=dev-libs/glib-2.0
- sys-libs/db"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}.patch
-}
-
-src_compile() {
- econf || die
- make || die "make failed"
-}
-
-src_install() {
- dodir /usr/bin
- dodir /usr/man/man1
- dodir /usr/lib
- dodir /usr/share/htcobol
- make prefix="${D}/usr" install
- dodoc AUTHORS ChangeLog README STATUS
- cd "${D}"/usr/lib
- rm libhtcobol.so libhtcobol.so.0
- ln -s libhtcobol.so.0.* libhtcobol.so.0
- ln -s libhtcobol.so.0 libhtcobol.so
-}