summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2004-10-21 18:51:22 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2004-10-21 18:51:22 +0000
commit2ed4af31da14ca77f0f345e3945b81fcbf2f3d1e (patch)
tree2ba5ba771b923a81bd74785286697ce3ca2a6184
parentold patches (Manifest recommit) (diff)
downloadgentoo-2-2ed4af31da14ca77f0f345e3945b81fcbf2f3d1e.tar.gz
gentoo-2-2ed4af31da14ca77f0f345e3945b81fcbf2f3d1e.tar.bz2
gentoo-2-2ed4af31da14ca77f0f345e3945b81fcbf2f3d1e.zip
Added support for authentication using PostgreSQL.
-rw-r--r--net-mail/tpop3d/ChangeLog8
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.3-variable-name-clash.patch62
-rw-r--r--net-mail/tpop3d/tpop3d-1.5.3.ebuild19
3 files changed, 80 insertions, 9 deletions
diff --git a/net-mail/tpop3d/ChangeLog b/net-mail/tpop3d/ChangeLog
index fa8add1fe1df..b618a8c5301c 100644
--- a/net-mail/tpop3d/ChangeLog
+++ b/net-mail/tpop3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/tpop3d
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.14 2004/08/26 13:50:28 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.15 2004/10/21 18:51:22 griffon26 Exp $
+
+ 21 Oct 2004; Maurice van der Pot <griffon26@gentoo.org>
+ +files/tpop3d-1.5.3-variable-name-clash.patch, tpop3d-1.5.3.ebuild:
+ Added support for authentication using a PostgreSQL database to
+ ebuild as suggested by Lionel Bouton <lionel-dev@bouton.name> in
+ bug #68024.
26 Aug 2004; Maurice van der Pot <griffon26@gentoo.org>
+files/tpop3d-1.5.3-invalid-user-message.patch, tpop3d-1.5.3.ebuild:
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.3-variable-name-clash.patch b/net-mail/tpop3d/files/tpop3d-1.5.3-variable-name-clash.patch
new file mode 100644
index 000000000000..90af058d86d6
--- /dev/null
+++ b/net-mail/tpop3d/files/tpop3d-1.5.3-variable-name-clash.patch
@@ -0,0 +1,62 @@
+diff -urN tpop3d-1.5.3.org/auth_mysql.c tpop3d-1.5.3/auth_mysql.c
+--- tpop3d-1.5.3.org/auth_mysql.c 2004-08-19 23:51:19.751469352 +0200
++++ tpop3d-1.5.3/auth_mysql.c 2004-08-19 23:54:16.564589672 +0200
+@@ -44,7 +44,7 @@
+ * [2] unix user
+ * [3] mailbox type
+ */
+-char *user_pass_query_template =
++static char *user_pass_query_template =
+ "SELECT concat(domain.path, '/', popbox.mbox_name), popbox.password_hash, "
+ "domain.unix_user, 'bsd' "
+ "FROM popbox, domain "
+@@ -52,7 +52,7 @@
+ "AND popbox.domain_name = '$(domain)' "
+ "AND popbox.domain_name = domain.domain_name";
+
+-char *apop_query_template =
++static char *apop_query_template =
+ "SELECT concat(domain.path, '/', popbox.mbox_name), popbox.password_hash, "
+ "domain.unix_user, 'bsd' "
+ "FROM popbox, domain "
+@@ -60,7 +60,7 @@
+ "AND popbox.domain_name = '$(domain)' "
+ "AND popbox.domain_name = domain.domain_name";
+
+-char *onlogin_query_template = NULL;
++static char *onlogin_query_template = NULL;
+
+ /* GID used to access mail spool (if any). */
+ int use_gid;
+diff -urN tpop3d-1.5.3.org/auth_pgsql.c tpop3d-1.5.3/auth_pgsql.c
+--- tpop3d-1.5.3.org/auth_pgsql.c 2004-08-19 23:51:18.772618160 +0200
++++ tpop3d-1.5.3/auth_pgsql.c 2004-08-19 23:54:37.936340672 +0200
+@@ -105,7 +105,7 @@
+ * [2] unix user
+ * [3] mailbox type
+ */
+-char *user_pass_query_template =
++static char *user_pass_query_template =
+ "SELECT domain.path || '/' || popbox.mbox_name, popbox.password_hash, "
+ "domain.unix_user, 'bsd' "
+ "FROM popbox, domain "
+@@ -113,7 +113,7 @@
+ "AND popbox.domain_name = '$(domain)' "
+ "AND popbox.domain_name = domain.domain_name";
+
+-char *apop_query_template =
++static char *apop_query_template =
+ "SELECT domain.path || '/' || popbox.mbox_name, popbox.password_hash, "
+ "domain.unix_user, 'bsd' "
+ "FROM popbox, domain "
+@@ -121,7 +121,7 @@
+ "AND popbox.domain_name = '$(domain)' "
+ "AND popbox.domain_name = domain.domain_name";
+
+-char *onlogin_query_template = NULL;
++static char *onlogin_query_template = NULL;
+
+ /* GID used to access mail spool (if any). */
+ int use_gid;
+
+
diff --git a/net-mail/tpop3d/tpop3d-1.5.3.ebuild b/net-mail/tpop3d/tpop3d-1.5.3.ebuild
index 3f1e04b7f9b6..4ec3b7da5093 100644
--- a/net-mail/tpop3d/tpop3d-1.5.3.ebuild
+++ b/net-mail/tpop3d/tpop3d-1.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.5.3.ebuild,v 1.8 2004/08/26 13:50:28 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.5.3.ebuild,v 1.9 2004/10/21 18:51:22 griffon26 Exp $
inherit eutils
@@ -11,25 +11,28 @@ SRC_URI="http://www.ex-parrot.com/~chris/tpop3d/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-IUSE="ssl ldap mysql perl pam tcpd maildir debug"
+IUSE="ssl ldap mysql perl pam tcpd maildir debug postgres"
DEPEND="virtual/libc
- ssl? ( >=dev-libs/openssl-0.9.6 )
- ldap? ( >=net-nds/openldap-2.0.7 )
- mysql? ( >=dev-db/mysql-3.23.28 )
- perl? ( >=dev-lang/perl-5.6.1 )
- pam? ( >=sys-libs/pam-0.75 )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ mysql? ( >=dev-db/mysql-3.23.28 )
+ postgres? ( >=dev-db/postgresql-7.3 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ pam? ( >=sys-libs/pam-0.75 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
epatch ${FILESDIR}/${P}-invalid-user-message.patch
+ epatch ${FILESDIR}/${P}-variable-name-clash.patch
}
src_compile() {
local myconf
use mysql && myconf="--enable-auth-mysql"
+ use postgres && myconf="${myconf} --enable-auth-pgsql"
use ldap && myconf="${myconf} --enable-auth-ldap"
use perl && myconf="${myconf} --enable-auth-perl"
use tcpd && myconf="${myconf} --enable-tcp-wrappers"