summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-10-02 00:46:17 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-10-02 00:46:17 +0000
commit2da3c95f2abef0b90f502d6d21b6d7946dc7f6d6 (patch)
treeb5c6df1b4425886faf7cfec651d395034fa66878
parent>=net-im/twinkle-0.9 -segv for me- more testing (diff)
downloadgentoo-2-2da3c95f2abef0b90f502d6d21b6d7946dc7f6d6.tar.gz
gentoo-2-2da3c95f2abef0b90f502d6d21b6d7946dc7f6d6.tar.bz2
gentoo-2-2da3c95f2abef0b90f502d6d21b6d7946dc7f6d6.zip
version bump requested by genstef
(Portage version: 2.1.2_pre1-r2)
-rw-r--r--net-im/twinkle/ChangeLog7
-rw-r--r--net-im/twinkle/files/digest-twinkle-0.93
-rw-r--r--net-im/twinkle/twinkle-0.9.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/net-im/twinkle/ChangeLog b/net-im/twinkle/ChangeLog
index 04de10f9675d..74b1084c18bc 100644
--- a/net-im/twinkle/ChangeLog
+++ b/net-im/twinkle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/twinkle
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.18 2006/07/29 14:37:08 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.19 2006/10/02 00:46:17 dragonheart Exp $
+
+*twinkle-0.9 (02 Oct 2006)
+
+ 02 Oct 2006; Daniel Black <dragonheart@gentoo.org> +twinkle-0.9.ebuild:
+ version bump requested by genstef
29 Jul 2006; Daniel Black <dragonheart@gentoo.org> twinkle-0.8.ebuild,
twinkle-0.8.1.ebuild:
diff --git a/net-im/twinkle/files/digest-twinkle-0.9 b/net-im/twinkle/files/digest-twinkle-0.9
new file mode 100644
index 000000000000..0f87aa58bd88
--- /dev/null
+++ b/net-im/twinkle/files/digest-twinkle-0.9
@@ -0,0 +1,3 @@
+MD5 74ef85e9f4570cec10bd23d301f5549e twinkle-0.9.tar.gz 1012524
+RMD160 f6b8b70a9630687cf7f100c9dde888289d97f082 twinkle-0.9.tar.gz 1012524
+SHA256 22f536aaf6a7aa6870c31d03190b206509cfc8b6147c3af7080d6dbfa5a992b6 twinkle-0.9.tar.gz 1012524
diff --git a/net-im/twinkle/twinkle-0.9.ebuild b/net-im/twinkle/twinkle-0.9.ebuild
new file mode 100644
index 000000000000..b8720843ebc7
--- /dev/null
+++ b/net-im/twinkle/twinkle-0.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-0.9.ebuild,v 1.1 2006/10/02 00:46:17 dragonheart Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="a soft phone for your VOIP communcations using SIP"
+HOMEPAGE="http://www.twinklephone.com/"
+SRC_URI="http://www.xs4all.nl/~mfnboer/twinkle/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="arts speex ilbc zrtp"
+
+# Requires libqt-mt actually... Is that *always* built, or do we need to check?
+RDEPEND=">=net-libs/ccrtp-1.5.0
+ >=dev-cpp/commoncpp2-1.4.1
+ $(qt_min_version 3.3.0)
+ arts? ( kde-base/arts )
+ media-libs/libsndfile
+ dev-libs/boost
+ speex? ( media-libs/speex )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ zrtp? ( net-libs/libzrtpcpp )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.4.1-badcflags.patch
+}
+
+src_compile() {
+ econf \
+ $(use_with ilbc) \
+ $(use_with arts) \
+ $(use_with zrtp) \
+ $(use_with speex) || die 'Error: conf failed'
+ emake || die "Error: emake failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README THANKS
+}