summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Bouyer <stubear@gentoo.org>2002-07-10 14:18:04 +0000
committerStuart Bouyer <stubear@gentoo.org>2002-07-10 14:18:04 +0000
commit2c03a2df04a4bdd1d8ef0a476d279fb6e3c66c5a (patch)
treedf9836f935270bc08fcd56a678c35d1e7af26307
parentfixed header (diff)
downloadgentoo-2-2c03a2df04a4bdd1d8ef0a476d279fb6e3c66c5a.tar.gz
gentoo-2-2c03a2df04a4bdd1d8ef0a476d279fb6e3c66c5a.tar.bz2
gentoo-2-2c03a2df04a4bdd1d8ef0a476d279fb6e3c66c5a.zip
Initial ebuild for Kanjipad
-rw-r--r--app-i18n/kanjipad/files/digest-kanjipad-1.2.31
-rw-r--r--app-i18n/kanjipad/kanjipad-1.2.3.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-i18n/kanjipad/files/digest-kanjipad-1.2.3 b/app-i18n/kanjipad/files/digest-kanjipad-1.2.3
new file mode 100644
index 000000000000..d566151e5a5d
--- /dev/null
+++ b/app-i18n/kanjipad/files/digest-kanjipad-1.2.3
@@ -0,0 +1 @@
+MD5 acd3dea4186312817893c4aa97027d41 kanjipad-1.2.3.tar.gz 77173
diff --git a/app-i18n/kanjipad/kanjipad-1.2.3.ebuild b/app-i18n/kanjipad/kanjipad-1.2.3.ebuild
new file mode 100644
index 000000000000..50931795e44b
--- /dev/null
+++ b/app-i18n/kanjipad/kanjipad-1.2.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kanjipad/kanjipad-1.2.3.ebuild,v 1.1 2002/07/10 14:18:04 stubear Exp $
+
+KEYWORDS="x86"
+
+DESCRIPTION="Japanese handwriting recognition tool"
+
+HOMEPAGE="http://www.gtk.org/~otaylor/kanjipad/"
+
+LICENSE="GPL-2"
+
+DEPEND=">=gtk+-1.2.10-r8 >=glib-1.2.10-r4"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+SRC_URI="ftp://ftp.gtk.org/pub/users/otaylor/kanjipad/${P}.tar.gz"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
+# if you omit this line.
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # Most open-source packages use GNU autoconf for configuration.
+ # You should use something similar to the following lines to
+ # configure your package before compilation. The "|| die" portion
+ # at the end will stop the build process if the command fails.
+ # You should use this at the end of critical commands in the build
+ # process. (Hint: Most commands are critical, that is, the build
+ # process should abort if they aren't successful.)
+ #./configure \
+ # --host=${CHOST} \
+ # --prefix=/usr \
+ # --infodir=/usr/share/info \
+ # --mandir=/usr/share/man || die "./configure failed"
+ # Note the use of --infodir and --mandir, above. This is to make
+ # this package FHS 2.2-compliant. For more information, see
+ # http://www.pathname.com/fhs/
+
+ # emake (previously known as pmake) is a script that calls the
+ # standard GNU make with parallel building options for speedier
+ # builds (especially on SMP systems). Try emake first. It might
+ # not work for some packages, in which case you'll have to resort
+ # to normal "make".
+
+ # Edit Makefile to install in /usr
+ mv Makefile Makefile.orig
+ sed -e "s/PREFIX=\/usr\/local/PREFIX=\/usr/" Makefile.orig > Makefile
+
+ emake || die
+ #make || die
+}
+
+src_install () {
+ # You must *personally verify* that this trick doesn't install
+ # anything outside of DESTDIR; do this by reading and
+ # understanding the install part of the Makefiles.
+ #make DESTDIR=${D} install || die
+ # For Makefiles that don't make proper use of DESTDIR, setting
+ # prefix is often an alternative. However if you do this, then
+ # you also need to specify mandir and infodir, since they were
+ # passed to ./configure as absolute paths (overriding the prefix
+ # setting).
+ #make \
+ # prefix=${D}/usr \
+ # mandir=${D}/usr/share/man \
+ # infodir=${D}/usr/share/info \
+ # install || die
+ # Again, verify the Makefiles! We don't want anything falling
+ # outside of ${D}.
+
+ dobin kanjipad kpengine || die
+ dodir /usr/share/kanjipad || die
+ insinto /usr/share/kanjipad
+ doins jdata.dat || die
+}