summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-19 20:43:34 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-19 20:43:34 +0000
commit2ae3339dafcc9c353831377fa05ebd5fb9c189c9 (patch)
tree7e9ca1d17c9b1f2107a69135a08cdc5a429eac0b
parentUpdate to EAPI=4 to have USE=static depend on USE=static-libs of all the libr... (diff)
downloadgentoo-2-2ae3339dafcc9c353831377fa05ebd5fb9c189c9.tar.gz
gentoo-2-2ae3339dafcc9c353831377fa05ebd5fb9c189c9.tar.bz2
gentoo-2-2ae3339dafcc9c353831377fa05ebd5fb9c189c9.zip
Only show ecdsa key message when upgrading from older versions, and drop USE=pam warning wrt valid shells as people should know this #440568 by poletti.marco.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
-rw-r--r--net-misc/openssh/ChangeLog7
-rw-r--r--net-misc/openssh/openssh-6.1_p1.ebuild16
2 files changed, 12 insertions, 11 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 522c96551887..617ddb0c9cec 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.458 2012/11/19 20:41:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.459 2012/11/19 20:43:34 vapier Exp $
+
+ 19 Nov 2012; Mike Frysinger <vapier@gentoo.org> openssh-6.1_p1.ebuild:
+ Only show ecdsa key message when upgrading from older versions, and drop
+ USE=pam warning wrt valid shells as people should know this #440568 by
+ poletti.marco.
19 Nov 2012; Mike Frysinger <vapier@gentoo.org> openssh-6.1_p1.ebuild:
Update to EAPI=4 to have USE=static depend on USE=static-libs of all the
diff --git a/net-misc/openssh/openssh-6.1_p1.ebuild b/net-misc/openssh/openssh-6.1_p1.ebuild
index dc97fb7d4752..4547d4e756a1 100644
--- a/net-misc/openssh/openssh-6.1_p1.ebuild
+++ b/net-misc/openssh/openssh-6.1_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.1_p1.ebuild,v 1.7 2012/11/19 20:41:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.1_p1.ebuild,v 1.8 2012/11/19 20:43:34 vapier Exp $
EAPI="4"
inherit eutils user flag-o-matic multilib autotools pam systemd
@@ -277,17 +277,13 @@ pkg_preinst() {
}
pkg_postinst() {
- elog "Starting with openssh-5.8p1, the server will default to a newer key"
- elog "algorithm (ECDSA). You are encouraged to manually update your stored"
- elog "keys list as servers update theirs. See ssh-keyscan(1) for more info."
- echo
+ if has_version "<${CATEGORY}/${PN}-5.8_p1" ; then
+ elog "Starting with openssh-5.8p1, the server will default to a newer key"
+ elog "algorithm (ECDSA). You are encouraged to manually update your stored"
+ elog "keys list as servers update theirs. See ssh-keyscan(1) for more info."
+ fi
ewarn "Remember to merge your config files in /etc/ssh/ and then"
ewarn "reload sshd: '/etc/init.d/sshd reload'."
- if use pam ; then
- echo
- ewarn "Please be aware users need a valid shell in /etc/passwd"
- ewarn "in order to be allowed to login."
- fi
# This instruction is from the HPN webpage,
# Used for the server logging functionality
if [[ -n ${HPN_PATCH} ]] && use hpn ; then