summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-10-08 16:45:30 +0000
committerHanno Böck <hanno@gentoo.org>2009-10-08 16:45:30 +0000
commit2aa5426cf5a9cc6437dddcdc1521ffaccdf9e4af (patch)
tree912db6faaa9787172999084cbc49c18e5a7341ca
parentImport from the science overlay. Thanks François Bissey for his efforts. (diff)
downloadgentoo-2-2aa5426cf5a9cc6437dddcdc1521ffaccdf9e4af.tar.gz
gentoo-2-2aa5426cf5a9cc6437dddcdc1521ffaccdf9e4af.tar.bz2
gentoo-2-2aa5426cf5a9cc6437dddcdc1521ffaccdf9e4af.zip
efte: switch to cmake eclass
(Portage version: 2.2_rc44/cvs/Linux x86_64)
-rw-r--r--app-editors/efte/ChangeLog5
-rw-r--r--app-editors/efte/efte-1.0.ebuild26
2 files changed, 15 insertions, 16 deletions
diff --git a/app-editors/efte/ChangeLog b/app-editors/efte/ChangeLog
index 1aa752dec4fa..b22f54c9cdc2 100644
--- a/app-editors/efte/ChangeLog
+++ b/app-editors/efte/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/efte
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/ChangeLog,v 1.5 2009/07/20 22:15:41 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/ChangeLog,v 1.6 2009/10/08 16:45:30 hanno Exp $
+
+ 08 Oct 2009; Hanno Boeck <hanno@gentoo.org> efte-1.0.ebuild:
+ Switch to cmake eclass, fix #287597.
*efte-1.0 (20 Jul 2009)
diff --git a/app-editors/efte/efte-1.0.ebuild b/app-editors/efte/efte-1.0.ebuild
index a460fdeba0b9..873492ef7db3 100644
--- a/app-editors/efte/efte-1.0.ebuild
+++ b/app-editors/efte/efte-1.0.ebuild
@@ -1,10 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/efte-1.0.ebuild,v 1.1 2009/07/20 22:15:41 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/efte-1.0.ebuild,v 1.2 2009/10/08 16:45:30 hanno Exp $
+
+EAPI="2"
+
+inherit cmake-utils
DESCRIPTION="A fast text editor supporting folding, syntax highlighting, etc."
HOMEPAGE="http://efte.sourceforge.net"
-SRC_URI="http://downloads.sourceforge.net/${PN}/${P}.tar.bz2"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -19,20 +23,12 @@ RDEPEND="sys-libs/ncurses
x11-libs/libXau
media-fonts/font-misc-misc
)"
-DEPEND="${RDEPEND}
- dev-util/cmake"
+DEPEND="${RDEPEND}"
-src_compile() {
- cmake \
+src_configure() {
+ local mycmakeargs="
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_GPM=$(use gpm && echo ON || echo OFF) \
- -DBUILD_X=$(use X && echo ON || echo OFF) \
- ./
- emake || die "emake failed"
-
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ -DBUILD_X=$(use X && echo ON || echo OFF)"
+ cmake-utils_src_configure
}