summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-27 23:28:06 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-27 23:28:06 +0000
commit2a6afaeccfea745579bdb279adcd6e9e6cb43161 (patch)
treeb94c5a1e9f9b42987d66f5b17524ea1cbacca965
parentVersion bump (bug #346875 by Michael Orlitzky) and remove old. Remove unneces... (diff)
downloadgentoo-2-2a6afaeccfea745579bdb279adcd6e9e6cb43161.tar.gz
gentoo-2-2a6afaeccfea745579bdb279adcd6e9e6cb43161.tar.bz2
gentoo-2-2a6afaeccfea745579bdb279adcd6e9e6cb43161.zip
Revbump to optionally include identation patch
(Portage version: 2.1.9.24/cvs/Linux x86_64)
-rw-r--r--app-shells/fish/ChangeLog9
-rw-r--r--app-shells/fish/files/fish-1.23.1-fish_indent.patch33
-rw-r--r--app-shells/fish/fish-1.23.1-r1.ebuild65
3 files changed, 106 insertions, 1 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index 6e26d31770ac..6512c63a9bad 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/fish
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.47 2010/06/21 17:19:29 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.48 2010/11/27 23:28:06 xmw Exp $
+
+*fish-1.23.1-r1 (27 Nov 2010)
+
+ 27 Nov 2010; Michael Weber <xmw@gentoo.org> +fish-1.23.1-r1.ebuild,
+ +files/fish-1.23.1-fish_indent.patch:
+ Revbump to optionally include indentation patch from James Bowlin
+ <bowlin@mindspring.com> (bug 346509). Thanks
21 Jun 2010; Christian Faulhammer <fauli@gentoo.org> fish-1.23.1.ebuild:
stable x86, bug 319473
diff --git a/app-shells/fish/files/fish-1.23.1-fish_indent.patch b/app-shells/fish/files/fish-1.23.1-fish_indent.patch
new file mode 100644
index 000000000000..513978e8b5c0
--- /dev/null
+++ b/app-shells/fish/files/fish-1.23.1-fish_indent.patch
@@ -0,0 +1,33 @@
+--- orig/fish_indent.c 2010-11-23 02:34:55.000000000 -0700
++++ fish-1.23.1/fish_indent.c 2010-11-23 02:35:29.000000000 -0700
+
+
+@@ -171,23 +171,23 @@
+ case TOK_REDIRECT_IN:
+ case TOK_REDIRECT_FD:
+ {
+- sb_append( out, last );
++ /* sb_append( out, last ); */
+ switch( type )
+ {
+ case TOK_REDIRECT_OUT:
+- sb_append( out, L"> " );
++ sb_append( out, L" > " );
+ break;
+
+ case TOK_REDIRECT_APPEND:
+- sb_append( out, L">> " );
++ sb_append( out, L" >> " );
+ break;
+
+ case TOK_REDIRECT_IN:
+- sb_append( out, L"< " );
++ sb_append( out, L" < " );
+ break;
+
+ case TOK_REDIRECT_FD:
+- sb_append( out, L">& " );
++ sb_append( out, L" >& " );
+ break;
+
+ }
diff --git a/app-shells/fish/fish-1.23.1-r1.ebuild b/app-shells/fish/fish-1.23.1-r1.ebuild
new file mode 100644
index 000000000000..14e404ea4bad
--- /dev/null
+++ b/app-shells/fish/fish-1.23.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-1.23.1-r1.ebuild,v 1.1 2010/11/27 23:28:06 xmw Exp $
+
+EAPI="3"
+
+inherit base autotools eutils
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.org/"
+SRC_URI="http://fishshell.org/files/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="X vanilla"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bc
+ sys-devel/gettext
+ www-client/htmlview
+ X? ( x11-misc/xsel )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.23.0-glibc-2.8.patch"
+ "${FILESDIR}/${PN}-1.22.3-gettext.patch"
+ "${FILESDIR}/${P}-gentoo-alt.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+
+ if ! use vanilla ; then
+ epatch "${FILESDIR}"/${P}-fish_indent.patch
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --without-xsel \
+ --bindir="${EPREFIX}"/bin
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "To use ${PN} as your default shell, you need to add ${EPREFIX}/bin/${PN}"
+ elog "to ${EPREFIX}/etc/shells."
+ elog
+ ewarn "Many files moved to ${EROOT}usr/share/fish/completions from ${EROOT}etc/fish.d/."
+ ewarn "Delete everything in ${EROOT}etc/fish.d/ except fish_interactive.fish."
+ ewarn "Otherwise, fish won't notice updates to the installed files,"
+ ewarn "because the ones in /etc will override the new ones in /usr."
+ echo
+}