summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-11-19 10:53:57 +0000
committerHans de Graaff <graaff@gentoo.org>2011-11-19 10:53:57 +0000
commit2a50175b855bf14a64c031b684f44ddb56650376 (patch)
tree69eae6925a31840187b09b7ed88461ff466e8b28
parentFix bugs #390845 and #386127 (diff)
downloadgentoo-2-2a50175b855bf14a64c031b684f44ddb56650376.tar.gz
gentoo-2-2a50175b855bf14a64c031b684f44ddb56650376.tar.bz2
gentoo-2-2a50175b855bf14a64c031b684f44ddb56650376.zip
Version bump for Rails 3.0.11.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.11.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 0f8d5119474d..24fd9e4e84dd 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.156 2011/10/05 18:00:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.157 2011/11/19 10:53:57 graaff Exp $
+
+*activesupport-3.0.11 (19 Nov 2011)
+
+ 19 Nov 2011; Hans de Graaff <graaff@gentoo.org> +activesupport-3.0.11.ebuild:
+ Version bump for Rails 3.0.11.
05 Oct 2011; Hans de Graaff <graaff@gentoo.org> -activesupport-3.0.7.ebuild,
-activesupport-3.0.9.ebuild:
diff --git a/dev-ruby/activesupport/activesupport-3.0.11.ebuild b/dev-ruby/activesupport/activesupport-3.0.11.ebuild
new file mode 100644
index 000000000000..8ec9762babf4
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.0.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.11.ebuild,v 1.1 2011/11/19 10:53:57 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
+
+# libxml-ruby and nokogiri are not strictly needed, but there are tests
+# using this code.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}