summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-22 19:22:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-22 19:22:23 +0000
commit27c69bdf30a0234ec6d616213f5ddd69418e6851 (patch)
tree5fc58988d5761adef4ce8523409871b6f559d917
parentold (Manifest recommit) (diff)
downloadgentoo-2-27c69bdf30a0234ec6d616213f5ddd69418e6851.tar.gz
gentoo-2-27c69bdf30a0234ec6d616213f5ddd69418e6851.tar.bz2
gentoo-2-27c69bdf30a0234ec6d616213f5ddd69418e6851.zip
uclibctoolize
-rw-r--r--app-crypt/mhash/mhash-0.9.1.ebuild11
-rw-r--r--dev-libs/expat/expat-1.95.7-r1.ebuild6
-rw-r--r--dev-libs/expat/expat-1.95.7.ebuild6
3 files changed, 15 insertions, 8 deletions
diff --git a/app-crypt/mhash/mhash-0.9.1.ebuild b/app-crypt/mhash/mhash-0.9.1.ebuild
index 00937110fdaa..6cf0d7d0fcd9 100644
--- a/app-crypt/mhash/mhash-0.9.1.ebuild
+++ b/app-crypt/mhash/mhash-0.9.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.1.ebuild,v 1.6 2004/09/21 23:25:05 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.1.ebuild,v 1.7 2004/09/22 19:18:54 vapier Exp $
+
+inherit libtool
DESCRIPTION="library providing a uniform interface to a large number of hash algorithms"
HOMEPAGE="http://mhash.sourceforge.net/"
@@ -8,12 +10,17 @@ SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc alpha arm hppa amd64 ia64 s390 ~ppc-macos"
+KEYWORDS="alpha arm amd64 hppa ia64 ppc ~ppc-macos s390 sparc x86"
IUSE=""
DEPEND="virtual/libc"
RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ uclibctoolize
+}
+
src_compile() {
local myconf
myconf="--enable-static --enable-shared"
diff --git a/dev-libs/expat/expat-1.95.7-r1.ebuild b/dev-libs/expat/expat-1.95.7-r1.ebuild
index 755cb7f7467a..7b5010d72b3a 100644
--- a/dev-libs/expat/expat-1.95.7-r1.ebuild
+++ b/dev-libs/expat/expat-1.95.7-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.7-r1.ebuild,v 1.1 2004/09/09 06:29:14 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.7-r1.ebuild,v 1.2 2004/09/22 19:22:23 vapier Exp $
-inherit gnuconfig
+inherit gnuconfig libtool
DESCRIPTION="XML parsing libraries"
HOMEPAGE="http://expat.sourceforge.net/"
@@ -21,8 +21,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # Detect mips systems properly
gnuconfig_update
+ uclibctoolize
}
src_install() {
diff --git a/dev-libs/expat/expat-1.95.7.ebuild b/dev-libs/expat/expat-1.95.7.ebuild
index 08fde99889d5..955a9701f906 100644
--- a/dev-libs/expat/expat-1.95.7.ebuild
+++ b/dev-libs/expat/expat-1.95.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.7.ebuild,v 1.21 2004/09/19 08:00:43 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.7.ebuild,v 1.22 2004/09/22 19:22:23 vapier Exp $
-inherit gnuconfig
+inherit gnuconfig libtool
DESCRIPTION="XML parsing libraries"
HOMEPAGE="http://expat.sourceforge.net/"
@@ -18,8 +18,8 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd "${S}"
- # Detect mips systems properly
gnuconfig_update
+ uclibctoolize
}
src_install() {