summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-08-11 12:10:15 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-08-11 12:10:15 +0000
commit2672cd11a6623d1d2c26453a0ee81e7761ca5a52 (patch)
tree1faa7d8d6544dda75a366027c1e84bf19f8f20c6
parentMarked stable on amd64 as per bug 176297. (diff)
downloadgentoo-2-2672cd11a6623d1d2c26453a0ee81e7761ca5a52.tar.gz
gentoo-2-2672cd11a6623d1d2c26453a0ee81e7761ca5a52.tar.bz2
gentoo-2-2672cd11a6623d1d2c26453a0ee81e7761ca5a52.zip
Added an upstream patch to allow pwc-driven webcams to work again in Kopete. First part of fixing bug 187400.
(Portage version: 2.1.3.3)
-rw-r--r--kde-base/kopete/ChangeLog9
-rw-r--r--kde-base/kopete/files/digest-kopete-3.5.7-r16
-rw-r--r--kde-base/kopete/files/kopete-3.5.7-videodevice.patch22
-rw-r--r--kde-base/kopete/kopete-3.5.7-r1.ebuild130
4 files changed, 166 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index c9618ce903a6..e1cac427a673 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.121 2007/08/10 14:42:39 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.122 2007/08/11 12:10:15 philantrop Exp $
+
+*kopete-3.5.7-r1 (11 Aug 2007)
+
+ 11 Aug 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kopete-3.5.7-videodevice.patch, +kopete-3.5.7-r1.ebuild:
+ Added an upstream patch to allow pwc-driven webcams to work again in Kopete.
+ Fixes bug 187400.
10 Aug 2007; Christoph Mende <angelos@gentoo.org> kopete-3.5.7.ebuild:
Stable on amd64 wrt bug #176297
diff --git a/kde-base/kopete/files/digest-kopete-3.5.7-r1 b/kde-base/kopete/files/digest-kopete-3.5.7-r1
new file mode 100644
index 000000000000..ac045c99a7b9
--- /dev/null
+++ b/kde-base/kopete/files/digest-kopete-3.5.7-r1
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 d7f2a05a7e304b33128123c3f67ea636 kdenetwork-3.5.7.tar.bz2 9370098
+RMD160 85b2780b411f91afb7e2dd6670500c9046b8b591 kdenetwork-3.5.7.tar.bz2 9370098
+SHA256 979d93802693a76e2e4fc0f7bdd4c44bde48296f842619a2b59100d94346d596 kdenetwork-3.5.7.tar.bz2 9370098
diff --git a/kde-base/kopete/files/kopete-3.5.7-videodevice.patch b/kde-base/kopete/files/kopete-3.5.7-videodevice.patch
new file mode 100644
index 000000000000..50cb8a0f2d7b
--- /dev/null
+++ b/kde-base/kopete/files/kopete-3.5.7-videodevice.patch
@@ -0,0 +1,22 @@
+--- branches/KDE/3.5/kdenetwork/kopete/libkopete/avdevice/videodevice.cpp 2006/08/17 13:37:13 573903
++++ branches/KDE/3.5/kdenetwork/kopete/libkopete/avdevice/videodevice.cpp 2007/06/09 01:27:58 673109
+@@ -1604,7 +1604,8 @@
+ case VIDEO_PALETTE_RGB32 : return PIXELFORMAT_RGB32; break;
+ case VIDEO_PALETTE_YUYV : return PIXELFORMAT_YUYV; break;
+ case VIDEO_PALETTE_UYVY : return PIXELFORMAT_UYVY; break;
+- case VIDEO_PALETTE_YUV420 : return PIXELFORMAT_YUV420P; break;
++ case VIDEO_PALETTE_YUV420 :
++ case VIDEO_PALETTE_YUV420P : return PIXELFORMAT_YUV420P; break;
+ case VIDEO_PALETTE_YUV422P : return PIXELFORMAT_YUV422P; break;
+ }
+ break;
+@@ -1758,7 +1759,8 @@
+ case VIDEO_PALETTE_RGB32 : returnvalue = pixelFormatName(PIXELFORMAT_RGB32); break;
+ case VIDEO_PALETTE_YUYV : returnvalue = pixelFormatName(PIXELFORMAT_YUYV); break;
+ case VIDEO_PALETTE_UYVY : returnvalue = pixelFormatName(PIXELFORMAT_UYVY); break;
+- case VIDEO_PALETTE_YUV420 : returnvalue = pixelFormatName(PIXELFORMAT_YUV420P); break;
++ case VIDEO_PALETTE_YUV420 :
++ case VIDEO_PALETTE_YUV420P : returnvalue = pixelFormatName(PIXELFORMAT_YUV420P); break;
+ case VIDEO_PALETTE_YUV422P : returnvalue = pixelFormatName(PIXELFORMAT_YUV422P); break;
+ }
+ break;
diff --git a/kde-base/kopete/kopete-3.5.7-r1.ebuild b/kde-base/kopete/kopete-3.5.7-r1.ebuild
new file mode 100644
index 000000000000..ee352fe40a0e
--- /dev/null
+++ b/kde-base/kopete/kopete-3.5.7-r1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.7-r1.ebuild,v 1.1 2007/08/11 12:10:15 philantrop Exp $
+
+KMNAME=kdenetwork
+MAXKDEVER=$PV
+KM_DEPRANGE="3.5.0 $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="jingle sametime ssl xscreensaver slp kernel_linux latex crypt
+ winpopup sms irc yahoo gadu groupwise netmeeting statistics autoreplace
+ connectionstatus contactnotes translator webpresence texteffect highlight
+ alias autoreplace history nowlistening addbookmarks kdehiddenvisibility"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-1.0* )
+ jingle? (
+ >=media-libs/speex-1.1.6
+ dev-libs/expat
+ ~net-libs/ortp-0.7.1 )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ kernel_linux? ( virtual/opengl )
+ sms? ( app-mobilephone/gsmlib )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )
+ !kde-base/kdenetwork
+ latex? ( virtual/tetex
+ media-gfx/imagemagick )
+ crypt? ( app-crypt/gnupg )"
+# gnomemeeting is deprecated and ekiga is not yet ~ppc64
+# only needed for calling
+# netmeeting? ( net-im/gnomemeeting )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ x11-proto/videoproto
+ kernel_linux? ( x11-libs/libXv )
+ xscreensaver? ( x11-proto/scrnsaverproto )"
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+kopete_disable() {
+ einfo "Disabling $2 $1"
+ sed -i -e "s/$2//" "${S}/kopete/$1s/Makefile.am"
+}
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ epatch "${FILESDIR}/kopete-0.12_alpha1-xscreensaver.patch"
+
+ epatch "${FILESDIR}/${PN}-3.5.5-icqfix.patch"
+
+ epatch "${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch"
+
+ # Fixes bug 187400, pwc-driven webcams broken.
+ epatch "${FILESDIR}/${PN}-3.5.7-videodevice.patch"
+
+ use latex || kopete_disable plugin latex
+ use crypt || kopete_disable plugin cryptography
+ use netmeeting || kopete_disable plugin netmeeting
+ use statistics || kopete_disable plugin statistics
+ use autoreplace || kopete_disable plugin autoreplace
+ use connectionstatus || kopete_disable plugin connectionstatus
+ use contactnotes || kopete_disable plugin contactnotes
+ use translator || kopete_disable plugin translator
+ use webpresence || kopete_disable plugin webpresence
+ use texteffect || kopete_disable plugin texteffect
+ use highlight || kopete_disable plugin highlight
+ use alias || kopete_disable plugin alias
+ use addbookmarks || kopete_disable plugin addbookmarks
+ use history || kopete_disable plugin history
+ use nowlistening || kopete_disable plugin nowlistening
+
+ use winpopup || kopete_disable protocol winpopup
+ use gadu || kopete_disable protocol '\$(GADU)'
+ use irc || kopete_disable protocol irc
+ use groupwise || kopete_disable protocol groupwise
+ use yahoo || kopete_disable protocol yahoo
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ local myconf="$(use_enable jingle)
+ $(use_enable sametime sametime-plugin)
+ --without-xmms --without-external-libgadu
+ $(use_with xscreensaver) $(use_enable sms smsgsm)
+ $(use_enable debug testbed)"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ rm -f "${D}${KDEDIR}"/bin/{stun,relay}server
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ elog "If you would like to use Off-The-Record encryption, emerge net-im/kopete-otr."
+}